Why does my Windows 7 network file copy slow down or even stop / fail?


  • I've recently set up an HP Pavilion with Windows 7 Ultimate 64-bit.  My "old" computer is a Windows Vista Ultimate 32-bit desktop sitting on the same desk and connected to a small hub a few feet away (which connects to the company network).

    I've noticed that when I copy large files on the Windows 7 box the file transfer slows down dramatically during the file copy, and sometimes stops with an error.

    In all cases the file transfer starts out okay, running at a speed of around 10 MB according to the "details" display on the copy dialog.

    Then the rates steps down into the KB range over a minute or two and the rest of the file transfer runs at the greatly reduced speed.

    I suspect some kind of network throttling, but in 1-2 hours of searching I haven't found a solution.

    I would appreciate suggestions for settings to try and perhaps better terminology to use for my own searches.  I'm not running any media, so I don't think it should be QoS, and I'm not sure "throttling" is the best term for this slowdown, either.

    According to the HP Update program my drivers are up to date (NVIDIA nForce 10/100 Mbps Ethernet)

    Wayne Erfling
    Saturday, May 15, 2010 10:17 AM

All replies

  • Hi,


    I would like to confirm that does it copy slowly also between local hard drives?


    I would like to suggest you update the BIOS and the chipset drivers manually from NVIDIA website to test the issue.


    If it does not work, you can try to disable Receive-side scaling for NVIDIA nForce network controller to check the result. Follow these steps:

    1.    Click the Start button, type Devmgmt.msc into Search bar and press Enter to open Device Manager.

    2.    Look under the Network adapters node, right click on the NVIDIA nForce network controller and click Properties.

    3.    Click the Advanced tab, highlight Receive side scaling under Property list and select Disable under Value list.

    4.    Click OK.



    Arthur Li - MSFT
    Monday, May 17, 2010 7:39 AM
  • Thanks very much for your REPLY.

    1) Making a copy of a file on my hard drive does report a slowdown, but not nearly as bad as over the network.  A copy of a 4GB file slowed down from perhaps 35 MB / second to 25 MB per second.

    2) As far as I can tell, I already have the latest drivers.  When I downloaded a driver file from NVidia, the NVidia setup program only offerred me a storage driver, and when I tried to replace the driver from the Windows Device Manager it told me either that the driver was up to date or (when I tried to force the issue with Have Disk...) that it could not verify the driver.   So I didn't proceed any further.

    3) The NVidia nForce network controller "Advanced" dialog does NOT include the item "Receive side scaling", so there was nothing for me to try.  Just the usual flow control, negotiation, etc.

    I'm still looking for a solution to this issue.  In fact, both machines have 100MB connections and are running through a gigabit hub, so my network file copies should have run faster than 10MB, which is only the maximum speed before the connection slows down.

    Additional information on the NVidia driver download: based on the PNP string I see in Windows I selected a driver that appeared to cover the series product I have (680), though the NVidia site is clearly not oriented towards their networking drivers.  The file I selected was 15.53_nforce_win7_64bit_international_whql.exe.

    Wayne Erfling
    Friday, May 21, 2010 3:57 PM
  • Thank you for this tip.

    I had been having failed network transfers between Win7 and Server 2008 (R2). This completely fixed the problem. The failed transfers were happening only with a large file, 20MB or more. The file transfer would just be stuck on "Calculating". Canceling the the transfer would take hours, then forcing the cancel would crash explorer.

    The other major issue: using roaming profiles on my domain, when users would log off the PC would hang on teh Logging Off screen.... forever. They would power off teh PC, and in some cases lose data that should have been synced between their local and server copy profile.


    Thanks again for this tip. I had been losing sleep over this issue, worrying that my users were going to lose more data.

    Monday, December 20, 2010 1:44 PM
  • Hi Cornan,

    I was reading Arthurs reply and your reply to it. Can I ask, did you try a local file copy on both machines to check the HDD speed/function? I guess a slow HDD read/write speed on either machine could be a potential cause of the slowdown. Otherwise it could signal network issues. Also have you tried copying files to/from other computers on your company network?



    Cathal O'Brien BSc, PgDip, PhD
    Tuesday, March 08, 2011 11:14 PM
  • It might be late now but this might help you:

    I have reliazed that there is a setting in the network cards that if not set to "Auto" will cause slow download speed from local network and also freezes the machine when downloading large files:

    Depending on the network card

    --> Network and Sharing Center --> Change Adapter Settings --> Configure --> Double click on the Active connection name --> Properties --> Configure --> Link Speed --> Speed and Duplex has to be set as "Auto Negotiation"

    Thursday, November 01, 2012 10:02 PM
  • Remove IPv6 from network properties.

    If your internal or external networks do not  require  IPv6 protocol, better remove it under network connection properties. Keeping IPv6 in your computer sometimes slows down network by trying to register IPv6 addresses, or trying to get IPv6 address, or trying to resolve IPv6. Better remove it if it’s not required.

    Monday, February 25, 2013 3:18 PM