none
Disabling Welcome Screen style logon RRS feed

  • Question

  • Hi .. I am trying to setup Windows 7 professional to have a login screen similiar to the XP classic login.  By this I mean it presents a box displaying the previous login name (allowing the user to change it if required) and an empty box to enter the password.  In XP I could simply uncheck the option 'Use the Welcome Screen' in the User Account screen.

    When I install the machine I have to create 3-4 users + activate the administrator account + create a corporate administrator account.  By default at login time all these accounts are visible and displayed as icons.  This provides anyone at the console a full list of acounts that they can try to use.

    'Hiding' the accounts as 'special accounts' is not an option as they are used fairly frequently.

    I can remove this list by using secpol.msc and enabling the "Interactive Logon: Hide last user..." option and it is close to the classic xp login but this also removes the name of the last user that logged in forcing the user to retype it.

    A previous thread 'Hide User Accounts on Windows 7 Logon' does not help me help.

    Any help would be appreciated.

    Rick

    Wednesday, January 20, 2010 3:16 PM

Answers

  • With Vista, MS replace the old MSGINA, so you can't have the old logon back.

    You can only set the option, not to show the last loggon username, so you have to enter the username and the password.

    [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName = 1

    But you still have the Welcome Screen View.

    André
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Proposed as answer by Andre.Ziegler Wednesday, January 20, 2010 3:54 PM
    • Marked as answer by Linda Yan Friday, January 22, 2010 6:59 AM
    Wednesday, January 20, 2010 3:54 PM

All replies

  • With Vista, MS replace the old MSGINA, so you can't have the old logon back.

    You can only set the option, not to show the last loggon username, so you have to enter the username and the password.

    [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName = 1

    But you still have the Welcome Screen View.

    André
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Proposed as answer by Andre.Ziegler Wednesday, January 20, 2010 3:54 PM
    • Marked as answer by Linda Yan Friday, January 22, 2010 6:59 AM
    Wednesday, January 20, 2010 3:54 PM
  • As Andre stated there is no way to get the classic login screen back which means you are stuck with the Welcome screen. You can also add a GPO that specifies the default domain to which users logon to ease logins as sometimes users by mitsakte are trying to login to the local machine rather than the domain. The GPO setting is found in Computer configuration > Administrative templates > System Logon and is named "Assign a default domain for logon".
    Wednesday, January 20, 2010 4:02 PM