How to Sync System Clock with Internet Time in Windows 7?


All replies

  • Is the service "Windows Time" (W32Time) running? Can you check this under the services MMC snapin.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Wednesday, January 19, 2011 2:32 PM
  • The tab might be missing because your computer is part of a domain.


    Wednesday, January 19, 2011 11:48 PM
  • Yes, the tab won't be available if your machine is part of a domain (see for details).

    However, you can configure a client computer for automatic domain time synchronization as described in the following article:

    Hope this helps.


    Thursday, January 20, 2011 2:39 AM
  • The note at the bottom of the first link from Alex Verboon has the following, which worked on my Domain-associated Windows 7 system:

    Synchronizing with an Internet time server

    You can synchronize your computer clock with an Internet time server. This means that the clock on your computer is updated to match the clock on the time server, which can help ensure that the clock on your computer is accurate. Your clock is typically updated once a week and needs to be connected to the Internet for the synchronization to occur.


    If your computer is on a domain, you can't synchronize your clock with an Internet time server.

    Open Date and Time by clicking the Start button, clicking Control Panel, clicking Clock, Language, and Region, and then clicking Date and Time.
    Click the Internet Time tab, and then click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    Click Automatically synchronize with an Internet time server, select a time server, and then click OK.

    Friday, August 09, 2013 1:39 PM
    • If your computer is on a domain, you can't synchronize your clock with an Internet time server.

    i notice when the computer that is on a domain, connects to a external internet cable, the internet server tab appears. (im not talking about leaving the domain workgroup, just switching of cables)

    is this common or a bug? is there a way to fix it? or to force it to be always automatically syncing with internet server as long as it leaves the domain network. 

    Wednesday, April 09, 2014 7:33 AM