none
Disable Photo Viewer in Windows 7

    Question

  • I want to DISABLE windows photo viewer.

    I have already associated the picture types to programs I use and they come up fine.  When I print, the photo viewer comes up and am FORCED to print from that program.  The problem is, that it is not working - the colors are inverted and incorrect.  All attempts to fix them in color management have failed. 

    Tuesday, November 16, 2010 7:20 PM

Answers

  • Hi,

     

    Thanks for the post!

     

    I suggest you change the default program for that types of picture.

     

    Click Start - input default programs in search bar -  set your default programs – Windows Photo Viewer – Choose defaults for this program, do not select the type that you want to print.

     

    If it doesn’t work, please try to remove the preview by modifying the registry. Please backup the registry before you modify it.

     

    Click Stat – input Regedit in search bar, navigate to  HKEY_CLASSES_ROOT/SystemFileAssociations/image/ShellEx/ContexMenuHandles

    Then delete the key ShellImagePreview.

     

    Regards,

    Miya

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 18, 2010 8:05 AM
    Moderator

All replies

  • Hi,

     

    Thanks for the post!

     

    I suggest you change the default program for that types of picture.

     

    Click Start - input default programs in search bar -  set your default programs – Windows Photo Viewer – Choose defaults for this program, do not select the type that you want to print.

     

    If it doesn’t work, please try to remove the preview by modifying the registry. Please backup the registry before you modify it.

     

    Click Stat – input Regedit in search bar, navigate to  HKEY_CLASSES_ROOT/SystemFileAssociations/image/ShellEx/ContexMenuHandles

    Then delete the key ShellImagePreview.

     

    Regards,

    Miya

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 18, 2010 8:05 AM
    Moderator
  • Greetings, all.

    I'm also running W7 and I also wish very much to remove WPV.  Miya, I've seen your registry solution in this and other forums, and have tried it.  But in my machine @ ContexMenuHandles I see no ShellImagePreview.  In that location is only a folder named "Play To."

    I must be close to success. Perhaps you can help?

    Thanks in advance.

    Sunday, February 06, 2011 6:03 PM
  • Greetings, all.

    I'm also running W7 and I also wish very much to remove WPV.  Miya, I've seen your registry solution in this and other forums, and have tried it.  But in my machine @ ContexMenuHandles I see no ShellImagePreview.  In that location is only a folder named "Play To."

    I must be close to success. Perhaps you can help?

    Thanks in advance.

    I have EXACTLy the same problem - there is so much old and useless info on the web on this subject. There is no SHELLIMAGEPREVIEW on my 64-bit Windows 7 machine - and the defaults are already set to associate images with FASTSTONE - but no matter what I do - when looking at files on a memory stick - the absolutely AWFUL Windows Photo Viewer comes up - you can't even ROTATE images never mind tart them up. I need to remove this program utterly from my PC - can anyone out there help?
    Wednesday, April 20, 2011 4:10 PM
  • If you have solved this. please post the solution. There must be wooden stake somewhere . . . sinbad
    Tuesday, May 31, 2011 5:39 PM
  • By scanning through my 64bit system registry I found (and deleted) the ShellEx\ContextMenuHandlers

    ShellImagePreview keys for all the image related files under HKEY_CLASSES_ROOT.

    I now only have the Set as desktop background entry in my context menu for images.

    .bmp
    .dib
    .gif
    .ico
    .jfif
    .jpe
    .jpeg
    .jpg
    .png
    .rle
    .tif
    .tiff
    .wdp

    Those were the only entries I found. Whether this bit sticks or not I've yet to find out but XnView as my main

    quick image viewer has not lost the control since doing this.
    Well That's My Two-penneth Worth
    Tuesday, August 16, 2011 1:07 AM
  • XnView is my main viewer as well,,, I've set jpg's to it countless times in the set default app via the "open With" contex menu..  Some work correctly and open in XnView other jpg's continue to be opened this worthless piece of code.

    IS there no way to just KILL it and have it stay down.??

    Monday, October 17, 2011 2:56 PM
  • GDawg2k2, are you sure that those other JPGs aren't in fact image files with a different extension (possibly even .jpeg or .jpe instead of .jpg)?
    Tim De Baets
    http://www.bm-productions.tk
    Friday, October 21, 2011 7:21 PM
  • Miya, I just backed up and saved an export of ShellImagePreview and then deleted the pesky rodent from my Windows 7 Ultimate 64bit registry. I hope this solves my constant bluescreen problems.

    • Edited by SIObserver Thursday, February 16, 2012 10:51 PM
    Thursday, February 16, 2012 10:51 PM
  • There is an ongoing discussion at the XnView website forum where the author acknowledges file associations aren't sticking, and he's indicating an update will be forthcoming.

    I see great value in doing the research on these 3rd party tools FIRST, you may not like the default viewer (which provides a menu to open the file under properly associated programs) but in this case the associations aren't sticking due to an oversight by the 3rd party vendor.

    DAS

    Friday, February 17, 2012 3:57 PM
  • Has anyone resolved this problem with Windows 7?

    I don't understand.

    I hook up my camera (via USB); can see the images as thumbnails in Explorer (although no Explorer menu in this case); prior to them displaying as such there are IrfanView logos in their place; they tell me that they are IrfanView JPG Files but, instead, Photo Viewer is invoked upon selection.

    Why?

    Sunday, May 27, 2012 8:24 AM
  • Gluepack: what exactly do you mean with "no Explorer menu in this case"?

    Do you get the same behavior when copying the images locally to the hard drive first and then double-clicking the local copies? What's the file extension of the images?


    Tim De Baets
    http://www.bm-productions.tk

    • Proposed as answer by nmehr Monday, May 20, 2013 9:08 AM
    Wednesday, May 30, 2012 7:27 PM
  • Мия вы о каком виндовсе говорите в 7 такое не проходит...

    Friday, December 07, 2012 7:21 PM
  • Hi,

    Thanks for the post!

    I suggest you change the default program for that types of picture.

    Click Start - input default programs in search bar -  set your default programs – Windows Photo Viewer – Choose defaults for this program, do not select the type that you want to print.

    If it doesn’t work, please try to remove the preview by modifying the registry. Please backup the registry before you modify it.

    Click Stat – input Regedit in search bar, navigate to  HKEY_CLASSES_ROOT/SystemFileAssociations/image/ShellEx/ContexMenuHandles

    Then delete the key ShellImagePreview.

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    i dont have shellimagepreview in image .just i have play to

    how can i disable phto viewer ????????????????

    Monday, May 20, 2013 9:11 AM