none
Windows Security Centre cant start / Windows Defender

    Question

  • hello

     

    I have had a look through the other posts with the same problem, but their fixes are NOT working for me.

    If I click start, search services, find security centre / windows defender and turn them to automatic & click start. They will after a few seconds both be off again.

    This all started after I downloaded something, when I double clicked the .exe it vanished, turned out to be a fake and not what I was after.

    Also I am not sure if this is down to the same virus/malware. If I search for something on google (using chrome), i select a link and it takes me to a random website. I do not have this problem in IE9 (chrome is my default browser)

    I have ran the following checks and saved the logs from this link:http://social.technet.microsoft.com/Forums/en-US/itprovistasecurity/thread/10174062-410d-4ad4-9e0f-75bc7b3fc686

    The logs can be found here: http://dl.dropbox.com/u/22641734/logs.zip

    I have also ran command prompt and ' sfc / scannow ' windows displayed the following message : "Windows Resource Protection did not find any integrity violations"

    I have downlaoded avg free, malwarebyes free & spy bot. They did find infections and fixed them, but my problem still remains.

    Any ideas on how I can fix this?

    Windows 7 Professional 64Bit
    • Edited by Gurraj Singh Thursday, July 14, 2011 11:22 PM adding details
    Thursday, July 14, 2011 11:17 PM

All replies

  • Have you try running a scan in safe mode? Try using avast & MSE, remember to run it in safe mode. If the problem still occurs after the scan, suggest you to reinstall windows defender or alternatively install MSE instead.

    If all fails after trying the above, last resort is to repair windows


    Friday, July 15, 2011 7:42 AM
    Answerer
  • Hi Daniel.

    I ran avg free / superantispyware / malwarebytes in safe mode (run as administrator)

    I just attempted to re-download windows defender, upon install I was prompted that Windows Vista comes with Windows Defender at that I do not need to install this. (I am using Windows 7 Professional 64bit)

    I have just downloaded Microsoft Security Essentials and its running now... Hopefully this one does re-install.

    Before this problem, all I had was Microsoft Security Essentials / Windows Defender / Windows Firewall and every thing was fine.

     

    Ok it hasnt worked.

     

    MSE - "The Security Essentials Upgrade Installation Wizzard encountered a problem while installing..."

    Upgrade Error. An error has prevented the Security Essentials Upgrade Wizard from continuing. The previous version of SE was restored.

    Error code :0x80070643


    /Gurraj Singh
    Friday, July 15, 2011 11:04 AM
  • Hmm, has you try system restore by right clicking computer and choose properties>advanced system settings>system protection tab, next under system restore, click on system restore tab, and hit next till you see the following as in "restore your computer to the state it was in before the selected event" at the lower portion there a check box which say shows more restore points, checked on it and if there's any restore point option, select it and hit next

    Btw i ask you to download avast but it seem that you hasn't did so? Try downloading the free avast home edition and next copy it onto a thumb drive, once done boot into safe mode and run setup follow by scan

    Following are the download link for avast free

    Friday, July 15, 2011 11:37 AM
    Answerer
  • I have downloaded avast free, I am in the process of installing it.

    With the system restore, I followed the directions, however I have found that it was off. I have not turned this off myself.

    I am going to run a scan with avast in safe mode, as administrator. If this doesn't work I will try my Windows7 Repair disc that I made. How ever this was made on the 28th of Octoboer 2009. Would this erase any documents/photos/videos/software from the computer?

     

     


    /Gurraj Singh
    Friday, July 15, 2011 11:50 AM
  • I have downloaded avast free, I am in the process of installing it.

    With the system restore, I followed the directions, however I have found that it was off. I have not turned this off myself.

    I am going to run a scan with avast in safe mode, as administrator. If this doesn't work I will try my Windows7 Repair disc that I made. How ever this was made on the 28th of Octoboer 2009. Would this erase any documents/photos/videos/software from the computer?

     

     


    /Gurraj Singh


    I doubt it would erase any doc and stuff so long is from the same version of windows 7 which you had on your rig, alternatively you could also use your original win 7 CD to do a repair. To be on the safe side, backup your stuff and once the repair is completed have it restore

    Following are the step for repairing win 7, take note prior to repairing windows 7, you would need to access cmos setup in bios and set the first bootable device to cd/dvd drive, next save before you exit cmos setup and with the win 7 dvd or repair disk on the drive, restart your comp, once you see the prompt hit any key, just did as what it says

    Linked

    Friday, July 15, 2011 12:01 PM
    Answerer
  • On Fri, 15 Jul 2011 11:04:57 +0000, Gurraj Singh wrote:

    Hi Daniel.

    I ran avg free / superantispyware / malwarebytes in safe mode (run as administrator)

    I just attempted to re-download windows defender, upon install I was prompted that Windows Vista comes with Windows Defender at that I do not need to install this. (I am using Windows 7 Professional 64bit)

    I have just downloaded Microsoft Security Essentials and its running now... Hopefully this one does re-install.

    Before this problem, all I had was Microsoft Security Essentials / Windows Defender / Windows Firewall and every thing was fine.

    You never has Microsoft Security Essentials and Defender. Microsoft
    Security Essentials, AVG, Norton, and McAfee (and perhaps others) all
    turn off Defender. That's good, not bad. Not only is there potential
    conflict, but there's no reason to have both; they all essentially
    have something very similar to Defender built into them, and running
    both at once will hurt your performance and create the risk of
    problems as they conflict with each other.

    For an anti-virus program, I recommend eSet NOD32, if you are willing
    to pay for it. If you want a free anti-virus, I recommend one (do not
    run more than one) of the following three:
     
    Avira AntiVir
    Avast
    Microsoft Security Essentials
     
    You also need anti-spyware software (even if you run a program like
    Microsoft Security Essentials, with anti-spyware capability built into
    it). I recommend that you download and
    install (freeware) MalwareBytes AntiMalware


    Ken Blake, Microsoft MVP
    Friday, July 15, 2011 3:24 PM
  • hello

    I have now only got Avast & MalwareBytes installed.

    I have performed checks with each as administrator in safe mode (one at a time, restart in between)

     

    Both cant find anything on the pc, shows the pc as being "clean"

     

    Yet still when I start MSE (via start - services) it turns off automatically. (MSE didnt start in guest)

     

    When searching in google (IE or Chrome) clicking on links take me to random websites. (This happens on the guest account too)

     

    I also have the flag in the bottom right from action centre that I cant seem to turn off now that I am only using Avast & MalwareBytes

     

    Any ideas, thank you for your help so far guys, much appriciated.


    /Gurraj Singh
    Saturday, July 16, 2011 6:27 PM
  • If it linked you to random website chances that your pc is infected with spyware or virus. Since you can't get it to be remove, why not repair windows7 as mention earlier on or back up your data prior to reinstalling win 7?

    Sunday, July 17, 2011 2:28 AM
    Answerer
  • I was going to run another check with each program in safe mode, when I realised on the same screen for choosing which safe mode you want to go into there was an option to repair windows.

    Clicked that and saw a date from last week. Which I was not able to get to from in Windows.

    I have done the restore, resinstalled avast & malwarebytes. Turned off defender and MSE.

     

    No problems so far, I hope its all gone and not hiding anywhere. Otherwise I'll have to do a complete format and reinstall.

    Really dont like the idea of setting each different bit in windows / programs up again.

     

    Thanks for your help though guys, much appreciated!


    /Gurraj Singh
    Tuesday, July 19, 2011 5:22 PM
  • I was going to run another check with each program in safe mode, when I realised on the same screen for choosing which safe mode you want to go into there was an option to repair windows.

    Clicked that and saw a date from last week. Which I was not able to get to from in Windows.

    I have done the restore, resinstalled avast & malwarebytes. Turned off defender and MSE.

     

    No problems so far, I hope its all gone and not hiding anywhere. Otherwise I'll have to do a complete format and reinstall.

    Really dont like the idea of setting each different bit in windows / programs up again.

     

    Thanks for your help though guys, much appreciated!


    /Gurraj Singh
    Tuesday, July 19, 2011 5:22 PM
  • Microsoft Security Essentials, AVG, Norton, and McAfee (and perhaps others) all
    turn off Defender. That's good, not bad.

     

     


     

    Ken Blake, Microsoft MVP


    Ken, I've seen you this posted several times. While I can't say for certain that one of the above programs DON'T turn off Defender, I can tell you that I have a computer running Windows 7, McAfee, AND Windows Defender. Maybe WD isn't needed with the aforementioned antivirus programs but it can and does run with McAfee so I think your answer is a little misleading.

    I also have a computer that was recently infected by a rootkit. After getting rid of it I realized that my Windows Defender service is gone. It doesn't appear in the list of services when I run service.msc.

    Friday, December 16, 2011 3:20 PM