none
BOOTMGR missing after deploying a custom image

    Question

  • Hello

     

    I'm stuck. I followed the "Deploying Vista Step by Step Guide". As a server I've used Vista Ultimate. Then I installed a target machine using autounattend file and Vista CD.  

    Run sysprep (Sysprep.exe /oobe /generalize /shutdown). I created PE, captured an Image from target machine to a network share (z:\Tools\Imagex.exe /compress fast /capture C: z:\\Myimage.wim "my Vista Install" /verify).

    Image was created successfully. I booted target machine with PE and created partition with diskpart:

     

    diskpart

    select disk 0

    clean

    create partition primary size=40000

    select partition 1

    active

    format

    exit

     

    Next I dropped an image (z:\tools\imagex.exe /apply z:\myimage.wim 1 c:

    As this far everything has gone as planned. But when dropping an image there are quite a lot of this kind of text:

     

    [INFO] c:\windows\system32\config\systemprofile\AppData\LoaclLow\desktop.in [Restore Sec. Descriptor: <seq. 25> -> SACL is going away <acecount ==1>] <GLE = 0>

     

    I get quit a lot of those but those are only INFO so does it matter? What causes those INFO messages?

     

    After image has dropped completely I boot the target machine resulting BOOTMGR is missing. Press Ctrl + alt + del to restart.

     

    I tried to find answer everywhere but without any success... 

     

    Wednesday, February 21, 2007 9:09 AM

All replies

  • First, the SACL message is a known issue. It is benign and ignorable. It should have nothing to do with the bootmgr missing error.

    for bootmgr error, could you try runing "bootsect /nt60 <drive letter>" on the target drive, to see if it can boot? Also, make sure c:\bootmgr file exists.

    thanks.

     

    Thursday, February 22, 2007 9:43 PM
  • I'm running into this problem as well, installing vista on my machine. When I leave the vista DVD in the machine to boot it up, it boots up fine into the OS. It is a nuisance, leaving the disc in. It's as though the BOOTMGR file isn't on the harddrive, but is on the disc, as I found it using search. I believe I may be able to put this file on the harddrive manually, but I don't know where it would go, can someone help me?
    Saturday, February 24, 2007 4:13 AM
  • sorry for the double post, but I found the bootmgr file in the Windows files and tried copying it from the disc, but it didn't work. whenever I try to boot the machine up without the disc in, it says bootmgr missing, press CTRL+ALT+DEL to restart. I then restart and leave the Windows Vista install disc in, and it boots up fine. Once the OS boots up, I can remove the disc, and it runs fine, as it is now. This is a real nuisance, but I can live with it, for now... does anyone know a fix??? I'd like to have my OS working properly!!!
    Saturday, February 24, 2007 4:32 AM
  • Well, this is my third post, and I've answered my own question, and hopefully the question of anyone else who runs into this problem. The answer was simple. I simply copied and pasted the entirety of my boot disc onto my C:drive, not changing any file locations, especially the location of BOOTMGR which needs to have the path C:\\BOOTMGR. I then restarted and the computer told me my system had been damaged, and automatically booted into the Vista Setup, as though I was going to reinstall it, but it said to use the repair your computer function. I did so and now my OS boots perfectly every time, and it does not go into setup. Other than that quirk, i've had no problems with the OS except a few incompatible drivers for older devices. My question is now though...what if my OS is damaged again? Will the setup boot up, and ask me to repair it, kind of like a fail safe? I guess I'll see if I have the misfortune of damaging my OS again!
    Tuesday, February 27, 2007 3:50 AM
  • First, thanks for all who had answered.

    Arlian, what do you mean you copied the boot disc? Vista installation disc?

    When I boot from Vista disc it repairs some boot files / or creates them. But after boot it still does not work. I'm confused because I took an image from properly working computer and that image did not work fine. Some boot options were missing. Anyone knows why? I thought that image does not exclude any more files than ExclusionList contains. Could the problem be that there are two partitions. C:\ contains Vista image and D:\ is empty. Is it possible that it tries to find bootmgr from the d: drive?

    Mzhou: Thaks for SACL message help. Unmounting my image showed that c:\ has autoexec.bat, config.sys exists. But no bootmgr. Bootmgr is in c:\windows\boot\PCAT folder. I believe that it should be like that.

    When you should run that bootsect /n60? When running PE?

    Anyone else problem with applying an image?

    Tuesday, February 27, 2007 11:07 AM
  • Yep, now I know where the problem was. I just don't know yet why. Problem was the partition. Vista installation was actually on my d:\ drive. All folders were hidden. So when I deleted the D:\ I managed to get the same bootmgr error.

    I just can't figure what went wrong because I followed the "Step by step" guide, atleast I thought so.

    Best regards, GreenOne

    Tuesday, February 27, 2007 12:04 PM
  • you are welcome.

    bootsect.exe should be run in winpe after you have formatted the target drive, but before you reboot the machine trying to boot up the restored image.

    Now, bootmgr should be under c:\, for booting to work. if you don't find c:\bootmgr right after a clean install of Vista, this is an indication that you have another active partition, which botomgr ends up into. Is this the case for you?

     

    Tuesday, February 27, 2007 6:41 PM
  • I ran into the same “BOOTMGR / NLTDR is missing” problem with Windows 7 after applying a WIM image using diskpart and ImageX and I managed to resolve it by running this command after applying the image "bcdboot c:\windows"

    • Proposed as answer by misterdiggle Friday, February 18, 2011 8:25 PM
    Friday, February 18, 2011 8:18 PM
  • Excellent work Misterdiggle! That works great! Thanks :)
    Monday, June 13, 2011 6:48 PM
  • Thanks misterdiggle!

    That worked for me too!

    Thursday, June 30, 2011 5:13 PM
  • awesome. as others stated, worked for me too

     

    thx! :)

    Wednesday, September 07, 2011 7:24 PM
  • gr8 help. worked for me too, but now i am stuck with "Setup is installing devices" sometimes it freezes on 60% sometimes on 79% and one time it remained for 2 hrs on 98%. i don't know what is wrong with it, any clues.
    Sunday, April 08, 2012 12:38 PM
  • Adding this to the SetupComplete.cmd:

    bcdboot c:\windows

    Regards,

    Tim


    http://directoryadmin.blogspot.com

    Monday, April 23, 2012 1:04 PM
  • Schweet!!! Thanks!
    Thursday, July 26, 2012 9:00 PM
  • It worked! Thanks a lot!
    Monday, July 30, 2012 11:27 PM
  • This error can also occer if you forget to mark the windows partition active as i just found out lol such an old school mistake but hey we are human
    Thursday, August 16, 2012 5:49 AM