none
Network Discovery not working after win10 1709 update RRS feed

  • Question

  • After my pc was updated to v1709 network discovery stopped working ie cannot see my NAS in file explorer , but I can map a drive or ping it.

    After trying to roll back to 1703 and back to 1709 I appear to have isolated the problem further. That is network discovery works when I boot the pc up. However when I connect to my VPN it stops working and still won't work if I disconnect the VPN.

    After re-boot it works again.

    Prior to this 1709 update it was all working fine.

    Sunday, February 11, 2018 6:26 AM

All replies

  • Hi,

    Please check if "SMB 1.0/CIFS File Sharing Support" is working.
    (1) [Control Panel] > [Programs] > [Programs and Features]
    (2) click [Turn Windows features on or off] --- this is left side of [Programs and Features]
    (3) if [SMB 1.0/CIFS File Sharing Support] is not checked, please check it
        

    cf.  SMB is a feature for file sharing. Version 1.0 is older and said it has some security hole.
      So, newer version of Windows will stop SMB 1.0. But some old(?) NAS requires it for sharing files with Windows.

    Regards,

    Ashidacchi

    • Proposed as answer by Nima28 Wednesday, July 24, 2019 4:39 PM
    Sunday, February 11, 2018 7:32 AM
  • Hello,

    Also make sure these services are running:

    Network Location Awareness
    Network Connections
    UPnP Device Host
    DNS Client
    Function Discovery Resource Publication
    SSDP Discovery


    Let us know if this helps!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Sunday, February 11, 2018 8:51 AM
  •   But many NAS devices do not use network discovery - they rely on the old NetBIOS/SMBv1 datagram system (used on Windows XP and earlier). Network discovery was introduced in Windows Vista.

      If the NAS uses this older system, you definitely need SMB 1.0 (see Ashidacchi post above), which is disabled by default in version 1709. The same applies to XP or older Windows systems and Samba shares. You will not see them from a machine without SMBv1 enabled.

      If this was working before but stopped working in version 1709, that is the most likely cause.

    Without SMB.

    With SMB

      Readyshare is my Samba-based NAS.

     

    Bill

    Monday, February 12, 2018 6:03 AM
  • Hi, thankyou for the suggestions.

    I have checked the services and features suggested and they are all on or running. The only one that wasn't was Network Connections, so I switched on, but no luck.

    Given this problem only occurs when I connect to my VPN, could it have something to do with the network adapter the VPN uses which is "TAP-Windows Adapter V9"?

    In this adapter I have checked the properties to make sure net bios is enabled.

    For what it's worth, my NAS is a synology with the latest sw/os on it. I don't think it's just the NAS as there are other devices on the network that show up in network places, but disappear after VPN is engaged.

    Michael

    Monday, February 12, 2018 9:17 AM
  • Hi,

    I'm at a loss...
    I'm using three NASs (QNAP and imation) in my home, within private network, so I don't use VPN. Where is your Synologi NAS?

    How about physically turning off them (NAS, switches, and all network devices)?
    (Sorry for my poor idea)

    Regards,  

    Ashidacchi

    • Edited by Ashidacchi Monday, February 12, 2018 9:30 AM
    Monday, February 12, 2018 9:28 AM
  • Hi,

    You can configure these settings on your NAS console page if you would like it could be connected via VPN:

    https://support.hidemyass.com/hc/en-us/articles/203548726-Synology-NAS-VPN-Setup-OpenVPN-PPTP-L2TP

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 12, 2018 9:49 AM
    Owner
  •    Local network connections are always affected when you connect your host to a VPN link. The amount of disruption is unpredictable but something is bound to be.

      There was a post in this forum recently where a long-standing problem was resolved by changing VPN supplier.


    Bill

    Tuesday, February 13, 2018 1:48 AM
  • Hi

    Sorry I may not have been clear. The VPN software / connection is on my windows 10 pc. Normally (before connecting pc to vpn) I am able to see my NAS in network places on the pc. The NAS is in my local network. Now when I connect my pc to the vpn I can no longer see the NAS and other network devices. I can still map a drive to the NAS.

    This only became an issue with the latest Fall Creators update (1709) to windows 10, on my pc.

    Tuesday, February 13, 2018 7:46 AM
  •  That was quite clear. It is connecting the host to a VPN which upsets local networking on the host.

      The purpose of a VPN is to make sure all traffic leaving the machine uses the VPN, not the direct Internet connection. To do that it has to make changes to the host's networking setup. This will quite often affect how the host interacts with devices on the local network.

     


    Bill

    Tuesday, February 13, 2018 10:47 PM
  • Thank you very much.  Selecting this setting solved a win10 1709 file sharing problem that was driving me crazy!
    Tuesday, May 1, 2018 7:29 PM
  • This one worked for me.  The services were configured as Manual start.  I changed this to automatic and started them. My machine appeared on the network tab on file explorer.
    Sunday, May 27, 2018 9:16 AM
  • I solved this another (more secure way). Synology NAS devices come configured with SMB1 as their minimum and maximum version but they support up to SMB3. It would be better to enable SMB3 on the Synology NAS than enabling SMB1 on Windows.

    Assuming your NAS is Synology, see Control Panel > File Services > SMB/AFP/NFS > Advanced Settings and set Maximum SMB protocol to SMB3 and click apply.

    • Proposed as answer by Gondar Thursday, January 24, 2019 4:28 AM
    Thursday, January 24, 2019 4:28 AM