none
8.00 gb ram (3.25 GB usable) msg, help?

    Question

  • hey there,
    i have windows 7 installed x64 bit, and i have 4 2GB sticks of DDR3 1300 FSB inside my comp, the bios reads 8 gigs and so does the os, but why is it only allowing me to use 3.25gb. how do i get the pc to read the full 8 gigs since im using the 64 bit os which should read all of it. i checked the bios settings and its showing up in there just fine.
    Friday, May 29, 2009 8:43 PM

Answers

  • In your BIOS, got to Advanced - Chipset Configuration and set Memory Remap Feature to Enabled.
    • Marked as answer by axfelix Saturday, May 30, 2009 8:32 PM
    Saturday, May 30, 2009 10:31 AM

All replies

  • Hi some006dude:
         Could you open Windows Task Manager and select the Performance tab and see what it says in the Physical Memory (MB) box?  If your PC is using the 8 GBs it should show there where it is all allocated.  The O.S. will try to make use of almost all the available RAM to speed up the PC but it will have a portion marked available even though it is being used.
    Saturday, May 30, 2009 12:12 AM
  • Hi Sanmartin:
         The poster said that both the bios and the O.S. see the full 8 GBs of RAM.  Where do you suppose he is seeing that he can only "use" 3.25 GBs?  I thot it was a reasonable question to see if the Task Manager would show where his memory is allocated.  Where else would he find that he can only "use" 3.25 GBs?  A reply only calling someone's post stupid is counter-productive and has no useful purpose.
    Saturday, May 30, 2009 3:37 AM
  • Thats right newnerd,
    It was a simple question and just needs an answer of how to get the OS to allow full use of the memory.

    Anyway, the bios and OS reads the 8.00GB memory, its just in the system info it says 3.25 usable, and the os is only using the 4gb. I have 64 bit installed so thats why i just need a little help finding out how i can get the OS to allow me to use all 8.00GB of memory on the 64 bit OS.

    Any help is appreciated.
    Saturday, May 30, 2009 4:42 AM
  • And also, under the performance tab in task manager it only shows the 3.25 gb it doesnt show at least 6 or 7 which should be usable.
    Saturday, May 30, 2009 4:47 AM
  • Please list your system specs as to narrow down any hardware issues.
    Saturday, May 30, 2009 6:54 AM
  • my specs are

    intel 775 quadcore 2.83ghz
    asrock x38 turbotwins motherboard
    4 x 2 GB corsair 1333 fsb ram
    1GB sapphire 4830 vid card
    500 gb sataII harddrive
    850w ocz gamextream powersupply

    running dxdiag it says "Memory: 8192MB"
    i just want to know what i have to turn off/on in order to get the full use of the ram. and again i installed 64bit and it shows that anywhere i look at system information.
    Saturday, May 30, 2009 7:47 AM
  • Have you tried maxing out the RAM by loading applications to see if it's actually hitting that limit?
    Saturday, May 30, 2009 7:49 AM
  • no i havent tried because task manager is already showing me 2.14 gigs is being used and the total physical memory is 3327MB which it should definately be around 6000 or 7000s
    Saturday, May 30, 2009 7:51 AM
  • Try going past that and see if it starts to use swap space.
    Saturday, May 30, 2009 7:53 AM
  • I currently have page filing turned off altogether, that wont affect anything will it?
    Saturday, May 30, 2009 7:54 AM
  • See what it gives you anyway, i.e., if it goes over, runs out of memory, or just blue screens.

    I'm going to go look something up...
    Saturday, May 30, 2009 7:57 AM
  • alright, well i put the memory usage up to 2.30ghz in task manager and i got this:

    "Close programs to prevent information loss. Your computer is low on memory. Save your files and close these programs:"

    is there any driver or changes i need to make to get this to work?
    Saturday, May 30, 2009 8:11 AM
  • Can you keep going or does it stop you? As that's suppose to kick in once you reach a certain threshold of resources (which seems low in this case).

    Saturday, May 30, 2009 8:16 AM
  • Well one thing I should have had you do earlier (command prompt):

    wmic memchip list brief > C:\memchip.txt

    Post the results here.
    Saturday, May 30, 2009 8:22 AM
  • memchip - alias not found
    Saturday, May 30, 2009 8:26 AM
  • Always do that... replace memchip with memorychip.
    Saturday, May 30, 2009 8:27 AM
  • what is it i run


    wmic memorychip list brief > C:\memorychip.txt    ?
    Saturday, May 30, 2009 8:29 AM
  • Yes, that will work; as long as memorychip comes after wmic. You can save the text file anywhere you want really.
    Saturday, May 30, 2009 8:31 AM
  • Capacity    DeviceLocator  MemoryType  Name             Tag                TotalWidth 
    2147483648  DIMM0          17          Physical Memory  Physical Memory 0  64         
    2147483648  DIMM1          17          Physical Memory  Physical Memory 1  64         
    2147483648  DIMM2          17          Physical Memory  Physical Memory 2  64         
    2147483648  DIMM3          17          Physical Memory  Physical Memory 3  64  
    Saturday, May 30, 2009 8:33 AM
  • Well I'll have to resume this later today, but try these following commands:

    wmic memorychip list full > C:\temp1.txt
    wmic memphysical list full > C:\temp2.txt
    wmic bios list full > C:\temp3.txt
    Saturday, May 30, 2009 9:01 AM
  • @some006dude and others -

    what I wrote (look at it again) was nothing about a "stupid question". I said that my reply might sound stupid and be considered as no real answer. And it isn't, it was thought more as a pointer to things to consider when someone asks about "memory usage", "who ate my memory?" etc.
    What would you think of a system that shows at an idle state (no process running) a huge mass of 2,046,965 MB total available RAM (2 TB, when I ain't wrong) and 1,951,425 MB free (or usable for processes) RAM. Both impressive values, indeed - but there's some kind of a loss between the two values, a loss of 95 GB to be exact. And no, that isn't Science Fiction, such systems exist (very few), as you can see in this screenshot http://blogs.technet.com/blogfiles/markrussinovich/WindowsLiveWriter/PushingtheLimitsofWindowsPhysicalMemory_878B/image_4.png taken from Mark Russinovich's blog.
    That said, my only intention was to clear that nobody should expect that ALL the RAM shown in the BIOS will be FREE to use for any application in any given system because the memory management itself requires some memory that can't be used for other purposes. But the difference between 8 GB and 3.25 GB is, indeed, another thing to clear up. Hope we understand each other now.
    Mob. AMD64 3000+, 1 G RAM, Mob. ATIRadeon9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Saturday, May 30, 2009 10:17 AM
  • In your BIOS, got to Advanced - Chipset Configuration and set Memory Remap Feature to Enabled.
    • Marked as answer by axfelix Saturday, May 30, 2009 8:32 PM
    Saturday, May 30, 2009 10:31 AM
  • Hi some006dude,

    perhaps this is helpful: Go to DeviceManager, go to View and select "Resources by connection". There you should see at least what parts of the memory are used by what devices, and - interesting, too - where the device memory resides, below 8 G, below 4 G or so.
    The value of 3.25 G reminds me of what you should expect from a 4 G system, not from a 8 G system. As the free memory is measured as a contiguous block, there could be 32-bit devices using memory below 4 G thus disrupting the contiguity of the RAM.
    Mob. AMD64 3000+, 1 G RAM, Mob. ATIRadeon9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Saturday, May 30, 2009 12:57 PM
  • The only cure I have seen for this problem is to reallocate the ram in the BIOS. Sorry that is all I've seen on the subject that is said to work.
    cheers .. Barry
    Saturday, May 30, 2009 6:50 PM
  • hey dominicp, your answer was right! i went into the advanced settings and turned on memory remap, and now my OS reads the 8.00GB and doesnt show 3.25 usable. I checked the physically memory in task manager and its showing 8191MB total physical memory.

    thanks for all the help guys! looks like its working here now.
    Saturday, May 30, 2009 7:00 PM
  • Hello, ive got the same problem but it says: 8gig (4gig Usable). But then when I check in taskmanager it says, 4101Mb hardware reserved .
    Monday, May 03, 2010 4:30 PM
  • .bLasT wrote:

    Hello, ive got the same problem but it says: 8gig (4gig Usable). But then when I check in taskmanager it says, 4101Mb hardware reserved .


    If you really want assitance with your situation, then start your own thread.  It is very rude to hijack and existing thread for you own problem.  Even if you think your problem is relevant, your post can get lost when you hijack another's thread.

    Also, you need to specify your exact system harware configuration for an informed response.

    Monday, May 03, 2010 6:31 PM
  • Hi mate, try typing system configuration into windows search bar, click boot tab, go to advanced options and make sure maximum memory is NOT ticked. if it is ticked then untick it. you will have to restart after applying these settings. If the maximum memory is already unticked then I'm afraid I cant help
    Monday, June 14, 2010 3:04 PM
  • I am having the same problem and I tried your advice out, but for some reason I don't have the Advanced - Chipset Configuration in my BIOS. Could you help me out?
    Tuesday, June 28, 2011 2:41 AM
  • Same here. Got Windows 7 64-bit. No Advanced - Chipset thingy here.
    Wednesday, September 28, 2011 9:20 PM
  • I had the same problem - 8G but only recognized 3.79 - I also had no advanced chipset thingy - so I downloaded a BIOS upgrade from the manufacturer's website, ran it and voila! it now can use (almost) all 8G
    Wednesday, June 20, 2012 9:04 PM