none
NTFS Disk check at startup?

    Question

  • I am using Windows 7.

    Constantly at startup I see the following message:

    "One of your disks needs to be checked for consistancy. You
    may cancel the disk check, but it is strongly recommended
    that you continue.
    To skip disk checking, press any key within 1 second(s)"

    I can skip it I press a lot of keys, but if I don't press anything it doesn't do anything and I'm stuck on this dos-like page. There is NO indication that the computer is thinking at all; like it freezes.

    What do I do?
    Tuesday, December 29, 2009 8:29 AM

Answers

  • Hi,

    There may be lot of issues as the cause of this issue like Improper shutdown, bad sectors, improper driver for your IDE/SATA controllers, old drivers for BIOS etc. You may anyway stop the autocheck by chkntfs.exe utility.

    Click start/run, type cmd and click ok. From the prompt, run chkntfs utility. This should stop the checkdisk on every boot.

    Example:
    chkntfs /x c: This disables chkdsk from running on drive C:

    More on this page about chkntfs http://support.microsoft.com/kb/160963

    regards from www.windowsadmin.info

    ManuPhilip
    • Proposed as answer by cdobbs Wednesday, December 30, 2009 12:17 AM
    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Tuesday, December 29, 2009 10:50 AM
  • You did read the article at the link ManU provided yes?  Then you would have seen this table

       chkntfs drive: [...]
       chkntfs /d
       chkntfs /x drive: [...]
       chkntfs /c drive: [...]
    
         drive:         Specifies a drive letter.
         /D             Restores the machine to the default
                        behavior; all drives are checked at boot
                        time and chkdsk is run on those that are
                        dirty. This undoes the effect of the /X
                        option.
         /X             Excludes a drive from the default boot-time
                        check. Excluded drives are not accumulated
                        between command invocations.
         /C             Schedules chkdsk to be run at the next
                        reboot if the dirty bit has been set.
    				
    What switch reverts the machine back to its default behavior ;-)

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Proposed as answer by cdobbs Wednesday, December 30, 2009 12:17 AM
    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Wednesday, December 30, 2009 12:16 AM
  • Hi Casull,

     

    If the issue persists after trying the above suggestions, please try the following steps to disable Check Disk utility when starting up the computer:

     

    1.     Click the "Start" button, type "regedit" (without quotation marks) in the "Search" bar, right click on the "regedit.exe" found in the list and then click "Run as administrator".

    2.     Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

     

    3.     Right click the BootExecute entry on the left pane, choose "Export", select "Desktop" in the "Save in" box and type "backup" (without quotation marks) in "File Name". Click "Save".

     

    Please Note: The backup file is on the Desktop and named "backup.reg". We can simply restore the registry by double-clicking the "backup.reg" file.

     

    4.     Change the BootExecute entry on the right pane to: autocheck autochk /k:C *

    5.     Exit Windows Registry Editor.

    6.     Restart your computer for the changes to take effect.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Wednesday, December 30, 2009 7:44 AM

All replies

  • Hi,

    There may be lot of issues as the cause of this issue like Improper shutdown, bad sectors, improper driver for your IDE/SATA controllers, old drivers for BIOS etc. You may anyway stop the autocheck by chkntfs.exe utility.

    Click start/run, type cmd and click ok. From the prompt, run chkntfs utility. This should stop the checkdisk on every boot.

    Example:
    chkntfs /x c: This disables chkdsk from running on drive C:

    More on this page about chkntfs http://support.microsoft.com/kb/160963

    regards from www.windowsadmin.info

    ManuPhilip
    • Proposed as answer by cdobbs Wednesday, December 30, 2009 12:17 AM
    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Tuesday, December 29, 2009 10:50 AM
  • Is it possible to turn the auto disk-check on later?
    Tuesday, December 29, 2009 5:25 PM
  • You did read the article at the link ManU provided yes?  Then you would have seen this table

       chkntfs drive: [...]
       chkntfs /d
       chkntfs /x drive: [...]
       chkntfs /c drive: [...]
    
         drive:         Specifies a drive letter.
         /D             Restores the machine to the default
                        behavior; all drives are checked at boot
                        time and chkdsk is run on those that are
                        dirty. This undoes the effect of the /X
                        option.
         /X             Excludes a drive from the default boot-time
                        check. Excluded drives are not accumulated
                        between command invocations.
         /C             Schedules chkdsk to be run at the next
                        reboot if the dirty bit has been set.
    				
    What switch reverts the machine back to its default behavior ;-)

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Proposed as answer by cdobbs Wednesday, December 30, 2009 12:17 AM
    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Wednesday, December 30, 2009 12:16 AM
  • Hi Casull,

     

    If the issue persists after trying the above suggestions, please try the following steps to disable Check Disk utility when starting up the computer:

     

    1.     Click the "Start" button, type "regedit" (without quotation marks) in the "Search" bar, right click on the "regedit.exe" found in the list and then click "Run as administrator".

    2.     Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

     

    3.     Right click the BootExecute entry on the left pane, choose "Export", select "Desktop" in the "Save in" box and type "backup" (without quotation marks) in "File Name". Click "Save".

     

    Please Note: The backup file is on the Desktop and named "backup.reg". We can simply restore the registry by double-clicking the "backup.reg" file.

     

    4.     Change the BootExecute entry on the right pane to: autocheck autochk /k:C *

    5.     Exit Windows Registry Editor.

    6.     Restart your computer for the changes to take effect.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Wednesday, January 06, 2010 2:25 AM
    Wednesday, December 30, 2009 7:44 AM