none
Windows 7 Stereo Mix Missing - Not Vista

    Question

  • Hello,

    When I had Vista I was able to right click inside the "Recording" tab and check "Show Disabled Devices" and the Stereo Mix would be shown as grayed. After enabling the device I was easily able to record from stereo.

    This is no longer the case with Windows 7. I right click on "Show Disabled Devices" as well as "Show Disconnected Devices" yet **nothing** appears. I'm very very upset and disappointed.

    One would think that "drivers" might have something to do with it... If so, then Windows 7 is lacking the drivers that Vista had? super counter-intuitive. THIS IS AN ISSUE WITH WINDOWS.

    What can I do please?
    Wednesday, October 07, 2009 11:37 PM

Answers

  • Hi,

     

    Before going any further, I would like to know the model of your computer and the sound card.

     

    I checked it on local machine, the "Stereo Mix" option appears after I check "Show Disabled Devices". So, please be assured that this option is available in Windows 7. Generally, this issue occurs because the driver is not fully compatible with Windows 7.

     

    I suggest updating BIOS and sound card driver from the manufacturer's web site first. You can also try the following steps:

     

    Reinstall driver

    ==============

    1. Click the Start Button, type "devmgmt.msc" (without quotation marks) in the Start Search box and press Enter.

    2. Double click to expand "Sound, video and game controllers".

    3. Right click your sound card and click Uninstall.

    4. Check "Delete driver software for this device" check box, click OK.

    5. Restart the computer

     

    If the issue persists, you can collect System Information and upload it to the http://skydrive.live.com/ using your Live ID and I will check it:

     

    System Information

    ============= 

    1. Click the Start Button, type "MSINFO32" in the Start Search box and press Enter to start the System Information.

    2. On the popup window, on the menu bar, click "File", and click "Save", type a file name and then choose NFO as "Save as type", click Desktop on the left pane, and click Save. (If the Desktop option is not available, please click Browse Folder button first.)

    3. Go to the Desktop, right-click on the exported file, choose "Send To" -> "Compressed (zipped) Folder". Upload this file and let me know the link.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, October 12, 2009 6:18 AM
    Friday, October 09, 2009 7:47 AM

All replies

  • Hi,

     

    Before going any further, I would like to know the model of your computer and the sound card.

     

    I checked it on local machine, the "Stereo Mix" option appears after I check "Show Disabled Devices". So, please be assured that this option is available in Windows 7. Generally, this issue occurs because the driver is not fully compatible with Windows 7.

     

    I suggest updating BIOS and sound card driver from the manufacturer's web site first. You can also try the following steps:

     

    Reinstall driver

    ==============

    1. Click the Start Button, type "devmgmt.msc" (without quotation marks) in the Start Search box and press Enter.

    2. Double click to expand "Sound, video and game controllers".

    3. Right click your sound card and click Uninstall.

    4. Check "Delete driver software for this device" check box, click OK.

    5. Restart the computer

     

    If the issue persists, you can collect System Information and upload it to the http://skydrive.live.com/ using your Live ID and I will check it:

     

    System Information

    ============= 

    1. Click the Start Button, type "MSINFO32" in the Start Search box and press Enter to start the System Information.

    2. On the popup window, on the menu bar, click "File", and click "Save", type a file name and then choose NFO as "Save as type", click Desktop on the left pane, and click Save. (If the Desktop option is not available, please click Browse Folder button first.)

    3. Go to the Desktop, right-click on the exported file, choose "Send To" -> "Compressed (zipped) Folder". Upload this file and let me know the link.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, October 12, 2009 6:18 AM
    Friday, October 09, 2009 7:47 AM
  • i have figured out a way to make the stereo mix appear... ok first and for most goto the website of your motherboard and download the win7 driver for the sound(assuming you have onboard sound like me) if not Goto your sound cards manufacture site and get the driver for win 7...NOW  ... If they dont make the driver for win7 (like me) you are screwed....BUT WAIT you're not!!!! cos windows 7 is the best and you can run programs in COMPATIBILITY mode for any previous windows OS....SO all i did was get the driver from the manufacture website For Xp(my previous OS) and before i installed it I right clicked on the driver and went to "properties" THEN I went to the "compatibility" tab...THEN i checked where it says "run this program in compatibility mode for and chose winxp sp3(my previous os) and it installed PERFECTLY and i now have Stereo mix :) Good luck!!
    Thursday, April 29, 2010 3:42 AM
  • I use headphone splitter plugged into the speaker jack. I plugged the speakers into one side and a cable from the line-in jack into the other side. I can now record

    anything that comes out of the speakers.

    Saturday, November 20, 2010 4:25 PM
  • Hi...I am having a similar problem, cant record the sound passing via the on-board sound card.

    1. OS - Windows 7 Home Premium.

    2. Audacity v1.2.6.

    3. No problem with either headphones or speakers. They are working fine.

    4. I have connected both the speaker and the headphone via a splitter to the system and the male Mic jack connector of the headphone (Pink) to the female Mic jack connector of the on-board sound card (Pink).

    5. I wanted to record background or playback song with my voice via microphone. How to do it?

    Saturday, January 15, 2011 9:16 AM
  • PLEASE help me!! I DELETED GAME, VIDEO and game controllers and now my audio cant work!! please help me
    Sunday, March 06, 2011 4:51 AM
  • Always try this first in windows & regardless of your PC mfg or audio drivers...

    1. Right click on the speaker icon in system tray
    2. Click on playback devices, in the new windows do right click in empty space
    3. Mark show disabled devices.
    4. Go to recording tab. The Stereo Mix device should now be there. Right click to enable it.
    5. Have fun using it.

    If that does not work then move forward with messing with drivers, inf files, etc...

    Hope that helps.


    Wednesday, January 11, 2012 10:00 PM
  • Its the same stupid solution everyone knows, enable this enable that.

    If you have a new computer and you don't see stereo mix, yes most of times it works when you enable disabled devices, stereo mix shows up.

    Just keep in mind, after a while, when you do the Windows Update, that stereo mix will dissapear!! 

    Stereo mix was taken away from consumers by Stupid engineers working for big companies in the hopes of minimizing the online piracy of Music but little did they think that there are other 100 ways to record the sound/video that is delivered to a computer.

    While most people seem to want stereo mix for recording sound, i need it for the opposite purpose ie to upload the sound from my computer and now that I dont' have stereo mix I can't do it. Thanks to smart ass engineers, great job that people can't use stereo mix to record but they have found other 100 ways to do it.

    Tuesday, March 27, 2012 1:58 AM
  • jmroszczak's tip is a fantastic tip, & it helped me a great deal, but I can add a bit more. I could not get Audacity to record computer audio, so I did the same as jmroszczak's tip, & I got the Stereo Mix back, & it also then appeared as an option in Audacity, but then found that Audacity did not like it...."check audio device " etc, so I completely uninstalled Audacity, & removed the leftover Audacity folder in Program files.( Previously I did uninstall Audacity without removing the leftovers, & re-install did not cure the problem.)

     Then I did the same compatibility process with Audacity setup.exe. . Now Audacity works OK

    jmroszczak's tip , is one to remember. It will probably cure lots of other problems too.

    Sunday, June 09, 2013 12:47 PM
  • If you want enable stereo mix for windows 7, a better method is to install virtual audio streaming - an audio streaming which is a virtual sound card. Please click the following link to see more information.

    http://www.stereomixplus.com

    Tuesday, July 16, 2013 6:16 AM