none
USB malfunction

    Question

  • Hi,
     
    I was using some USB devices without problem and then my mouse suddenly stopped working. I got an error bubble "USB Device Not Recognized" I have since removed all devices even my mouse but I still get the "USB Device Not Recognized" error about every 5 - 10 seconds. I did a windows update as well as checked the device manager for problems but found none. I've also uninstalled all USB ports from the device manager and scaned/added them again. Tested the mouse on another computer and it is not faulty. Also when connecting other USB devices all seems too work except mice.

    The "USB Device Not Recognized" won't stop popping up with or without my mouse connected. In the "Devices and Printers" window a unspecified device keeps popping up then going away on a 5 - 10 second basis. This also happens with and without my mouse connected. Right-click troubleshoot option also did not do anything.

    Restarting as well as windows restore did not resolve anything

    I can still control my mouse pointer with my lappy's touch pad. I have a HP 6830s laptop with windows 7. The mouse is a standard MS optical scroller.


    Any ideas please?

    Thanks


    Monday, January 11, 2010 9:44 AM

Answers

  • It seems the bios configuration for the usb ports got corrupted somehow. 

    Here's how I fixed the problem.

    Uninstalled Intel(R) ICH9 Family USB2 Enhanced Host Controller 293A and Intel(R) ICH9 Family USB2 Enhanced Host Controller 293C in the device manager.
    Shut down computer.
    Remove battery
    wait 2 mins ;0
    Reconnect battery and power up
    Enter bios config and reset to system defaults save and exit (Think you only need to do this part but I added the other steps just in case)
    Boot normally and everything should load back and work properly
    • Marked as answer by Stalkerbee Monday, January 11, 2010 1:50 PM
    Monday, January 11, 2010 1:50 PM

All replies

  • Which operating system is installed? HP is operating system specific for their drivers. They have released several drivers in the last couple of months for your system and the first thing I would do is update the bios. The most likely culprit is that the driver may have been updated to one that isn't completely compatible with your system. Go here to HP's driver website and pick your operating system that your system is using. Any more questions just ask.  Oh and as you said, its not a hardware problem until we've ruled out that you have the correct drivers installed.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, January 11, 2010 1:22 PM
  • It seems the bios configuration for the usb ports got corrupted somehow. 

    Here's how I fixed the problem.

    Uninstalled Intel(R) ICH9 Family USB2 Enhanced Host Controller 293A and Intel(R) ICH9 Family USB2 Enhanced Host Controller 293C in the device manager.
    Shut down computer.
    Remove battery
    wait 2 mins ;0
    Reconnect battery and power up
    Enter bios config and reset to system defaults save and exit (Think you only need to do this part but I added the other steps just in case)
    Boot normally and everything should load back and work properly
    • Marked as answer by Stalkerbee Monday, January 11, 2010 1:50 PM
    Monday, January 11, 2010 1:50 PM