locked
Windows 7 Desktop Icons rearrange on reboot (screenshots included)

    Question

  • Hi,

    I'm running a freshly installed copy of W7 Ultimate from MSDN together with an nVidia GeForce 8800 GTX with the latest nVidia approved driver.

    My problem is that when I reboot my system some of my desktop icons rearrange themselves. I think this is a bug, but I'd be really grateful if someone could advise - and confirm if with a similar layout of icons it does it for you too.

    I want my desktop to look like this, and this is the way I arrange it. The two folders are shortcuts to my NAS device (\\server\folder):



    and after a reboot, it moves to look like this:



    This happens every time, rebooting and shutdown all happen completely normally (the system isn't failing to shutdown cleanly, for example).

    Although not the most critical problem, it is annoying.

    Thanks for any help
    Thursday, October 08, 2009 7:44 AM

Answers

All replies

  • Windows is designed to save those alignments upon a valid shutdown/restart, but running applications, improper shutdowns, and random glitches can prevent it from doing so. The only workaround is to use a third-party utility that manages icon position. Personally, I recommend Fences, currently a free beta application from Stardock, but there are other free and paid options available as well.

    Hope this helps
    Thursday, October 08, 2009 11:55 PM
    Answerer
  • Please right click on your desktop and click “View”, uncheck “Auto arrange icons”.

    Does it work?

     


    Arthur Li - MSFT
    Friday, October 09, 2009 3:31 AM
    Moderator
  • Hi,

    Thanks for the replies.

    Auto-arrange icons isn't checked.

    I realise I could perhaps use a third-party tool to help with this, but I'm not interested in bloating my system with something that fixes an issue that Windows shouldn't have. I guess my only workaround is to delete the items from my desktop or rename them (they only move because their names are similar I think).
    Friday, October 09, 2009 11:05 AM
  • Hi,

    It's more than likely an issue with an application not shutting down properly possibly causing Windows to revert to a previously used arrangement. If you open Event Viewer, does it show any errors concerning application shutdown?

    Also, I find that 'sometimes' icons will move about if something has caused your resolution to change, even for a split second. Are you running any apps that might not be 100% compatible with the features of Aero?

    Hope this helps :)


    Jeff
    If anyone is helpful, please click the 'Vote as helpful' icon. If anyone has answered, please click 'Suggest as answer' at the bottom of the post involved :) Thanks
    • Proposed as answer by Orbital Shark Monday, October 19, 2009 7:18 AM
    Friday, October 09, 2009 11:40 AM
  • Hello,

     

    Yes, I agree with “Orbital Shark”. You may test the issue in Safe Mode and Clean Boot first.

     

    I also suggest you create a new user account to test the issue. The user profile issue also can cause such issue.

     

    What’s the result?


    Arthur Li - MSFT
    Monday, October 12, 2009 3:30 AM
    Moderator
  • I'm seeing the same issue as well. Dell Optiplex 760 using the GMA 4500 runing Windows 7 (64-bit). System refuses to hold my manually adjusted resolution, and re-arranges the icons, after every reboot.
    Monday, November 09, 2009 7:58 PM
  • Same problem here. I having tons of icons desktop and since Windows 95 everything worked fine.
    YOu had plenty time to fix that damn Vista. Couldn't you?
    Saturday, November 14, 2009 8:38 AM
  • Ditto, got exact same issues.  How big can this problem be?  Provide a FIX MS!
    Thursday, November 19, 2009 12:18 PM
  • Ditto, got exact same issues.  How big can this problem be?  Provide a FIX MS!
    This, along with folders not saving their positions, sizes, and internal layouts on a folder per folder basis, is part of the Windows 7 Upgrade!  This makes EVERYONES experience just the same.  Don't you see the great value?!

    Seriously though.  I think someone forgot a metric tone of useability in the explorer interface.  Stuff we've been using since windows 95 / 98 / 2000... GONE, just like that.
    Thursday, November 19, 2009 5:41 PM
  • I read this in another forum and it worked for me, much simpler than any convoluted process that MS recommends. After arranging your desktop icons, right click on desktop and select "Refresh." I have tested it, and you will have to refresh every time you move an icon. Obviously, it shouldn't be necessary to do it, but we will have to live with it.
    • Proposed as answer by Parsnip Monday, April 02, 2012 12:46 PM
    Monday, November 23, 2009 8:18 PM
  • I had the same problem which seems to have disappeared.  The best fix I found is at:
    http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/.

    It's a workaround fix that's easy to use by right-clicking on Computer desktop icon. Good luck!

    theWeissGuy
    Monday, November 23, 2009 11:14 PM
  • Same issue but the rightclick>refresh trick mentioned here doent work for me. Im running virtual in a VMware/Fusion Windows 7 machine.  I think the issue for people where refresh doesnt work may be with a screen resolution changing at loggin or reboot.  For me with VMWare I see the window flash a different size/resolution as the virtual Windows 7 machine starts.  The solution told by 'theWeissGuy' here works for me.  (see also http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/).  I hope this helps others... Thanks to theWeissGuy!
    • Proposed as answer by Dean-Desktop Tuesday, January 12, 2010 3:56 AM
    Friday, December 11, 2009 8:54 PM
  • Hi-

    I was having the same exact problem on my Sony Vaio Laptop, running Windows 7 Home, right out of the box.  Very Frustrating.  Here's how I fixed it, at least for now:

    Right-click Desktop > View > Make sure "auto-arrange icons" is not selected (duh, obvious!)

    THEN . . .

    Right-click Desktop > View > Uncheck "Align Icons to Grid"

    So far, so good.  I'd love to hear if this works for others.

    Peace,

    Dean
    Tuesday, January 12, 2010 4:00 AM
  • The problem is not only due to improper shutdowns it also happens when switching to other montiors even when there are set to the same resoution.

    Wednesday, January 13, 2010 2:52 PM
  • I see this intermittently on a desktop and laptop.  Win 7 Pro and Ultimate 64 bit.

    I also (intermittently) have an issue where a deleted or renamed or moved (to another folder) icon doesn't reflect the change until I refresh the desktop.

    There is a _slight_ possibility that this only happens after an S3 sleep/wake cycle.

    [edit] CONFIRMED .  Sleep/wake cycle on the laptop (Lenovo T400, Win 7 Pro 64) or the deskside (EVGA i7 white box, Win 7 Ult 64) triggers the problem.  Desktop does not auto refresh after any change to icons (delete, rename, move).
    Wednesday, January 13, 2010 5:52 PM
  • I have the same types of icon arrangement issues on a Compaq Laptop, Win 7 Pro, with two monitors. I also see applications do the same thing though. If I have a program open and close the lid on the laptop, often when I open the lid and log back in the application screen location will have changed.
    Monday, February 01, 2010 12:43 PM
  • try group policy editor...

    start>run type gpedit.msc and press enter
    open user conf...>administrative templases>desktop>dont save settings on exit [double click] select disbled and press ok

    or

    start>run type regedit and hit enter
    when UAC comes press yes
    go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer create NoSaveSettings DWORD value if exist change value to '0'

    3rd method:

    open notepad and copy-paste this text

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000001

    and save this file with .reg assocation [ex: file name.reg] and double click press yes or ok in all windows...

    Mert [Turkey -14- (1995)

    Monday, February 01, 2010 8:26 PM
  • try group policy editor...

    start>run type gpedit.msc and press enter
    open user conf...>administrative templases>desktop>dont save settings on exit [double click] select disbled and press ok

    or

    start>run type regedit and hit enter
    when UAC comes press yes
    go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer create NoSaveSettings DWORD value if exist change value to '0'

    3rd method:

    open notepad and copy-paste this text

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000001

    and save this file with .reg assocation [ex: file name.reg] and double click press yes or ok in all windows...

    Mert [Turkey -14- (1995)



    didn't personally try it, but from what i can read, this won't affect desktop icon arrangement at all.

    I'm using Win7 Ultimate x64.  Same problem ever since the fresh install.  For me, the problem occurs not only when a reboot happens. but also when....

    1. a new shortcut is placed on the desktop by either newly installed software or users
    2. the computer is left idle for hours

    When the problem happens, it could just simply moves some or most of my icons to certain specific positions, or just randomly shuffles them like a deck of cards.  It has nothing to do with anything suggested above, except for the third part programs, which I'm more than reluctant to try.

    Up til now, still no solution from MS yet.
    Wednesday, February 10, 2010 3:27 AM
  • We ran into this same problem on our new Windows 7 Pro 32-bit workstations. I believe the bug lies in the way each icon is differentiated from one another. It looks like the icon id's are only recognized by the first few characters in the name. The only icons that moved for us were similarly named icons. It looks like in the original post the "Wedding To-Do.docx" and the "Wedding" icons would be confused. The operating system tries to set these in the same position coordinates but can't because one is already in place. Naturally the other icon just gets placed in another position.

    The workaround for us was to rename one of the similarly named icons.

    Hope this helps,
    JZeman
    Monday, February 15, 2010 6:19 PM
  • I have noticed the same issues. I have noticed some things that you may not have. It happens to me whenever I shutdown or restart the computer using Shortcuts or the power button. If I use the shutdown or restart commands in the start menu my icons will remain where I move them to. after that I can use the power button or my desktop shortcuts (Run: shutdown /s /t 00) or (Run: shutdown /r /t 00) and they will stay the way I have them arranged. If I move them again and use the shortcuts or the power button they will go back to the same place as where I had them the last time I used the start menu shutdown or restart.

    I believe that this issue is do to an update because my vista install just started doing the same thing. I believe that the update that does it has something to do with Icon placement when hooking up and unhooking multiple monitors because before this started whenever I hooked up a second monitor and unhooked it later all my Icons used to lineup along the right side of my screen and I would have to move them all after unhooking the second monitor. Now that I am having a problem with the Icons not staying when using my shortcuts and the power button when I unhook my second monitor all the Icons go back to where they were before I hooked up the second monitor. I am not possitive that this is it but it is somewhere to start since they started at the same time. And since vista now has the same issue where as it didn't before I am going to assume that the problem lies with microsoft and one of there updates

    J.T.

    Green Bay Wi

    Friday, March 19, 2010 7:41 PM
  • I have noticed the same issues. I have noticed some things that you may not have. It happens to me whenever I shutdown or restart the computer using Shortcuts or the power button. If I use the shutdown or restart commands in the start menu my icons will remain where I move them to. after that I can use the power button or my desktop shortcuts (Run: shutdown /s /t 00) or (Run: shutdown /r /t 00) and they will stay the way I have them arranged. If I move them again and use the shortcuts or the power button they will go back to the same place as where I had them the last time I used the start menu shutdown or restart.

    I believe that this issue is do to an update because my vista install just started doing the same thing. I believe that the update that does it has something to do with Icon placement when hooking up and unhooking multiple monitors because before this started whenever I hooked up a second monitor and unhooked it later all my Icons used to lineup along the right side of my screen and I would have to move them all after unhooking the second monitor. Now that I am having a problem with the Icons not staying when using my shortcuts and the power button when I unhook my second monitor all the Icons go back to where they were before I hooked up the second monitor. I am not possitive that this is it but it is somewhere to start since they started at the same time. And since vista now has the same issue where as it didn't before I am going to assume that the problem lies with microsoft and one of there updates

    J.T.

    Green Bay Wi
    Friday, March 19, 2010 7:42 PM
  • I am running Win7 x64.  Everytime my computer updates itself my icons become rearraged.  I like to leave my icons in horizontal rows.  After Win7 updates itself I get my icons rearranged in vertical rows starting underneath my Recycle bin in top left corner.  Annoying!!!

    Wednesday, March 31, 2010 10:18 PM
  • I have the same problem on Win7 64bit and wish it would be fixed. It would be nice if windows saved desktop icon positions. There are several programs out there that 'claim' to be a resolve to the issue, but they are bloated with options I don't care for or like this one (suggested) http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/ . This site does not work for me, or the 64bit alternative. I see the options, but when I click to save or restore icon placement it doesn't do anything. I do remember it worked in Vista 64, but it does not work in Windows 7 64bit. I am trying alternative solutions but so far no success or I don't like the program. One other program restarted my explore.exe 3 or 4 times when I installed it.


    Cheers Tom
    Sunday, April 25, 2010 2:59 AM
  • Hi , I was having the same problem with my pc running windows 7 64 bit, so frustrating!!!, tryed turning off auto-align

    and align to grid, that did not work, also tried that holding shift key down thing , that also did not work for me. Heres how 

    I stopped it at least  START>Type in search window,"themes">Change themes>In menu choose from the far left where

    it says change desktop icons, see if the box marked,"allow themes to change desktop icons" is checked, if so you know what

    to do brother, uncheck it and APPLY and hopefully that works for you, did for me. Peace out

    • Proposed as answer by Muirio Friday, May 14, 2010 8:25 AM
    Saturday, May 01, 2010 3:02 AM
  • I Managed to fix this by deleting the desktop.ini file found in C:\Users\All Users\Desktop and C:\Users\"my current User"\Desktop, this file is occulted.
    • Proposed as answer by Vitor Luis Monday, June 14, 2010 5:59 PM
    Monday, June 14, 2010 5:56 PM
  • That bug is annoying but the solution is unbelievably simple...

     

    uncheck "Align icons to grid"

     

    check it when you want to align your icons but always uncheck it everytime after use .

     

    Please credit me if this solution works for you.

    Clementimuzio
    Friday, June 25, 2010 8:36 AM
  • Hi!

    I used 3rd party drivers installed over producers drivers(lower GPU temps) for while and one day i got to the same problem with my icons. I used a 3rd party app called Icon Restorer.

    Lately however i played with dual screen display and something went wrong with my drivers (kept crashing) I uninstalled both 3rd party (Omegadrivers.net) and producers (zotac) drivers and rebooted. System booted up finding a new device and installed its own drivers. Than after reeboot i installed 3rd party drivers (omegadrivers) for the reasons mentioned above.

    Anyways, after removing all the drivers NOT installed by system, when OS recodnizing the device and installed its own drivers all the icon issues stopped. And now with newly installed drivers that i want (3d party) it still is OK.

    I guess maybe the problem lays somewhere in OS <-> GPU.driver communication.

    PS: Before i resorted to Icon Restorerer i tried looking into registry, deleting desktop.ini and other things i found here and on other sites. So if thats any help to anyone, use an UNINSTALL option on Your drivers, allow OS to install them from its own database, and than after reeboot install those of your choice. It worked for me it shoudl hopefully be usefull for you.

    Good luck :)

    Tuesday, June 29, 2010 9:52 PM


  • This happens every time, rebooting and shutdown all happen completely normally (the system isn't failing to shutdown cleanly, for example).

    I was researching this problem as well.  When I undid "Align to grid", did a refresh, and then restarted, my icons stayed where they were supposed to be.

    A 2 minute fix.

    Dan

    Thursday, September 23, 2010 4:29 PM
  • shame on microsoft for windows 7. although i agree it is far better than vista they still have a long way to go.

    it shouldnt need to get to the point of downloading 3rd party apps.

     

    shame on you microsoft

    Friday, December 03, 2010 10:17 PM
  • shame on microsoft for windows 7. although i agree it is far better than vista they still have a long way to go.

    it shouldnt need to get to the point of downloading 3rd party apps.

     

    shame on you microsoft


    ditto!

    jas

    Saturday, April 16, 2011 11:30 PM
  • try group policy editor...

    start>run type gpedit.msc and press enter
    open user conf...>administrative templases>desktop>dont save settings on exit [double click] select disbled and press ok

    or

    start>run type regedit and hit enter
    when UAC comes press yes
    go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer create NoSaveSettings DWORD value if exist change value to '0'

    3rd method:

    open notepad and copy-paste this text

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000001

    and save this file with .reg assocation [ex: file name.reg] and double click press yes or ok in all windows...

    Mert [Turkey -14- (1995)


    Thought you were on to something, Mert.

    Unfortunately, there is no such policy setting on Win 7.

    I highly reccomend for everyone this free utility: http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/


    --Aargh!
    • Proposed as answer by BufferOverflow Thursday, June 02, 2011 3:05 PM
    Thursday, June 02, 2011 3:05 PM
  • That worked for me when all else failed! Thanks for the info Dean!
    Friday, June 17, 2011 7:36 PM
  • Nope
    Friday, August 05, 2011 2:34 PM
  • On another forum, Educationalist wrote:

    After arranging your icons, right-click the desktop and click 'Refresh'. That'll lock the current icons in place. [F5 also works if the desktop is the active window.]
    Caveat: If you change a document with MS office it'll delete the old icon and generate a new one. I use OpenOffice which seems to leave the icons intact.

    I think that Educationalist is onto something, as the following procedure worked for me:


    (Note: I have the Save and Restore Desktop Icon Layout utility installed, the one that uses a right-click on the desktop, *not* the one that requires a right-click on the 'Computer' link in the Start Menu. [See: http://www.kellys-korner-xp.com/xp_tweaks.htm, line 188, click on right side to download iconlayout.zip, which contains the files layout.dll, and iconlayout.vbs. The vbs file updates the registry automatically, which allows the utility to be used by right-clicking on the desktop, not the 'Computer' link in the start menu.] I highly recommend that utility, having used it under Windows Vista (32 bit) as well as XP. Occasional icon-location 'flubs' occur for various reasons, and if one has lots of icons it can be a pain to manually reset their positions on the desktop [if one can even remember where they all belong!]. [Note that there is another version of this utility using the same dll file, but a reg file that modifies the right-click menu for 'Computer' in the start menu, rather than the context menu for the desktop].)

    I'm running Windows Vista (32 bit) with Service Pack 2. For some unknown reason, my icons were being reset to one 'mass' on the left side of my desktop, and my usual solution, using the Save and Restore Desktop Icon utility followed by rebooting, was not helping. Also, resetting the icons with the Save and Restore Desktop Icon utility, followed by pressing F5, returned all the icons to the left side of the desktop once again.

    Educationalist's solution, above, began: "After arranging your icons...". The key seems to be that arranging the icons must be done *by hand* (not with the Save and Restore Desktop Icon utility)!

    I discovered that by pressing F5, which moved all icons to the left of my desktop. I then moved one icon to a slightly different location, and again pressed F5 to refresh. When I did this, I noted that the one icon that I moved remained in its new location. I then restored all the icons using the Save and Restore Desktop Icon Layout utility to their original locations that I use. (I could have done this 'by hand', but that would have taken much longer.) When I pressed F5 again, nothing moved.

    This solution worked for me, I hope it works for you, too!

    aboutblank6

     

    Saturday, August 13, 2011 5:10 AM
  • Yahoo!  Thanks

     

    F5 did the trick. Work with all setting.  Microsoft never fix these problem.

     

     

    • Proposed as answer by Wizmac Thursday, September 29, 2011 9:48 PM
    • Unproposed as answer by Wizmac Thursday, September 29, 2011 9:48 PM
    Monday, August 22, 2011 10:36 AM
  • Once you had your icons arranged the way you want them, was to hold down the shift key when re-booting. (Hold shift key, select restart, hold shift key until desktop loaded). You will need to do this each time you add more icons to your desktop.
    • Proposed as answer by Wizmac Thursday, September 29, 2011 9:51 PM
    Thursday, September 29, 2011 9:50 PM
  • Once you had your icons arranged the way you want them, was to hold down the shift key when re-booting. (Hold shift key, select restart, hold shift key until desktop loaded). You will need to do this each time you add more icons to your desktop.
    LOL ... Keep it pressed while you type your password too ...
    Monday, October 03, 2011 2:55 PM
  • Once you had your icons arranged the way you want them, was to hold down the shift key when re-booting. (Hold shift key, select restart, hold shift key until desktop loaded). You will need to do this each time you add more icons to your desktop.
    LOL ... Keep it pressed while you type your password too ...


    I am using Windows 7 (64 bit) I can't bring the icon of computer and other Icons to the desk top I mean I couldn't find the change desktop icons option, please help me.

    Thanks,

    AMID

    • Proposed as answer by Amidjan Wednesday, October 05, 2011 2:05 PM
    Wednesday, October 05, 2011 2:02 PM
  • the Refreshing fix worked for me, thanks Saki2

     

    Thursday, November 03, 2011 12:34 PM
  • Hi,

    This has worked for me in Windows 7 Pro.

    1. right click on space on desktop

    2. choose "personalize)

    3. On left side of window, click on "change desktop icons"

    4. In box that appears, unclick "Computer" make sure that "User's Files" is clicked. You can also  click network, recycle bin, and control panel if you want them so show on the desktop, but make sure "Computer" is not clicked. Also DO NOT click "Allow themes to change desktop icons."

    Good Luck.

    Tuesday, November 15, 2011 3:45 PM
  • Hi,

    This has worked for me in Windows 7 Pro.

    1. right click on space on desktop

    2. choose "personalize)

    3. On left side of window, click on "change desktop icons"

    4. In box that appears, unclick "Computer" make sure that "User's Files" is clicked. You can also click network, recycle bin, and control panel if you want them so show on the desktop, but make sure "Computer" is not clicked. Also DO NOT click "Allow themes to change desktop icons."

    Good Luck

    Tuesday, November 15, 2011 3:53 PM
  • Thank you, Refresh has fixed my problem. (Win 7 64bit).
    • Proposed as answer by Jaka Mon Wednesday, February 08, 2012 5:04 PM
    • Unproposed as answer by Jaka Mon Wednesday, February 08, 2012 5:04 PM
    Saturday, November 19, 2011 8:49 PM
  • None of the above solutions fix the prob for me.  Dell XPS laptop with win7 x64, 1920x1080 resolution.  Changing from showing computer to user files had zero effect.  Hitting -icon refresh- before leaving the pc unattended for a while did not prevent my open windows, from sliding to the right edge and/or to the bottom of the screen whenever the screen saver kicked in.  Auto-arrange icons was already off, and I turned off align icons to grid, none of which helped.

    What DID work was changing my screen saver from my aquarium (which has a lower max screen size) to one of the default windows screen savers (any will do, blank, mystify, ribbons, etc).

    So in my case, it was the lower resolution screen saver that was doing it.

    I keep my open windows less than full sized and overlapped so I can easily click on any or on any of the icons around the edge of the screen.  
    But whenever my screen saver kicked in, my open windows, whether currently open on the screen or minimized on the bottom bar, would shift to the right edge and/or to the bottom of the screen as long as I was using the lower resolution screen saver.
    I changed to windows -mystify- screen saver, and now none of my windows shift position or get rearranged.

    This never affected any of my icons.  I have icons on both the far left and far right side of my screen, and some on the top.  None of my icons ever moved, regardless of which screen saver I was using.

    It did, however, affect my Weather Bug app/gadget which would shift from upper right corner to about 1/3 distance from the left upper corner every time after the screen saver kicks in, and will even put itself on top of an icon already there.  This too has been 'fixed' by changing to standard, default windows screen saver.
    Wednesday, February 08, 2012 5:05 PM
  • I tried this fix as well as Right-click Desktop> "refresh" .  One of these two fixed mine.  I rebooted & all my icons stayed where I had them.  Thank you soooo much!!

    Jill

    Monday, March 26, 2012 3:51 PM
  • Definitely still a problem.

    I have tried all of the above, and I sometimes see my icons rearranged in the middle of the day!

    Without even logging off.

    It's crazy. When will M$ admit that there is a problem?????


    plugh

    Monday, March 26, 2012 4:29 PM
  • Hello,

    Yes, I agree with “Orbital Shark”. You may test the issue in Safe Mode and Clean Boot first.

    I also suggest you create a new user account to test the issue. The user profile issue also can cause such issue.

    What’s the result?


    Arthur Li - MSFT

    I *Love* these Microsoft types:

    -Mark your own post as an answer, even when it's not.

    -Ensure that there is no "Mark this proposed answer as utter bullsh*t" button.

    That's great. You can "close" the issue now.

    Tuesday, April 03, 2012 7:58 PM
  • Well, there may be a cause to that : the Themes.

    So go in the control panel and select the following menu in CP. Then Change Desktop icons. And disable themes action.

    Friday, July 06, 2012 10:53 AM
  • I've read the entire thread, repeated all the above, and I have the same issue with no resolution.

    On a reset, relog, or even refresh of desktop, for my current user profile, the desktop icons all get arranged to the left side, "auto arrange" gets unchecked, "align to grid" gets checked, and size gets set to medium.  All I have to do to repeat is click "refresh" and it puts them all back.

    I've tried:

    -unchecking "align to grid" and "auto align" and restarting

    -moving icons and "refresh" (just moves them back and resets options)

    -checking entries in registry for NoSaveSettings (not sure if even valid for win 7)

    -registry entries in HLKM\Software\Microsoft\Windows\Shell\Bags\Desktop

    -created 2 new profiles, one to copy entire profile to, and one to use to copy with.  Copied entire profile directory excluding the 3 files, and ended up with a profile that looked the same, but was completely unsable because anytime I tried to run *anything* or even right click on desktop, I got an error message saying that Explorer.exe could not be found.

    -I've ran multiple virus/adware/malware scans with various applications including AVG, Spybot - Seek and Destroy, Malwarebytes, in normal and safe mode.  I've ran a scandisk, drive cleanup, and defragment.

    I will not use a 3rd party application to "fix" something that worked perfectly fine before, but would like to find out what the problem is so if it happens again.

    Saturday, July 21, 2012 12:06 AM
  • I recently began having the same issue.  I am running Windows 7 home
    premium.  It began after another user shut down a game program and
    "something" happened.  I fixed the trouble by doing a system restore to
    an earlier date.  It would be nice to have a specific cause, but alas it
    is a mystery.
    • Proposed as answer by Alex_AGM Thursday, August 02, 2012 5:59 PM
    Friday, July 27, 2012 6:17 PM
  • Every time i use hte refresh to try and lock icons they all shift to the left again....  none of this start till after i installed a XFX r6570  AMD graphics card
    Wednesday, August 22, 2012 2:32 AM
  • I followed the instructions in this link, as suggested by schramm.r (near the top) and it worked for me.

    http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/

    My system just recently started rearranging my descktop items to the left upon startup.  Copying those files added the "save desktop icon layout" and "restore desktop icon layout" options.     If I right-click on my desktop directly and use "Refresh", it moves everything over to the left again.   If I go to my Windows startup button (windows icon, bottom left corner of screen), scroll over to "Computer" and right click on "Computer" (don't left-click "Computer"), I see my two new options. I click on the "restore desktop icon layout" and it moves my icons back to where I want them.

    But use the patch as instructed in the link above. That'll give you those two options.

    Friday, September 21, 2012 4:00 PM
  • This regedit will not work on Win 7 - 

    Does not exist -

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    Or

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    Friday, February 15, 2013 3:08 AM
  • Just in case anyone in MSFT is interested, this problem persists. Windows 7HP, SP1.

    It appears that forced reboots for Windows Update, cause the OS to so-helpfully toss all desktop items up in the air, letting them fall randomly back on the desktop.

    And before you help by suggesting I check auto-arrange and align to grid, please be assured they are, and have been since I purchased this machine a year ago.

    MSFT, is this really rocket science?

    • Proposed as answer by gerlag Sunday, August 18, 2013 8:53 PM
    • Unproposed as answer by gerlag Sunday, August 18, 2013 8:53 PM
    Friday, August 16, 2013 3:49 PM
  • Finally I found THE solution: 

    gravitypoint.se/windows-7-desktop-auto-arrange-solution/

    Also mentioned in this forum: social.technet.microsoft.com/Forums/windows/en-US/7d707f81-0f86-4fdc-9c3e-2f5475a180a9/desktop-icons-auto-arrange-after-refresh

    It appears to be quite difficult to find, so I post it here also...

    Quote from David_SE:

    "Full description of problem:

    - Desktop Icons arranging on the left after every reboot or refresh of dektop

    - Folder Views was not saved (like sorting by name, date, etc.)

    - initially the "Auto Arrange Icons" setting was not set.

    - the setting "Auto Arrange Icons" was not saved during reboot after activation (i activated it, after reboot it was deactivated)

    Solution:

    Delete the following Registry Key and do a reboot:

    [HKEY_CURRENT_USER\Software\Classes\clsid\{42aedc87-2188-41fd-b9a3-0c966feabec1}]"


    • Edited by gerlag Sunday, August 18, 2013 8:57 PM
    Sunday, August 18, 2013 8:55 PM