none
System Writer is not found in the backup( windows server 2012 ) RRS feed

  • Question

  • Dear All ,

    i facing a typical problem with my windows server 2012 backup.

    Recently we started using server 2012 standard , after installing the server backup feature, we ran server backup the following error keeps coming for us

    " system writer is not found in the backup " .

    can some one please help me to sort this

    thanks ,

    RAM

    Friday, February 8, 2013 10:45 AM

All replies

  • Hi RAM,

    Please test the steps below:

    Copy below into a batch file and run from an elevated command prompt (or execute every line manually).

    Takeown /f %windir%\winsxs\temp\PendingRenames /a

    icacls %windir%\winsxs\temp\PendingRenames /grant "NT AUTHORITY\SYSTEM:(RX)"

    icacls %windir%\winsxs\temp\PendingRenames /grant "NT Service\trustedinstaller:(F)"

    icacls %windir%\winsxs\temp\PendingRenames /grant BUILTIN\Users:(RX)

    Takeown /f %windir%\winsxs\filemaps\* /a

    icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"

    icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)

    icacls %windir%\winsxs\filemaps\*.* /grant BUILTIN\Users:(RX)

    net stop cryptsvc

    net start cryptsvc

    Type the following command to verify that the system writer is now listed:

    vssadmin list writers

    If we have system writer and other listed test running a System State backup using Windows Server Backup.


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, February 14, 2013 7:52 AM
    Moderator
  • Hi Shaon Shan ,

    thanks for your reply , though i followed all the steps one by one manually , still unable to list " system writer " on vssadmin list writers

    any other solution for this ?

    Wednesday, February 20, 2013 3:59 PM
  • Same problema here, I did those steps and is still not working.

    Have you found a Solution?

    Thanks,

    Douglas Chagas

    Thursday, April 25, 2013 9:45 PM
  • I am also having the same issue, anyone got any ideas?
    Monday, April 29, 2013 4:27 AM
  • Hi Guys,

    I'm facing a same problem of system writer in windows server backup (Windows Server2008 R2), I used above command to regain the permission on "winsxs" directory even i edited the registry also for the same, but NO system writer is found till.

    We are waiting for your solution....

    Thursday, May 2, 2013 5:35 AM
  • Same problem here on a few virtual machines running server 2012 datacenter (with gui).

    They all have SQL Server Dev.Edition, Sharepoint 2013 and Project Server 2013 installed.

    I tried all tricks about the permissions, checked the registry (it jus was set to 1) and re-installed windows server backup. I guess it's a problem during the feature installation of windows server backup!

    On one machine running SQL/SP/PS i didn't install server backup and checked the installed writers, no system writer. Then i added the feature and checked again - still no system writer!

    Wednesday, July 3, 2013 8:43 AM
  • I know It's old, but I'll answer anyway. After long searching I have found the hotfix (worked for me). Problem was on Windows server 2012 machine with visual studio installed.

    https://support.microsoft.com/en-us/kb/2807849

    cheers

    Thursday, October 27, 2016 11:46 AM
  • Hi Marek.zalewski,

    I have the same issue with backup on windows server 2012. Following the link you provided, i can not find the hotfix for windows server 2012 64bits. 

    Regards.

    Sunday, October 30, 2016 6:06 PM
  • Hi marek,

    thank you for your sharing. i had installed the update and it fixed the issue.


    srini

    Wednesday, November 23, 2016 8:12 AM
  • Hi did you get this problem solved , I have same issue only 2008server and 8RT patch don't want to install incorrect version
    Friday, March 10, 2017 12:28 AM
  • I have Server 2012 (all current on Windows Updates) and I picked the Win8 RTM patch. The install required a reboot. It solved the problem. The server is now backing up successfully.
    Tuesday, September 26, 2017 1:15 PM
  • I have a similar issue with server 2012 r2 where those patches won't work/install as they are the incorrect version for 2012 r2. Has anyone with that same server version installed found a solution? 
    Tuesday, October 3, 2017 6:38 PM