none
WDS , Server 2012 R2 and eUFI boot RRS feed

  • Question

  • Hi,

    Setup WDS on Server 2012 R2 , PXE boot is working if I disable secure boot and enable legacy boot.

    PXE boot working only in legacy mode, and if I install the OS anyways in legacy mode, then enable the Secure boot, machine not able to boot (because uefi support was disabled)any thoughts why?


    N.A.Malik


    • Edited by N A Malik Tuesday, March 4, 2014 11:33 AM
    Tuesday, March 4, 2014 11:30 AM

Answers

  • Yea, I questioned about Option 67.  Your pointing option 67 to the legacy files and not to EFI files.  If the computers your imaging are in the same subnet as your DHCP/WDS server than remove Option 67 and the device will pick the appropriate files.  If your in a separate subnet then you must IP Helper Tables otherwise you can only image EFI or Legacy but never both at the same time.

    http://technet.microsoft.com/en-us/library/cc766320(v=ws.10).aspx


    Be kind and Mark as Answer if I helped.

    Friday, March 7, 2014 3:25 PM

All replies

  • If you browse to \\Server\Reminst\boot\x64 do you have a file named "wdsmgfw.efi"?  Are you DHCP scopes forcing a pointer to "wdsnbp.com" with option 67?

    Be kind and Mark as Answer if I helped.

    Tuesday, March 4, 2014 3:04 PM
  • The boot image in WDS needs to be x64 and added to the x64 UEFI boot default option.

    What happens if you try to boot PXE using the UEFI option?

    In my experience, even if you do a Legacy boot to a server that only has a boot image added into the UEFI x64 option and no other options, the client is still able to boot to WinPE.

    For the non-booting issue, installing the OS in UEFI mode means you need to use a GPT disk. SecureBoot only works on GPT disk and not MBR disk.

    Tuesday, March 4, 2014 3:09 PM
  • The boot image in WDS needs to be x64 and added to the x64 UEFI boot default option.

    What happens if you try to boot PXE using the UEFI option?

    In my experience, even if you do a Legacy boot to a server that only has a boot image added into the UEFI x64 option and no other options, the client is still able to boot to WinPE.

    For the non-booting issue, installing the OS in UEFI mode means you need to use a GPT disk. SecureBoot only works on GPT disk and not MBR disk.

    I have added only x64 boot image UEFI but not working.
    My Server 2012 R2 setup was on MBR disk, would this be the case?

    N.A.Malik

    Tuesday, March 4, 2014 8:12 PM
  • Installed Server on machine with GPT /UEFI.

    PXE Booted a client PC and get the following:

    >>Start PXE over IPv4
    Station IP: 10.0.0.12
    PXE E16 : No offer received


    N.A.Malik

    Wednesday, March 5, 2014 9:10 AM
  • If you browse to \\Server\Reminst\boot\x64 do you have a file named "wdsmgfw.efi"?  Are you DHCP scopes forcing a pointer to "wdsnbp.com" with option 67?

    Be kind and Mark as Answer if I helped.

    hi,
    wdsmgfw.efi exists.

    In WDS , I have configured 
              Do not listen DHCP Ports
              Configure this server to indicate this is PXE Server as well.


    N.A.Malik

    Wednesday, March 5, 2014 9:20 AM
  • Use your boot menu option on the client to verify you are actually doing a UEFI PXE boot.

    I always make sure to use the client's boot menu to verify I am attempting to boot the system with the correct option. This picture shows a system that has UEFI boot enabled and legacy boot disabled. If you have both enabled, you would see UEFI prefixed and normal options. NOTE: your PC's boot menu may appear differently.

    Wednesday, March 5, 2014 4:30 PM
  • Use your boot menu option on the client to verify you are actually doing a UEFI PXE boot.

    I always make sure to use the client's boot menu to verify I am attempting to boot the system with the correct option. This picture shows a system that has UEFI boot enabled and legacy boot disabled. If you have both enabled, you would see UEFI prefixed and normal options. NOTE: your PC's boot menu may appear differently.

    Hello and thanks for reply.

    Actually I am pressing F12 to get the PXE boot.

    And I have disabled the legacy support in BIOS.


    N.A.Malik

    Wednesday, March 5, 2014 7:44 PM
  • Yea, your WDS server is not responding.  I noticed in a previous post you said you configured "      Do not listen DHCP Ports".  Is your DHCP and WDS on the same server?  If so then you also need to ensure in your DHCP scope that Option 60 is configured.  If DHCP and WDS are not on the same server then uncheck that box and try again.

    Be kind and Mark as Answer if I helped.

    Thursday, March 6, 2014 2:38 PM
  • Both WDS and DHCP on same server.
    60 and 67 option are configured as well. Can boot in legacy mode, but not in EFI.

    N.A.Malik


    • Edited by N A Malik Friday, March 7, 2014 8:22 AM
    Friday, March 7, 2014 8:22 AM
  • Yea, I questioned about Option 67.  Your pointing option 67 to the legacy files and not to EFI files.  If the computers your imaging are in the same subnet as your DHCP/WDS server than remove Option 67 and the device will pick the appropriate files.  If your in a separate subnet then you must IP Helper Tables otherwise you can only image EFI or Legacy but never both at the same time.

    http://technet.microsoft.com/en-us/library/cc766320(v=ws.10).aspx


    Be kind and Mark as Answer if I helped.

    Friday, March 7, 2014 3:25 PM