none
Sleep Mode Problem after Windows 7 sp1 installation

    Question

  • After installing yesterday windows 7 64bits sp1, when choosing "sleep" in the startup button or in the power options plan, the computer no more goes in to sleep mode. Instead it does an improper shutdown, causing the computer on the next start, to display the message that the computer did not shutdown properly, giving me the usual options: Safe mode, safe mode with networking, ..., start up normally.

    I have Rollback Rx installed. Rolling back to the last snapshot before the sp1, the sleep mode becomes normal again. Re-installing the sp1, the problem comes up again.

    Also launched "msconfig" and did a clean boot, disabling all non microsoft services. The problem remains.

    May by this should be looked for a future update.

    Thanks

    • Moved by Carey FrischMVP, Moderator Friday, February 25, 2011 10:31 PM Moved to relevant forum category (From:Windows 7 Installation, Setup, and Deployment)
    Friday, February 25, 2011 7:49 PM

Answers

  • Setting "Hybrid Sleep" to "Off" seems to fix the problem. "Hybrid Sleep On" worked fine before SP1.
    • Proposed as answer by Mikx12 Saturday, February 26, 2011 3:20 AM
    • Marked as answer by mclino Saturday, February 26, 2011 9:34 AM
    Saturday, February 26, 2011 3:19 AM

All replies

  • I'm having the exact same problem. Windows 7 Pro x64.
    Friday, February 25, 2011 11:54 PM
  • Setting "Hybrid Sleep" to "Off" seems to fix the problem. "Hybrid Sleep On" worked fine before SP1.
    • Proposed as answer by Mikx12 Saturday, February 26, 2011 3:20 AM
    • Marked as answer by mclino Saturday, February 26, 2011 9:34 AM
    Saturday, February 26, 2011 3:19 AM
  • That fixed the problem.

    Thank you

    Saturday, February 26, 2011 9:34 AM
  • I set "Hybrid Sleep" OFF and now, upon waking, I get the normal Windows desktop, a long delay where everything is frozen, and then the BSOD.

    With "Hybrid Sleep" ON, upon waking, the computer reboots (no Windows desktop; just a black screen), then displays a screen saying Windows did not shut down properly and asks what mode to start in.

    This started after installing Windows 7 SP1 32-bit. With RTM, sleep worked normally.

    • Proposed as answer by McMauh Monday, September 5, 2011 6:32 PM
    • Unproposed as answer by McMauh Monday, September 5, 2011 6:32 PM
    Saturday, February 26, 2011 6:14 PM
  • Same exact problem with Win 7 SP1. Turning off Hybrid Sleep seems to've resolved the problem, but Hybrid Sleep is a useful feature. Wonder if Microsoft will release a patch or update, please!?
    Sunday, February 27, 2011 5:02 PM
  • Setting "Hybrid Sleep" to "Off" seems to fix the problem. "Hybrid Sleep On" worked fine before SP1.

    This was quite an annoying issue. I can confirm that your suggestion does in fact work. Thanks!
    Tuesday, March 1, 2011 10:25 PM
  • Have the same problem with sleep mode after installing SP1 in my 64bit Window installation. I tried the hotfix KB426935 and it worked for several applications and then it didn't! No new software installed---it just went back to no sleep. Uninstalled it and reinstalled it and no joy.
    Uninstalled it and tried shutting off hybrid sleep and tht too worked for two tries and then again no sleep.

    What is crazy is that it works for a couple of shots and then back to square one. I tried shutting off multimedia sharing and THAT worked for one time and then back to NO SLEEP. This is weird.

    Friday, March 4, 2011 4:15 PM
  • HI,

    Using Windows 7 x64.

    I installed SP1.

    If i manually click hibernate it works ok and it hibernates the PC. Before SP1 Usually my computer goes to sleep in 20 min and if it remains untouched until 30 min it hibernates itself.

    But after installing SP1, it sleeps in 20 min but after that never goes to hibernation after 30 min.

    Is there a bug ? will it be fixed ?

    Saturday, March 5, 2011 2:07 AM
  • What really worked to completely restore all sleep functions is removing Secunia form the computer!
    Saturday, March 5, 2011 3:16 PM
  • After installing yesterday windows 7 64bits sp1, when choosing "sleep" in the startup button or in the power options plan, the computer no more goes in to sleep mode. Instead it does an improper shutdown, causing the computer on the next start, to display the message that the computer did not shutdown properly, giving me the usual options: Safe mode, safe mode with networking, ..., start up normally.

    I have Rollback Rx installed. Rolling back to the last snapshot before the sp1, the sleep mode becomes normal again. Re-installing the sp1, the problem comes up again.

    Also launched "msconfig" and did a clean boot, disabling all non microsoft services. The problem remains.

    May by this should be looked for a future update.

    Thanks


    Exact same problem with me after SP1. Hybrid sleep set to off does fix the problem.

     

    Kinda makes ya wonder how these service packs are supposed to make the system more stable?   I call bs on this one.  I  foresee another Microsoft update in the near future to fix the problems they created with SP1.

    Monday, March 7, 2011 7:48 PM
  • have you tried this hotfix?

    http://support.microsoft.com/kb/2495523

    A crash memory dump file is not created, or hibernation does not work, when you use a SCSIport miniport driver as the startup device driver in Windows 7 or in Windows Server 2008 R2

    Thursday, March 17, 2011 5:44 AM
  • I'll have to try that.. after I see if I use a SCSIport miniport driver as the startup device driver. And here I've been blaming the darn action center for slipping a AMD power management driver into my optional updates that I d/l'd and installed onto my INTEL system.. >_>

    Oh and by the way... turning off the hybrid sleep fixed my windows 7 64x crashes and instant power down upon entering sleep mode as well. Though it does sound like its a fix that may not take permanantly from what some of the others have been saying.

    Saturday, April 30, 2011 3:20 AM
  • FIXED

    Problem: After installing Windows 7 SP1, entering sleep/hibernate mode causes PC to hang for an extended period, and then bluescreen.

    I tried all of the following, and NOTHING worked:

    - Installed Win7 Hotfix KB2495523
    - Disabled "Allow hybrid sleep" in power options
    - Installed newest version of real-tek ethernet driver
    - Disabled "Allow Wake Timers" in power options
    - Set JavaScript Timer Frequency -> Maximum Power Savings in IE power options

    SOLUTION

    It turns out that for many users, the problem is actually a compatibility issue between Internet Explorer 9, and Skype versions 5+.

    There are currently 2 solutions:

    1. Uninstall Skype v5, and roll back to version 4. (Version 4.2.0.187 confirmed working)

    or

    2. Uninstall Internet Explorer 9 (Windows Update --> Installed Updates --> IE9, Uninstall)

     

    Skype Bug Report: https://jira.skype.com/browse/SCW-2796

     

    Monday, June 20, 2011 7:56 AM
  • I tried all of your helpful replies above and unfortunately none of them worked.

    However, the following worked for me. For anyone else this may help...

     

    In the Local Area Connection Properties, click Configure... On the Power Management tab, untick 'Allow the computer to turn off this device to save power'.

    Now my computers can happily sleep with Windows 7 SP1.

    Monday, September 5, 2011 12:07 PM