none
Boot up hangs at "Please wait" for "ever". NLA Service is culprit.

    Question

  • We've been having a LOT of difficulties with Vista on our laptops recently.  The bootup process goes relatively fast until it gets to the "please wait" screen just before CTRL-ALT-DEL would normally appear.   The laptops can sit here for 10 minutes or 10 hours.  No rhyme or reason.  Nothing in the event log says anything about what it is trying to do.  Everything seems normal except this LONG wait at "Please Wait..."

    After some experimenting, I determined that if I disable the "Network Location Awareness" service, everything works fine.   Better than fine actually... everything is faster than ever.  Boot up takes 45 seconds from power on to the CTRL-ALT-DEL screen.

    My question is, why all of a sudden is this an issue?  Why would NLA cause huge hangups and delays on boot?  By disabling it, it seems to be fixed, if not better than before.  If I leave this disabled, is it going to break anything else?   Minded, we are a school district.  We have a local network.  No internet acess unless through a proxy.  Relatively simple network setup.   2008 servers.  1 domain controller.

    Ideas?
    Wednesday, October 28, 2009 12:10 PM

All replies

  • Hi,

     

    Thank you for posting here.

     

    Based on my research, system needs to judge the current network profile/location when applying computer policies because some policies may depend on such information (e.g., Windows Firewall policies.); so, when it starts, it will wait for the NLA service. If the service does not work properly or it is conflicted, it may lead to this issue.

     

    At this time, please try the following to have a check:

     

    Clean boot

    =================

    1)   Click the Start Button type "msconfig" (without quotation marks) in the Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2)   Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3)   Click the "Startup" tab, click "Disable All" and click "OK".

    4)  Please ensure that NLA is not disabled.

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    NOTE: we can go back to normal boot by running msconfig again and checking on Normal Startup in the General tab.

     

    In the Clean Boot Environment, the third party services and applications are disabled, please check the issue persists.

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You may use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Thanks.

     

    Nicholas Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Nicholas Li - MSFT
    Thursday, October 29, 2009 11:39 AM
    Moderator
  • Hi,

     

    I just want to see how everything is going. If you have any questions or concerns on the recent information I've provided you, please feel free to let me know. I am happy to be of assistance.

     

    Thanks. Have a great day! 

    Nicholas Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Nicholas Li - MSFT
    Tuesday, November 03, 2009 4:18 AM
    Moderator
  • Sorry it took me so long to reply.  I have already tried everything you had suggested.  I spent an hour or more disabling services and rebooting.  As I had stated, I basically disabled everything in MSCONFIG.  That did nothing.  The next thing I started doing was disabling services.  I disabled everything that wasn't microsoft supplied.   That did nothing.  Then I disabled pretty much every service that was set to automatic.  Every time I rebooted, the system came up quickly without incident.  I began re-enabling services and rebooting to see if any one of those caused the problem to come back.   The only time the problem came back was when I re-enabled the NLA service.   I then disabled NLA once more and re-enabled EVERYTHING I had done.  Everything... services, msconfig, startup groups... etc.   The system once again booted quickly without problem.   Once I re-enabled the NLA service again, the problem returned.

    I then moved to another computer that was having the issue.  I left everything as-is and went straight to disable the NLA service.  On a reboot, the problem was gone.   I enabled the NLA service and reboot, the problem returned.

    Something is causing NLA to hang up on boot and cause a "Please wait" screen that will sit for 30 minutes or more.  It doesn't happen on every machine, but on the machines that it is happening on, disabling the NLA fixes it every time.
    Sunday, November 15, 2009 9:35 PM
  • Hello, I am experiencing a similar issue, with Windows 7 Ultimate, the system updated recently with a critical patch, recently being in the last few days. The system gets to the "Please Wait" screen and there it sits. I have disabled the NLA Service as Chuck5566 has commented on with resolving his problem. Unfortunately that did not cure mine.

    I have attempted the MSConfig routine that was also discussed in this posting, and I get the same result... the system hangs at "Please Wait"

    Any additional help would be nice.

    Thank you

    A.Hohensee
    Computer Nook
    Microsoft Partner
    (909)381-3446
    allen@cnook.com
    ahohensee@hotmail.com
    Thursday, December 10, 2009 6:27 PM
  • My system was hanging at "Please Wait" as well.  Disabling the NLA service fixed it.    Thanks!

    Tuesday, March 23, 2010 1:11 PM
  • I'm running Windows 7 x64 on a Dell laptop.  I could sometimes make this go away by switching off the wireless radio.  Not always, though.  I ended up setting the service to manual start.  So far, go good.  I'll post back later if I have to disable the service.  Thanks for the tip.

    Greg Wilkerson

    Wednesday, April 07, 2010 12:01 AM
  • I had this issue as well.  Disabling NLA worked for me, but now I have the red x through my network icon in the system tray.  Any idea why NLA would all of a sudden cause this?  Didn't have a problem until last week, and it happened on both a laptop and a pc with Windows 7 pro.  Running on sbs 2008 domain with folder redirection.
    Tuesday, May 04, 2010 2:07 AM
  • Same problem for me, however it started just after I had registered the PC's (Vista) to a brandnew SBS2008 domain. When removing it from the domain, I again reach alt-ctrl-del stage, as soon as I link it to the domain again, they go into indefinite hang on 'please wait' screen.
    Friday, July 02, 2010 6:15 AM
  • John,

    When I was running Vista, I found that issue to be related to the group policy service.  If I recall correctly, the group policy service can't be disabled (I wasn't using it).  So, I renamed the group policy dll (can't remember the name) to something Windows couldn't find.  You'll get an error in your event log everytime you start the computer, but it booted much faster.

    Greg

    Friday, July 02, 2010 10:42 AM
  • I have exactly the same issue as A.Hohensee and wondered if there has been any progress on this. My client's laptop is a Lenovo T410i with Windows 7 Pro and is not a member of a domain, using only local profile. So far, I've tried:

    • Booting to Safe Mode and disabling all Services - doesn't work
    • Downloading the password-protected KB fix from MS but you can't run this in Safe Mode!
    • Rolling back to the last System Restore point
    • Rebuilding from Recovery Partition

    Always the same result and I can't pinpoint which update it is that breaks it. I'm now looking at potentially paying MS £199 to fix a problem that they caused and the published potential fix for which is useless! Any help appreciated.

    Alan Rogers
    DreamGenius Ltd
    +44 17 3730 0480
    info@dreamgenius.net
    dreamgenius@hotmail.com

    Thursday, July 08, 2010 10:47 AM
  • Hello Alan,

    I was wondering if you were able to get anywhere with this issue.  I too am in the same boat and have tried all the above with no luck.

     

    Ian Gillanders

    Wednesday, August 25, 2010 6:51 PM
  • Hi Ian,

    That same problem started with my new Dell laptop (E6410), running Windows 7 Enterprise.  By systematically doing the "Clean Boot" procedures, I found out that the "Audio Service" by IDT, Inc. was the culprit.  Through "msconfig", I disabled it both from the "Services" and "Startup" tabs - the system came up fine.  I did not have to disable NLA or any other services.

    • Proposed as answer by Fabio Marreco Thursday, January 12, 2012 9:53 PM
    Tuesday, October 19, 2010 8:25 PM
  • We have the same problem with many Win7 Ent machines, but a different cause. It turns out that the Microsoft SCCM client is "bloating" the WMI Repository (c:\windows\system32\wbem\repository). When the repository gets big (above 150-200MB) then the Please Wait screen is shown for 4-6minutes. When disabling the "Windows Management Instrumentation" service (winmgmt), then the problem disappear. However, this is of cause not a solution as this is caused by the SCCM client, the solution must be to get the SCCM client fixed.
    • Proposed as answer by james1seattle Friday, March 04, 2011 1:16 AM
    • Unproposed as answer by james1seattle Friday, March 04, 2011 1:16 AM
    • Proposed as answer by s10xtremenlow Tuesday, March 13, 2012 12:00 PM
    Friday, February 25, 2011 10:58 AM
  • Download the Vista Recovery Disk here: http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/. Create boot disk from .iso. Boot from disk. Chose "Repair Computer". Chose "Vista Installation". Chose "Command Prompt". Type "bootrec.exe". Ignore all four choices.  Type "bcdedit /export  c:\bcd_backup". Type "c:". Type "cd boot". Type "attrib -s -h -r". Type "ren c:\boot\bcd bcd.old". Type "bootrec /rebuildbcd". Type "y" for yes. Restart. Problem solved.
    • Proposed as answer by Tabish.asifi Wednesday, March 09, 2011 5:48 AM
    • Unproposed as answer by Tabish.asifi Wednesday, March 09, 2011 5:48 AM
    Friday, March 04, 2011 1:27 AM
  • I just tried booting in safe mode and selected the last known good configuration..

    and it worked ..solved my problem.. 

    Wednesday, March 09, 2011 5:50 AM
  • @james1seattle:  Your solution of backing up and replacing boot files: How about an explanation of why it works.  Because....

    ....excact same  "please wait" occurs frequently during Windows XP installing, for repair install or new, using OEM cd.  Even if first run repair commands in recovery console.


    Friday, March 25, 2011 6:44 AM
  • I have been having the same problem on a windows 7 pro machine.  Disconnecting the ethernet cable before boot allowed it to start with no problem.  The compute is connected to SBS 2011, however I know the server is still having a problem pushing group policies to the domain computers.
    Monday, July 18, 2011 7:00 PM
  • We have been seeing a few situations where a laptop that is not connected to any wired or wireless network connection will hang at “Please wait” for quite a long time.


    Go to -- Network Location Awareness properties or local computer

    step 2 : Then you see a window  Network location then go to Generl Tab
    step 3 : Go to startup type : it should be automatic  or we suggest trying to set the NLA Service to Automatic (Delayed Start). If that still causes the stall at start up, then change the service to Manual so that the OS can still fire up the service if it is required.

    Once the setting change is complete, the laptop should boot up and display the logon screen in essentially the same amount of time whether connected to a network or not.

    Saturday, July 30, 2011 6:55 AM
  • Same thing here, 

    I have an Dell Latitude E5410, also Windows 7 Enterprise. when I disabled Audio Service by IDT, the system worked fine. 

    Thursday, January 12, 2012 9:55 PM
  • I'm seeing this problem too, but my system doesn't have the IDT audio service, and I've tried disabling NLA.

    Here are some other notes:

    "Please wait..." shows for almost exactly an hour consistently.

    I've found nothing glaring (to me) in an enourmous ProcMon (SysInternal) boot-time capture, but I wasn't really sure what I was looking for.

    It boots pretty much normally (minutes) if I disconnect the network.

    One suspicion I have is that software-install group policies that refer to a network path on a decomissioned server are at fault.  However I've created a test OU and turned off those policies, and the only one claiming update is readily available.

    Is there any way I can more closely monitor boot-time semiphors?  Or Boot-Time GP processing?

    Tuesday, February 14, 2012 11:28 PM
  •     I  had this same problem with a computer running Win 7 Pro in a domain.  I disabled NLA , which did not work.  I then removed the computer from the domain and manualy deleted the computer object from the Active Directory.  After rejoining the computer to the domain I checked the AD again to make sure the object was created, reenabled network discovery on the machine and remapped network drives, reenabled NLA and then did a restart.  It all worked fine. No more problems.  Anyone with the same setup may want to try this.
    Thursday, March 01, 2012 10:09 PM
  • We have the same problem with many Win7 Ent machines, but a different cause. It turns out that the Microsoft SCCM client is "bloating" the WMI Repository (c:\windows\system32\wbem\repository). When the repository gets big (above 150-200MB) then the Please Wait screen is shown for 4-6minutes. When disabling the "Windows Management Instrumentation" service (winmgmt), then the problem disappear. However, this is of cause not a solution as this is caused by the SCCM client, the solution must be to get the SCCM client fixed.

    We are experiencing the same exact thing... Were you able to ever correct this specific issue with SCCM?
    • Proposed as answer by s10xtremenlow Friday, March 16, 2012 11:20 AM
    Tuesday, March 13, 2012 12:01 PM
  • I found this link that helped troubleshoot the issue:

    http://soeteam.blogspot.com/2011/03/howto-turn-windows-7-please-wait-into.html 

    Turn on verbose messages about what is actually happening during the "Please Wait" screen.  In my case, some old GPO-based installs were still being applied to some client machines.  

    Whatever is happening, flipping this registry setting to turn on verbose status messages should aid troubleshooting.

     
    Tuesday, March 13, 2012 5:38 PM
  • We have the same problem with many Win7 Ent machines, but a different cause. It turns out that the Microsoft SCCM client is "bloating" the WMI Repository (c:\windows\system32\wbem\repository). When the repository gets big (above 150-200MB) then the Please Wait screen is shown for 4-6minutes. When disabling the "Windows Management Instrumentation" service (winmgmt), then the problem disappear. However, this is of cause not a solution as this is caused by the SCCM client, the solution must be to get the SCCM client fixed.


    We are experiencing the same exact thing... Were you able to ever correct this specific issue with SCCM?

    I found the issue. There is a hotfix from microsoft that stops the WMI from running a full check on each bootup.
    Friday, March 16, 2012 11:20 AM
  • s10xtremenlow, What is the hotfix you found I would like to look at it
    Thursday, June 28, 2012 1:42 PM
  • found the issue. There is a hotfix from microsoft that stops the WMI from running a full check on each bootup.

    It would be nice to know, to what KB number are you refering?

    My situation is this:
    - Windows 7 SP1 x86 images from SCCM.
    - Lenovo and HP laptops joined to domain
    - randomly laptops hangs at "please wait" but if I kill the power and start it up, it goes fine to CTRL+ALT+DEL
    - there is no effect, wherever laptop is connected to LAN, or WLAN, or both at the same time
    - no sign of any errors or warnings in event log during this.

    Friday, July 20, 2012 11:11 AM
  • I think this might be the one:

    http://support.microsoft.com/kb/2617858

    But there's a list of WMI related hotfixes here:

    http://social.technet.microsoft.com/wiki/contents/articles/1398.list-of-wmi-related-hotfixes-for-windows-7-and-windows-server-2008-r2-en-us.aspx

    Hope this helps.

    Wednesday, August 01, 2012 8:02 PM
  • I was having the same issue with a clients computer, on a hunch I removed it from the domain, rebooted then added it back to the domain and everything is working great now.  Not sure if this will help anyone else but thought I would throw it out there.
    Thursday, August 02, 2012 9:49 PM
  • I was having the same issue with a clients computer, on a hunch I removed it from the domain, rebooted then added it back to the domain and everything is working great now.  Not sure if this will help anyone else but thought I would throw it out there.

    That is too heavy procedure in business enviroment where you have many thousands workstations. If Network Location Awareness Service startup disablation is the key result in Windows 7,  not having "Please wait" states anymore, it would be easiest way to configure this service settings with Group Policy. I´m gonna do this on random computers, and see if that helps.

    Sunday, August 05, 2012 7:53 PM
  • Did turning NLA off via Group Policy work for you?  We're experiencing this with our new image (7 Enterprise 64Bit) but not our old (7 Enterprise 32Bit) - verbose logging shows wait for "User Profile Service" is about 45 seconds (sometimes more) and Preparing Desktop at 20+.  We've looked at everything including the WMI hotfix listed above, but no fix so far.
    Thursday, September 13, 2012 10:04 PM
  • Did turning NLA off via Group Policy work for you?  We're experiencing this with our new image (7 Enterprise 64Bit) but not our old (7 Enterprise 32Bit) - verbose logging shows wait for "User Profile Service" is about 45 seconds (sometimes more) and Preparing Desktop at 20+.  We've looked at everything including the WMI hotfix listed above, but no fix so far.

    Well yes, perhaps. At least, I haven´t heard any more complains about hanging in "Please wait" - state.
    Friday, September 14, 2012 12:48 PM
  • We have had this issue across a number of machines and we found a fix for it, I've put together and guide with all the files you'll need here:

    http://www.techygeekshome.co.uk/2012/10/welcome-screen-hanging-cannot-run.html


    http://itguru82-sccm.blogspot.co.uk/


    • Proposed as answer by itguru82 Saturday, November 17, 2012 8:05 AM
    • Edited by itguru82 Tuesday, August 13, 2013 8:23 PM Updated Links
    Wednesday, November 07, 2012 9:22 PM
  •      I had this issue with a customers computer after a fresh install of Windows 7 Home Premium when trying to boot into safe mode.  It turned out that the issue was pending updates that had apparently installed in the background and needed to perform pre-logon action.  Due to the boot into safe mode, they could not finish configuring and caused the freeze at "Please Wait...".

         Sadly I had booted into Safe Mode by changing msconfig so I could not seem to boot into normal mode.  I waited about 15 minutes at the "Please Wait..." screen and it finally asked for the password.  After restarting normally it failed updates, so I just re-installed updates and it went back to working normally.  Moral of the story, just wait! Then boot into normal mode and run Windows Update to see if it was attempted updates causing the "freeze".

    Tuesday, November 20, 2012 3:11 PM
  • There are a few reasons why this happens, could be custom hardware inventories, or large collections for AI and software metering. Suggest toning down some of these settings and see if this helps.

    http://itguru82-sccm.blogspot.co.uk/

    Wednesday, December 05, 2012 3:07 PM
  • Thanks this fixed my issue!

    Tuesday, January 29, 2013 1:08 AM
  • I had a similar problem at work. We had migrated to a new domain controller. Some computers started hanging at the "Please Wait.." message on boot up. We did everything people posted here: disabled NLA, enabled verbose logging, disabled all third party services and startups in msconfig, removing and readding to domain, etc. No success. All we know is that if its on the network (hooked up to lan) it hangs. Remove the lan cable or remove the computer from the domain then it boots up fine.

    TRY THIS: Go to Run and type in gpedit.msc. From there go to Computer Configuration > Administrative Templates > System > Scripts > and then enable Run Startup Scripts Visible. Reboot. For us we got an error window instead of the "Please Wait" message that looked like this..

    https://www.dropbox.com/s/w6r8dv3wit6om5v/Computer%20hangs%20at%20Please%20Wait.png

    This is as far as we've gotten. Hope it helps you guys out.

    Tuesday, February 05, 2013 4:57 PM
  • -------------SOLVED IT FOR ME--------------------

    -------------DISABLE CREDENTIAL PROVIDERS---------------

    Two separate instances on two separate Vista installations yielded the same solution.

    The problem was caused by third-party (Toshiba SmartFace, Digital Persona, HP ProtectTools, SimplePass,) software having attached at:

    "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers"

    The credential providers seem to have a problem connecting with their service, or their service having some other problem/delay.

    So the system delays waiting on the credential provider, which may be waiting on it's service, which may be waiting/faulting itself.

    Use SysInternals AutoRuns utility to see and disable third-party Credential Providers, restart.  BroadCom installs them with some products as well but to date, haven't had any issue out of them.  (perhaps barring unknown conflicts with other CPs)

    Hope this helps.

    Saturday, March 16, 2013 1:25 AM
  • I've had the same problem on it getting stuck at the "Please wait ... " screen for like 15 to 20 minutes every time! I also noticed that due to this my taskkill windows command had stopped working (for reasons unknown to me). I then checked, my wbem\repository directory had grown up to 2.67 GB!! I then followed these set of instructions by Scott Hanselman : http://www.hanselman.com/blog/SvchostexeSucksCPUAndRebuldingTheWMIWBEMRepository.aspx and rebuilt the repository after deleting it. Now my time has reduced to 1 minute. I enabled the service again.
    Thursday, March 28, 2013 10:29 PM