none
RDP client cannot connect to RDS CB / GW - RDWeb works RRS feed

  • Question

  • Hi all,

    Today i decided to try Microsoft RDS on server 2019. my normal user can get the session based desktop via https://RDSCB/RDWeb but if i try to open RDP client and point to RDSCB.Domain.Lan then i get 'The connection was denied because the user account is not authorized for remote login'

    Now i have not added the security group "DOMAIN\RDS Users" to any local groups on the RDS servers. not sure if thats required or not.

    Hoping someone can tell me if i should be able to just open RDP client and connect or if thats not possible. not sure what could be wrong.

    Followed this guide, although i have 2 servers https://www.slashadmin.co.uk/how-to-setup-a-single-server-rds-deployment-using-server-2016/

    Tuesday, January 28, 2020 12:42 PM

Answers

  • Hi,

    It is intended that users will launch RemoteApps/Desktops to an RDS deployment using one of the following methods:

    • RD Web Access
    • Remote Resources (Mac, iOS, UWP, Android)
    • RemoteApp and Desktop Connections (in Control Panel and GPO setting).  RemoteApps/Desktops show up in the Start Menu with this option.

    In this way the client will download .rdp files with proper settings for the deployment.  When a RemoteApp/Desktop is launched, the client first connects to the broker (via RD Gateway if needed) and sends the broker a hint that contains the target collection.

    It makes sense that you are seeing the error when manually connecting via the Remote Desktop client because you are not using a .rdp file with all the necessary settings.

    -TP

    Wednesday, January 29, 2020 5:55 AM
    Moderator
  • Hi,

    Internal users do not need RD Gateway to connect assuming they can reach the RDS servers via the LAN.  They still need RD Web Access so they can access the webfeed.

    -TP

    Wednesday, January 29, 2020 4:58 PM
    Moderator

All replies

  • Hi,

    It is intended that users will launch RemoteApps/Desktops to an RDS deployment using one of the following methods:

    • RD Web Access
    • Remote Resources (Mac, iOS, UWP, Android)
    • RemoteApp and Desktop Connections (in Control Panel and GPO setting).  RemoteApps/Desktops show up in the Start Menu with this option.

    In this way the client will download .rdp files with proper settings for the deployment.  When a RemoteApp/Desktop is launched, the client first connects to the broker (via RD Gateway if needed) and sends the broker a hint that contains the target collection.

    It makes sense that you are seeing the error when manually connecting via the Remote Desktop client because you are not using a .rdp file with all the necessary settings.

    -TP

    Wednesday, January 29, 2020 5:55 AM
    Moderator
  • Hi TP,

    That makes sense, I did find the control panel one after i swapped from a remote desktop to remoteApp and then i had Wordpad showed up twice on my machine :) one as a work resource.

    I can assume i can push out RemoteApp and Desktop Connections  settings via GPO so people do not need to do this themselves or i guess they can use the new Remote Desktop app where you can add a feed and that way I can also get it working.

    Not related to this subject but do you happen to know if the gateway is always required? Not sure if this is only for internal use, can we just connect to the connection broker?

    As it stands we do need to allow access from outside world and in, so was going to put Web Access and Gateway in the DMZ. But then i need to know if i need to point all clients to the gateway or if for internal people its just the connection broker.

    Wednesday, January 29, 2020 11:38 AM
  • Hi,

    Internal users do not need RD Gateway to connect assuming they can reach the RDS servers via the LAN.  They still need RD Web Access so they can access the webfeed.

    -TP

    Wednesday, January 29, 2020 4:58 PM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang  

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 3, 2020 9:51 AM
    Moderator
  • Hi TP,

    Thanks for the clarification. I also used the new remote desktop client to add a feed, that also works :)

    Monday, February 3, 2020 10:16 AM