Windows 7 and classpnp.sys safe mode loop. RRS feed

  • Question

  • Hello,
    First of all this is an outline to the system I am running.
    Acer Aspire X1800
    Brought as a Windows Vista Home Premium 32bit, has now been upgraded to the equivalent in Windows 7.
    Intel® Core™2 Quad processor
    NVIDIA® GeForce® 7100 and nForce® 630i
    4 GB of DDR2 667/800 MHz SDRAM (single-channel support on two DIMMs)
    Serial ATA hard disk 1 TB
    AMI PnP BIOS compatible with SMBIOS 2.4
    • PCI Express® 2.0 x16 slot
    • PCI Express® 2.0 x1 slot
      • Integrated NVIDIA® GeForce® 7100 graphics solution
    PCI Express® 2.0 x16 graphics card support (low-profile)

    I have been running Windows 7 now for some time a month or two and have no problems until now. I wanted to put my computer into safe mode so I can install the second disc of Fallout 3 Game of the year Edition. Frist of all I restarted the computer and used the F8 trick which did not work. The computer just booted into regular old Windows 7. So then I went through the msconfig way of things.
    Now it is important to note that I had this problem when installing Fallout 3 on the same machine but running Vista. However the computer managed to "fix" it self back then.

    The computer loads through all the drivers until it gets to C:\windows\system32\drivers\classpnp.sys
    It stops loading here and tries to go into safe mode. The computer then comes up with a message saying entering Windows safe mode (or words to that effect) and lists some of the system details. The screen then changes to a blank screen with a mouse cursor in the middle of it. The computer then shuts down and begins to restart itself. It has gone into a infinite loop of restarts.

    Ideas I have tried.

    1. Pressing F8 brings up the boot menu, i have tried all options available in that. Nothing worked.
    2. Interrupting the start up with a fake power cut. This resulted in the computer showing two options. Start Windows normally and start Windows recovery. Neither worked.
    3. I have tried renaming the problem file C:\windows\system32\drivers\classpnp.sys to C:\windows\system32\drivers\classpnp.old
      This resulted in the computer loading until the next value C:\windows\system32\drivers\disk.sys The computer then did all the usual loading. However before restarting the it showed the dreaded blue screen of death. It was over before i could see the error message that it contained.
    4. I have tried resetting to a prior system date. this does not work either.
    Other than that I have not been able to get into windows or anything else. The reason I am able to post this is a have access to another computer for the mean time.

    Any ideas on this would very appreciated



    Because the computer is Acer it should have a working E Recovery on it. However i can't remember if i deleted this or not. Will try using the hidden partition in the near future. This will most likely send me back to Vista but its a risk I am willing to take at this stage.
    • Edited by Limbix Tuesday, March 9, 2010 10:24 PM New Idea
    Tuesday, March 9, 2010 9:44 PM

All replies

  • I know replying to my own thread is stupid, but this is for every one who is having this problem.
    I have discovered that restoring to prior point in time does not work. So scratch that idea.

    So far I have six other solutions. Solution 1: Tap F8 until you see the boot options.
    Select repair system (the first option on the list).
    Let this load and follow the on screen instructions.
    Click the Command Input (the bottom option on this new list) This will open a window resembling DOS.
    Type in "Rename C:\windows\system32\drivers\classpnp.sys classpnp.old Press enter and then close.
    Restart your computer.

    This does not work. This just caused a Blue screen and a continuation of the infinite restarting loop I was suffering before. 

    Solution 2: I have found system repair disks for both Windows 7 and Vista. If you brought your computer from a major retailer you most likely did not get these disks. Also if your computer is from a company such as Acer, Compaq, HP etc you most likely did not get these disks either.
    They are available from this web site, http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/
    Download the one that suits your OS (all free).
    You will then need to download Imgburn. This program will put your recently downloaded recovery disc onto a disc (this is necessary because of the file type). Imgburn is freeware from this site http://www.imgburn.com/
    Shut down your computer, and restart. Put this disk in your computer and boot from it. Follow the instructions. Once completed and if works you may find some of your docs photos etc missing. If you can find away of backing these before doing this I recommend doing so.

    As yet I have not tried this, I will post if this works. 

    Solution 3: This requires more downloading and the software Imgburn that I talked about above. You need to go this web site http://www.ubuntu.com/ and download the software Ubuntu 9.10 Desktop. Once downloaded the process is similar to the one above. Burn the downloaded ISO file, using ImgBurn, to a disk. Shut down your PC and start it up again.
    Once that is completed insert the disk into the computer and boot using the Ubuntu software. This acts like a Operating system.
    Now that you are somewhat able to use your computer find the file C:\windows\system32\drivers\classpnp.sys Rename Classpnp.sys to Classpnp.bak
    Now got this website http://www.hotfile123.com/index.php?q=classpnp+sys and download the classpnp.sys file. Replace the old one that you have renamed with the newly downloaded one.
    Exit and restart your system making sure you are going back into Windows 7 not Ubuntu. The system will lag for a bit but should eventually go into Windows 7 safe mode (assuming you ticked the Safe mode box in msconfig).

    As yet I have not tried this, I will post if this works. 

    Solution 4: Wait for your computer restart again (or turn it back on). When your computer loads to manufacturers screen (one of the first screens you will see when starting you computer). Press either alt + F10 or alt + F11 (Acer users with have to use alt + F10).
    Provided you still have Acer eRecovery installed, (or your brand of recovery system) it should come up. Once the software is loaded click the option that resembles RESTORE TO FACTORY DEFAULT SETTINGS. From this point the software should update the C drive with a fully functional image from a secret partition on the hard drive.
    It is very important to note that this Secret Partition is very secret indeed, you can not see it or touch in almost any other way except for dong this. This process should take around ten minutes if working correctly.
    When the software has finished running press OK and reboot your computer with fingers crossed (and any other limbs and appendages you have).

    As yet I have not tried this, I will post if this works.

    Solution 5. Wait for your computer start. Tap F8 to bring up the menu. Click system restore, this is the very first option. Wait for this to load. If its your first time, be gentle it may take a little while. Once it has loaded click on the Command Prompt and type in "Restore" with out the quotation marks of course. Press Y and go with the flow.

    As yet I have not tried this, I will post if this works.

    And lastly the worst option I can think of. Solution 6: Reformat and reinstall your choice of windows; XP, Vista, Windows 7 or you could even go 98 if your system is compatible.

    I don't really want to do this but I may have to yet. I will be going back to vista as I will wait for Windows 8. Luckily I also have all my video and music content saved on hard drive. The only thing I am going to loose are my save game files but I that is no where near the end of the world now is it.

    There is also the last, well can't really call this a solution lets call it an option.

    Option 7: Find the nearest high rise building, the tallest building in your area should do. Climb to the top using any means necessary (ladder, stairs, elevator etc.) and drop it off the top. This will wipe your system and relieve any stress built up by the problems caused by CLASSPNP.SYS
    • Edited by Limbix Wednesday, March 10, 2010 1:29 AM Came through with bad format. My bad
    • Proposed as answer by Fernan82.Net Thursday, November 20, 2014 2:21 AM
    • Unproposed as answer by Fernan82.Net Thursday, November 20, 2014 2:23 AM
    • Proposed as answer by Marc986 Wednesday, September 14, 2016 2:12 PM
    • Unproposed as answer by Marc986 Wednesday, September 14, 2016 2:12 PM
    Wednesday, March 10, 2010 1:17 AM
  • Ok so I have fixed the problem.
    For some of you who have read this thread your not going to like the answers.
    Solutions 2 and 4 worked. Option 7 would have achieved all it set out to do (seeing as i managed to fix my computer I didn't not try).
    For those you who have not backed up there computers you will loose all data that was not backed up.

    I am not going to re-upgrade to Windows 7 as it was pointless. I found no benefit other than it looked a little cooler than its counterpart of Vista. Also with Windows 8 on the horizon I don't see the point.

    I still havent solved how I am going to get fallout 3 working with crashing in safe mode again. I have yet to understand the reason that why classpnp.sys did this. Also the reason on my computer under the vista operating system is still unclear. 

    If there are any ideas, let me know.
    Wednesday, March 10, 2010 6:31 AM
  • Hello,

    The problem should be caused by the corrupted system files. Try to perform an in-place upgrade to repair:

    In-place Upgrade
    1. Insert the Windows 7 DVD in the computer's DVD drive.
    2. Click Start and choose Computer.
    3. Please find the "setup.exe" file in the DVD-ROM and double click it.
    4. Click Install now.
    5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows 7 without the key. Please choose to confirm.
    6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows 7.
    Wednesday, March 10, 2010 7:02 AM
  • @Thomas_77
    hi there

    Sadly I brought my computer from a leading retailer in New Zealand (where I live). As it happens when you buy the computer you do not receive a Windows 7 disc, or as I brought my computer just a week before the official release I got Vista.
    As you may see from my above post, I fixed the issue. In the past few hours also got fallout 3 installed with out going into safe mode.
    However thankyou for your input.

    Thursday, March 11, 2010 1:15 AM
  • Hello Limbix

    Thank you for your initial problem and the follow-up discussion on such a conundrum of a problem. As evidenced by the number of hits under Google for "Windows 7 boot sequence classpnp.sys" and 0 fixes, this problem is systematic of this OS. As such, this is a ticking time bomb waiting for the most inopportune time to strike.

    Furthmore, this problem has been known since RC1 of Windows 7. The problem still persists and there is no known remediation method.

    KB 925810 is a unique solution when the OS is healthy. When this phenomena occurs, KB 925810 is a hoax for Laptop users and systems purchased from a vendor without a hardcopy of the OS media. For Home builts with a purchased hardcopy of the OS, KB 925810 is the option. But the option is to reinstall as opposed to a repair.

    Using Ubuntu, to effect change by replacing CLASSPNP.SYS with a 6.1.7600.16385 version has produced mixed results. In addition, the method of downloading any file is fraught with problems of possible infection or worse yet a trojan. This essentially leaves Option 2 and 4 as the SOP for this OS failure mode on laptops.


    New Toshiba A500 i7 with 8 Gig - Windows 7 Professional (Business)

    A series of three critical patches were deployed to this machine at 9:30 pm on 5/26/2010 from Windows Update.  At 6:30 am 5/27/2010, the machine was discovered to have restarted and was stuck at the Starting Windows logo. Here were the initial steps taken to remediate the problem.

    Step 1. CTRL-ALT-DEL was used multiple times to restart the machine. Results: The machine did not restart.

    Step 2. Power recycled the machine.  Windows 7 offered to Launch Windows Repair on the OS. The repair was selected and completed with a request to restart. Results: The machine stops at the Starting Windows logo. Still stuck.

    Step 3. Restarted the machine through a power recycle. Pressed F8, selected last known good and restarted. Results:  The machine stops at the Starting Windows logo. Still stuck.

    Step 4. Restarted the machine through a power recycle. Pressed F8, selected Advanced options. Results: No options were available.

    Step 5. Restarted the machine through a power recycle. Pressed F8, selected Boot loggin and restarted. Results: The machine stops at the Starting Windows logo. Still stuck.

    Step 6. Restarted the machine through a power recycle. Pressed F8, selected Safe Mode with Networking. Results: The machine's last entry for the loading list was on CLASSPNP.SYS and hung up.

    Step 7. Began researching for the Windows 7 boot loading list for the before and after sequences to see if CLASSPNP.SYS was the culprit. Results: Found this discussion and many more. Spent too much time researching for a solution. Most ended in silence.

    Step 8. Considered taking the STATA drive and putting into an external enclosure. Results: Did not take this step as the machine is under warranty. It was purchased in April, 2010.

    Step 9. Going back over the Google research, discussion http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/64a52415-f9aa-448e-b79c-f4d9d27836c3 has Moderator Tim Quan MSFT stating that

    "To obtain the phone numbers for specific technology request, please refer to the website listed below:



    This support site will take a user to a list of vendors. The Toshiba link was selected. The link is the Toshiba home page. The Support link was selected and a direct call was made to Toshiba at 7:30 am on 5/27/2010. A Toshiba case was opened. All 9 steps were presented to the support person and as directed the machine was put into a Factory reset mode. Results: The machine has completed rebuilding as of 11:11 am 5/27/2010. Windows update patching is continuing the assult to be "secure".


    Comments: One thing is certain, to be secure in one sense is have a machine in an inoperable state. However business cannot operate in an inoperable state. Neither can a business operate in an insecure state. So, to receive an OS patch which causes the machine to be inoperable, has the quest to be secure been reduced to inoperability?


    Suggestion: This problem needs more eyes and a better tracking method.

    1. Is this a vendor issue, e.g. Motherboard, Memory, Hardware?

         1a. Is this lot specific?

         2a. Is there a driver mismatch?

    2. Is this a process/sequence issue?

    3. Is there a recovery process other than "Scorched earth"?




    risc of KY 


    Thursday, May 27, 2010 3:29 PM
  • Non of the solutions that not imply a reinstall works for me, what fix this problem in an Acer Aspire 5536 with Win7 was to enter to BIOS and change the Hard disk mode from AHCI to IDE.
    Saturday, May 21, 2011 5:13 PM
  • @abracadabra3

    Thanks for posting this!  I tried a lot of different solutions I read about concerning this problem but none worked - except for a very similar solution to yours.

    The difference was my hard disk mode was already IDE, so I tried switching it to AHCI, and it worked.  After saving the BIOS settings I was taken to the screen that lets you choose which windows mode to boot in (safe, safe with networking, etc). I went into safe mode the first time. It seemed to hang on CLASSPNP.SYS again, but it went through after a pause. I rebooted into normal mode from there just fine.

    Out of curiosity, I also tried going back to IDE in the BIOS to see if Windows 7 had fixed the problem. No luck. Win 7 would not boot.  I put it back to AHCI and everything worked again.


    Thursday, July 14, 2011 9:53 PM
  • Also the same problem applying an stored image of Windows 7 taken from a DELL Optiplex 780 BIOS rev A08 and applied to a DELL Optiplex BIOS rev. A09, the BIOS default configuration was different between them. So had to change from RAID/AHCI to RAID/ATA. The error I had was "A patch is preventing the system from starting" Error code: 0x490 and the last driver loaded was classpnp.sys after loading it the system restarted and repair option from Windows 7 installation DVD was unable to repair it.
    Thursday, August 23, 2012 1:26 PM
  • Reigniting this ancient issue, as it just cropped up on a machine I was asked to look at.  A Dell Optiplex 380.  I spent the $20 for the Windows 7 recovery Disk suggested in solution 2 (he must have had enough downloads to start charging for this linux looking recovery package), but I am still looping after using the auto recovery options. 

    The machine I am working on appears to have no restore points.  I had booted up with BartPE, but I can't get network configuration working, and I can't get external media through USB working, so I can't even safely backup files before trying a system restore, which I guess is my next step, if I can find a system restore disk for cheap or free, as the owner does not have one.


    Saturday, July 27, 2013 5:13 PM
  • The Error is Batery.

    The problem is caused by the battery of the motherboard. You must stop short Connection pins for at least 30 seconds, 10 minutes would be best. then it should do a scandisk / r / f. Fixed that.



    Friday, September 20, 2013 9:50 PM
  • Hi,

    I know this is an old thread, but for the benefit of others reading it here's what worked for me.

    This happens if Windows cannot find your system partition. It has nothing to do with CLASSPNP.SYS. You probably noticed that right before CLASSPNP.SYS it loaded DISK.SYS, this is the driver that mounts your volumes properly, before that it's using a lower level driver. That's why if you delete or replace CLASSPNP.SYS it hangs on the next driver.

    In my case it was caused because I dual boot Windows and Linux and apparently I accidentally changed the type of my Windows parition type to HIDDEN NTFS WINDOWS (Type 27) or morelikely another tool gparted hid it because it has a single bad sector (probably since I got the laptop but I didn't noticed until the  warranty expired but it's been like that forever and not getting worse so the disk is ok). Other programs can do the same in Windows so you don't need to be dual booting for this to happen.

    So for me the solution was to boot to Linux and use FDISK to change the the partition type back to HPFS/NTFS/ExFAT (Type 7). You should be able to do the same on the command prompt of the Recovery Console in Windows, if not download KNOPPIX. After that it booted like new.

    Thursday, November 20, 2014 2:39 AM
  • Note that just before classpnp.sys is disk.sys which is apparently where the problem lies.
    For some people this was a hard disk hardware problem.

    I ran the system maintenance task which may or may not have fixed something and requested a file system check on reboot.

    After that, booting to safe mode worked again.  These steps may not fix your problem, but at least they should be harmless.

    Saturday, December 27, 2014 2:21 AM
  • The reboot after classpnp.sys has many reasons, but in my case it was that the SATA mode in the bios was for some reason changed from AHCI to IDE. After many hours of trying different solutions from the internet I just changed it to AHCI and - voilá - Windows started again.  
    Wednesday, May 25, 2016 4:27 PM
  • Holy crap, it worked! Went into the bios, primary SATI was AHCI but secondary was IDE. Switched it to AHCI, saved changes, and system booted promptly into windows 7. Nagging concerns: Why/how did that happen? Will it happen again? Ironically, the last operation I attempted was a full system backup using Acronis True Image 2015. It launched it Monday night, went to bed, and awoke Tuesday morning to find the system hung at "Starting Windows" and have been in PC hell-- until just a few minutes ago.

    Thanks for the suggestion, worked for me!

    Tuesday, July 4, 2017 7:03 PM
  • For the benefit of any latecomers:

    W7. I was stuck in this loop with no safe mode available and all recovery/repair options hanging.

    Solution for me: I entered Bios (F2 on my Dell XPS420) and one-by-one, disabled the HDDs that didn't contain the Windows partition, starting with one that had recently been flaky. Finally booted into windows okay.

    As for rescuing  the defective HDD (or for those whose main Windows drive is faulty) if you don't have a bootable W7 repair disc I can only suggest DLing a 'bootable WinPE' type rescue  utility on another machine, and running chkdsk etc using that instead.

    eg  Medicat USB https://www.geckoandfly.com/32030/bootable-windows-pe-recovery-repair/

    Saturday, August 3, 2019 10:49 AM