locked
Intel Virtualization (VT) Enabled in BIOS causes Windows 10, version 1809, build 17763) to hang/stop in early boot phase RRS feed

  • Question

  • A couple months ago I noticed that my vmware no longer runs.
    Like many I did the October update (1809) for Windows 10.
    Before that it all worked!

    Another app, AMIDuos reported that virtualization is off.
    So I checked in the BIOS and for some reason virtualization was off.
    So I turned it on.
    Windows 10 would never boot.
    So I turned it off.
    I noticed that my core I7 6700 CPU with hyper threading showed suddenly only 4 "cores". Never happened before.
    With VT-d enabled it showed again 8 "cores".

    In my case I can pin point the following:
    My current built is Version    10.0.17763 Build 17763. Before that all this was not a problem.
    Now after the upgrade:
    VT-d "ENABLED": no problem
    Intel Virtualization "ENABLED": Windows hangs on boot. No go. only in Safe mode.
    So no apps that require/run on virtualization will run, e.g. AMIDuos, vmware etc.

    You call that an "improvement?" Micro$oft?
    I call that a disaster!  hindrance, impediment, decay, declension, degeneration, deterioration, diminishment, downgrade, worsening, disablement etc. Gross incompetence as you just proven with the October 2018 update and the vanishing files!

    As the Germans say: "Verschlimmbessern". (To make worse by "improving")
    The American equivalent would be: "If it ain't broken don't fix it"

    SO MICRO$OFT, WHEN WILL YOU BECOME A COMPETENT BUSINESS NOT DELIVERING "UPDATES" WITH MORE BUGS AND DEFICIENCIES? WHEN WILL YOU STOP DELIVERING DEFECTIVE SERVICES AND PRODUCTS!?!?!?

    I'M SO GLAD YOU ARE NOT BUILDING CARS, TRAINS OR PLANES! WE'D ALL BE DEAD BY NOW, COURTESY YOUR BLOATED GARBAGE OS WINDOWS 10!

    GODDAM-IT! REALLY!


    Monday, December 10, 2018 4:40 AM

All replies

  •    Even if hardware virtualization is enabled in the BIOS, VMWare or VirtualBox will not run if the Hyper-V hypervisor is running. The hypervisor is active even before the OS loads and locks VT-x. If you want to run these even if Hyper-V is enabled you need to prevent the hypervisor from loading. (This will allow VirtualBox/VMWare to run successfully but of course Hyper-V vms will not run). You do that from bcdedit. If there is an entry for hypervisorloadtype set it to Off. If you have never installed Hyper-V or if it has been successfully uninstalled it should either be absent or set to Off already.

     As far as I know, VMWare and VirtualBox do not use VT-d. It is concerned with Directed I/O. It is not enabled on my  machines, and both VirtualBox and Hyper-V run as expected (on different host machines) with Windows 10 version 1809. 


    Bill

    Tuesday, December 11, 2018 6:30 AM
  • Thanks for the reply. Nope.

    Tried "bcdedit /set hypervisorlaunchtype off" still same issue.

    VMWare won't run (x64) without it. AMIDuos won't either.

    I think there's something fundamentally wrong with the last update of the OS.

    (Tried "refresh" but process reverts after OS safe setup phase.

    Rob



    Tuesday, December 11, 2018 4:17 PM
  •    It certainly looks like the only thing left to do.


    Bill

    Wednesday, December 12, 2018 1:35 AM
  • Having wasted a few hours and dozens of reboots I can say with certainty there is a defect in Windows 10 Pro, version 1809, build 17763.194

    This becomes evident as I find similar posts from other folks having the same issues. fact is all worked before until this year's (2018) updates.

    Intel VT ENABLED in BIOS and Windows freezes in the early boot phase.

    Intel VT DISABLED in BIOS and Windoz boots.

    So hello incompetent Micro$oft! Thank you for introducing new bugs with every update so I can use now less apps than before!

    Just like the decrepit Micro$oft Office 2016 who has more bugs and dysfunctionality let alone a hideous flat DOS days four-color design then all other versions combined in the last 20 years! it just shows how completely disconnected the company is wallowing, living detached from the outside realities in their own bubble world.

    This company needs to be broken apart because it has become a technology authoritarian despot who delivers garbage bugware and if anything works they will take it out and introduce dozens of more bugs! That to me is gross incompetence.

    What does it help me to have some "super sophisticated" bloatware operating system that now has been crippled by the company and I cannot run any virtual apps anymore!?!? DUH?

    Thursday, December 13, 2018 8:45 PM
  •   This is a user forum. Almost all users reading your rants are other users, not anybody to do with Windows 10 development.


    Bill

    Friday, December 14, 2018 1:24 AM
  • Still true and fact what I wrote. Which forum do you then suggest?
    Friday, December 14, 2018 2:24 AM
  • Hi,

    Just want to confirm the current situations of your issue.

    Have you also run sfc utility on the Windows 10 host to check for Windows system file integrity?

    Use the System File Checker tool to repair missing or corrupted system files

    Could you roll back to a previous OS version that VMWare can work properly on?

    Furthermore, we could list the updates that have been installed, and manually remove the hotfix may impact VMWare, please refer to this blog, 

    How to list updates that have been installed on your Windows Server 2016 machine.

    If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, December 17, 2018 9:38 AM
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 20, 2018 2:36 AM
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, December 25, 2018 9:56 AM
  • 1. SFC is another futile attempt as I belong to the "Stops at 17% club".

    2. Denies roll back to a previous OS as no longer available "because PC was updated more than 10 days ago."

    3.

    PS C:\Users\Robert> get-hotfix

    Source        Description      HotFixID      InstalledBy          InstalledOn
    ------        -----------      --------      -----------          -----------
    MAIN          Security Update  KB4465477     NT AUTHORITY\SYSTEM  10/17/2018 12:00:00 AM
    MAIN          Security Update  KB4465664     NT AUTHORITY\SYSTEM  11/16/2018 12:00:00 AM
    MAIN          Security Update  KB4467694     MAIN\Robert          11/16/2018 12:00:00 AM
    MAIN          Update           KB4469041     MAIN\Robert          12/08/2018 12:00:00 AM
    MAIN          Update           KB4470502     MAIN\Robert          12/13/2018 12:00:00 AM
    MAIN          Security Update  KB4470788     NT AUTHORITY\SYSTEM  12/13/2018 12:00:00 AM
    MAIN          Security Update  KB4471331     MAIN\Robert          12/05/2018 12:00:00 AM
    MAIN          Security Update  KB4471332     NT AUTHORITY\SYSTEM  12/13/2018 12:00:00 AM

    Saturday, December 29, 2018 3:57 PM
  • Yes!
    Saturday, December 29, 2018 3:57 PM
  • Nothing. everything I tried does not work. SoS.

    OS has also a "hangy" behavior to it as if it is searching fro something. (Obviously not the IQ to post a message i.e. "can't find xyz")

    I did notice that running msconfig.exe, in the general tab selective startup is selected "low system services" and "load startup items" or checked use original boot configuration is unchecked.

    "use original boot configuration" appears to be slightly gray but I can check it. upon clicking okay and getting a message from my security software that "werfault.exe" needs to send an error report out.

    If I select normal startup (load all device drivers and services) I get no boot or a blue screen



    Saturday, December 29, 2018 4:04 PM
  • Hi,

    Thanks for your update.

    I am currently performing research on this issue and will get back to you as soon as possible. I appreciate your patience.

    If you have any updates during this process, please feel free to let me know.

    Happy new year!

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, December 31, 2018 8:58 AM
  • any news? I have the same issue. I had Hyperv some time ago on my Windows 10 pro  to create a lab to  prepare some Microsoft exams . I removed the functionality because I didn't need it anymore. I want to prepare again for exams and need  some virtual machines for my Lab. When I try to reenable this functionality My Pc reboot and tries to repair  but it is not working. The only way to boot again is to disable virtualization in the Bios.

    Rgds


    Butor

    Tuesday, January 15, 2019 9:05 PM
  • I suspect something with the hyper V settings.
    I discovered that the cmd string "bcdedit /set {guid} hypervisorlaunchtype Off" Does not necessarily turn the hypervisor launch type off.
    I discovered that in easy BCD version 2.3 looking at the detailed (debug mode) boot loader configuration where it showed still as on despite having used the above string.
    Tuesday, January 15, 2019 10:32 PM
  • I've also been having this issue.  Windows 10 wasn't updating for the longest time because I had VT-d enabled, and when I turned it off in the BIOS to get up to date, VMWare no longer works properly.  Turning VT-d back on causes Windows 10 to no longer boot, so now I'm stuck in a tough spot.
    Saturday, February 2, 2019 9:20 PM
  •   Are you sure it was VT-d? That should have no effect on VMWare or Hyper-V. VMWare will not work if you do not have VT-x enabled or have Hyper-V enabled (because the hypervisor locks VT-x to itself). Credential Guard and Device Guard can also cause similar problems. This is what was being discussed above when hypervisorlaunchtype was mentioned. It prevents the hypervisor from loading.

     In any case, your string of problems sounds like file corruption. Have you run the sfc scan tools mentioned earlier in this thread?


    Bill

    Saturday, February 2, 2019 10:53 PM
  • I'm currently on "life support" with a specialist trying to figure out why my SFC stops at 18% despite that I have an error-free SSD.
    Tuesday, February 5, 2019 2:44 AM
  •   I admire you persistence - this thread is two months old.

     I would have done a fresh install long ago. I have never lasted a week.


    Bill


    • Edited by Bill Grant Tuesday, February 5, 2019 10:47 PM typo
    Tuesday, February 5, 2019 5:41 AM
  • I am encountering this same issue, except that I have performed a clean install of the OS.

    I am running version (edit: version 1809) that was cleanly installed. It was cleanly installed because I was unable to boot after enabling the Hyper-V service, and after disabling Hyper-V from safe mode did not resolve the issue.

    The boot process simply hung very early on, and nothing is reported in the event logs.

    I was able to figure out that disabling the virtualization feature on my Intel i5-2500K processor that I was able to get into windows properly, but without Hyper-V.

    I was then able to use BCDEdit to set hypervisorlaunchtype to "Off", and with that, I was able to enable the virtualization feature in BIOS again and boot properly.

    I'd love to be able to provide whatever additional information that would be helpful, but this problem is clearly not an issue of corrupt files.

    Sadly, it seems Microsoft no longer provides access to the older releases of Windows 10, which I feel is a mistake for people in my situation whose system is broken by the current version.


    • Edited by Matt Stetka Saturday, March 2, 2019 11:34 PM Correct factual error
    Saturday, March 2, 2019 6:46 PM
  • Following up, I have found a resolution to my problem, and it wasn't the 1809 update that caused the issue.

    I was able to get access to the 1803 release, as well as the 1709 release, and both of them failed at the same point in the boot process (1709 rebooted, 1803 and 1809 simply froze).

    I went through the process of disconnecting all unnecessary hardware I could, which also didn't help.

    Finally, I updated the BIOS of my motherboard, an Asus P8P67 Evo. I was running BIOS version 1502, and updated it to the 3602 version. The update process also reset my BIOS configuration, a step I hadn't previously tried.

    After the BIOS update, I was able to boot and use Hyper-V on Windows 10 1709. I then re-installed Windows 10 1809, and I am able to use Hyper-V on that version as well.

    I hope this information helps others facing this issue.

    Saturday, March 2, 2019 11:40 PM
  • Yeah. Weired things happens all the time these days. I've met with the exact problem which needed to a bios update to fix. And I've another machine which hangs at every hot-reboot even in windows 10 setup process. And after a BIOS update, it became fine. The other one needs a BIOS downgrade to over come the same problem 'cos it doesn't have a updated bios, only older ones.
    Saturday, May 4, 2019 6:55 AM
  • FYI, I have found a related WIN10 Intel Virtualization enabled problem that blocks updates. 

    SOLVED installation of WIN10 update 1806 with install of 1903 after disabling all Intel virtualization features in BIOS.

    My ASUS P6T motherboard based desktop would complete the v1806 update, but not reboot to a desktop.  It would complete 100% and reboot but fail on the reboot.  Alternatively, I tried to install the August 2019 1903 update.  Neither the USB or DVD with the 1903 iso file would boot.  I tried everything I could think of and followed hundreds of suggestions to install the updates.  Nothing worked.  The desktop would always fail to launch the desktop after reboot and would revert back to its prior version.  Finally, I went into the BIOS and disabled two setting related to Intel Virtualization.  Once Intel Virtualization was disabled.  I was able to easily install the 1903 update from an ISO I had copied to the desktop. The update installed smoothly and rebooted as it should.  ALL IS WELL in update land for now.




    • Edited by 1 BigGuy Saturday, September 7, 2019 4:44 PM
    Saturday, September 7, 2019 4:42 PM
  • I have the same problem.

    My PC doesn't boot if I active the VT-D. 

    This only happen in Windows 10 1909, not before.

    Intel i7 930 - X58


    http://www.gaap.dev


    Sunday, May 24, 2020 2:29 PM
  • Still an issue in Windows 10 2004.

    I thought it was fixed, enabled VT-d in bios and it was running for weeks.  Had a power outage.  After power restored PC was just stuck at a frozen Windows logo.  I went back in the bios and disabled VT-d after a few unsuccessful boots.  I saved the BIOS change and at next boot I held the power button down to signify a cold start next time.  I then cold started the computer and it booted back up.


    So changing the option a few weeks ago probably really didn't change it, because the save and exit ist like a reboot.  In my case my BIOS only must take effect if its cold started... so remove the power and reapply it and then as long as VT-d is disabled, Windows 10 boots fine.  I think this first started in 1803 or 1809, but its been a problem ever since.

    Thursday, July 9, 2020 7:09 PM
  • I can confirm this is also a problem in Windows Server 2019 (which is the same same OS build number as Windows 10 1809).

    On a vanilla Hyper-V VM, I enabled Device Guard and was then stuck at the Windows Boot Manager screen.

    Similarly to the workaround shared in this post, to fix a Hyper-V virtual machine stuck in this state, power off the VM. Then, run the following commands on the host within an elevated PowerShell prompt:

    Set-VMSecurity -VMName "VMNameHere" -VirtualizationBasedSecurityOptOut $true
    Set-VMProcessor -VMName "VMNameHere" -ExposeVirtualizationExtensions $false

    Then power the VM back up. It'll boot. However, I had turned on Device Guard with some features enabled with UEFI lock - so, the settings persisted.

    If you're on a physical system and not a VM, go into the BIOS and turn off Intel VT, as already suggested in this thread. The system should then boot. However, if you had Device Guard enabled with some features UEFI-locked, the settings will persist and reappear if you ever turn Intel VT back on.

    To fix:

    • Delete the key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeviceGuard
    • Open gpedit.msc, and navigate to Computer Configuration -> Administrative Templates -> System -> Device Guard. Open the "Turn on Virtualization Based Security" and set it to Disabled.
    • Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard (Note: if CurrentControlSet is not present, navigate to ControlSet001 instead). Change each registry value to a 0 (EnableVirtualizationBasedSecurity, Locked, RequireMicrosoftSignedBootChain, RequirePlatformSecurityFeatures).
    • Per documentation, you may need to navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA (again, if CurrentControlSet is missing, navigate to ControlSet001 instead) and then delete the value "LsaCfgFlags"

    Then, open an elevated command prompt and run:

    mountvol X: /s 
    copy %WINDIR%\System32\SecConfig.efi X:\EFI\Microsoft\Boot\SecConfig.efi /Y 
    bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader 
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi" 
    bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215} 
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS 
    bcdedit /set vsmlaunchtype off 
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=X: 
    mountvol X: /d

    Then reboot the system. You need to be at the console, because you will be prompted to press the Windows key or F3 to confirm disablement of any Device Guard features persisted in UEFI.

    When Windows boots up, shut down the computer or VM.

    If the VM is a Hyper-V VM, run the following command on the host within an elevated PowerShell prompt:

    Set-VMSecurity -VMName "VMNameHere" -VirtualizationBasedSecurityOptOut $false

    And if you need to use nested virtualization in the VM (not on by default), you can also run:

    Set-VMProcessor -VMName "VMNameHere" -ExposeVirtualizationExtensions $true

    And if you are on a physical system and not a VM, go to the BIOS/system setup and turn Intel VT back on.

    • Edited by Frank E Lesniak Tuesday, July 21, 2020 10:19 PM updated instructions
    • Proposed as answer by Frank E Lesniak Tuesday, July 21, 2020 10:19 PM
    Tuesday, July 21, 2020 8:46 PM