Windows 7 does not recognize IDE drives


  • Hello:

    Recently my computer has a strange problem.
    All IDE drives (cdrom and hard disks) stopped detecting inside windows.
    But they do detect and work well outside windows. (for example on startup disks).
    Right now, I have a DVDrom that outside windows works fine but inside windows
    does not work.
    When I go to Windows DIsk Management it always promts me with
    "INITIALIZE DISK: You must initialize disk before logical drive can access it"
    I click on for a Master Boot Record. just like everytime we put a new drive and
    it needs identifying and the first format. But when I click on it gives me this message:

    Virtual Disk Manager: The request could not be performed because of an I/O devide error.
    So in DISK MANAGEMENT I can see my DVDrom there as an "Unknown disk" and I cant inicialize it.
    On windows explorer its like it doesnt exist, as the drive letter is not there.

    THis happened from one day to another. ANd since Ive tried this DVDrom outside windows
    and it works fine. Im sure this is a problem inside my Windows 7, meaning its not a hardware problem.

    All other drives (SATA connection) work. I know this because I had another IDE drive on my computer
    and thought it was faulthy cause of this exact same problem, and bought a new drive, but a SATA
    which worked perfectly. So its only my IDE connections that dont work inside windows.

    Could someone help me with this problem please.
    thank you in a advance for your time and attention.

    Friday, April 08, 2011 9:10 PM


  • Hi David,


    Would you please let me know if you have installed any software or update before the issue occurring? Please perform a System Restore to an early point.


    The issue could occur if IDE drives' drive is not compatible with Windows 7, or its chipset is not compatible with Windows 7.


    I suggest going to the manufacture's site, downloading the latest drivers for BIOS, IED drives and chipsets for Windows 7 and installing them manually.


    Also make sure the BIOS is set to IDE/ATA.


    Best Regards,


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Friday, April 22, 2011 8:49 AM
    Tuesday, April 12, 2011 9:27 AM