The Settings For Ripping Music Could Not be Applied? RRS feed

  • Question

  • I upgraded to Windows 7 Professional a few months ago from Windows Vista Home Edition, so it did the clean install where it wiped out all my files and whatnot. I've just now gotten around to ripping my old Cd's, until now I have just been downloading new music. When I put a Cd in it says "Windows Media player cannot rip one or more of the tracks", Or more being the operative phrase, as it rips none of them. On another forum it looked like an easy fix, all I have to do is use a higher quality, which may or may not be true, seeing as how it won't let me change my rip settings at all. When I try it says "The settings for ripping music could not be applied". I have tried resetting WMP, I have checked the SFC, I've tested other Cd's, I've rebooted, I've disabled, re-enabled, and used the "Restore Media tool", all of which were suggested here: Nothing is working, all I want is to be able to rip my music. And I can't make it work. Someone, please help me. 

    Also, there is no location in my "rip music to this location" field in rip settings. And when I hit change, nothing happens. No dialogue box, no text box, nothing. 

    Monday, June 20, 2011 9:20 PM


All replies

  • The error message is caused by the broken rip music location, which can be fixed as follows. In WMP's library, please click Organize, and select Manage libraries - Music . What locations are listed there? If there are any unavailable locations, remove them, and also make sure that a Default save location is set. Do the same for the other libraries (Videos, Pictures, Recorded TV).

    If that doesn't help, close WMP, open Windows Explorer, right-click the Music library, select Properties, and click Restore Defaults. After that, make sure that a save location is set (as indicated by a checkmark).
    Tim De Baets
    Tuesday, June 21, 2011 6:21 PM
  • I've already tried both those things and neither of them had any effect. 
    Tuesday, June 21, 2011 8:23 PM
  • I suggest that you try deleting the current Music library and restoring the default one (your music files will be preserved), by following the instructions in this article:

    Tim De Baets
    • Marked as answer by Borden0240 Wednesday, June 22, 2011 4:32 PM
    Wednesday, June 22, 2011 4:06 PM
  • I almost didn't even want to try this because it seemed way to simple after everything else I had tried, but it worked. Thank you so much! :D
    Wednesday, June 22, 2011 4:32 PM
  • In case it helps anyone else, I had the same problem and tried all of the suggested options about the folders in the library, etc, and nothing worked.

    The solution for me was to run Media Player as administrator once.  Hit the start button->Media Player->right click and select "run as administrator".  After I ran it as administrator once I could then see/change the directory and save without getting the error.

    Thursday, May 3, 2012 4:55 PM
  • This is exactly what I needed to know to fix my problem. Thank you thank you thank you!!  I deleted the default folder for ripping music PRIOR to setting up a new default folder.  Media player could not tell me how to fix the problem.  All I kept getting was an error message.  I opened MP as administrator and was able to set the new default.

    Thanks again!

    Tuesday, July 31, 2012 11:11 PM
  • Very odd. The solution of altering the Music library still works in late 2016, but it's odd that it works.

    My library here comprised \Users\user\Music and \Users\Public\Music. Removing the Public half re-enabled ripping - for this user.

    Curiously, ripping was possible before this alteration for the administrator account; 'user' here is a local user account, not an admin.

    Thanks to the contributors ..from the future. :)

    Wednesday, November 23, 2016 12:30 PM
  • This worked perfectly - thanks a bunch Tim!
    Tuesday, July 18, 2017 3:55 PM
  • It is a useful solution and it worked out to me.I solved the problem.Thank you.
    Saturday, November 18, 2017 1:25 AM
  • Thank you!
    I just encountered this problem today and following your advice solved the issue.

    Much appreciated.


    Wednesday, December 6, 2017 10:54 AM
  • wunderbar............  after running media player as admin, I could rip cds again......... thanks 6 years later

    Sunday, August 5, 2018 11:03 PM
  • I had same Issue.

    I tried setting defaults to the music library and all it did was add the public\music folder, not the My Music Folder.

    I tried removing WMP and Media Center and reinstalling them, didn't fix it

    Went into regedit searched for My Music in values and discovered that the folder in the data was on F:\Music.  I had removed the F Volume so the path was invalid. that's why it displays nothing and won't let you change it. or save rip music settings.

    I changed the value to C:\Users\{My UserName}\Music and that fixed the problem.

    Tuesday, March 5, 2019 3:52 PM