none
Exchange 2016 MapiExceptionSessionLimit

    Question

  • I have a few users on my Exchange 2016 on premise server that have access to a high number of other users calendars.  These users are having connectivity issues.  I'm using Outlook 2010 and higher clients so they are all using MAPI over HTTP as confirmed by the Outlook connection status dialog.  The problem I have is that these users are getting a MapiExceptionSessionLimit in the MAPI Client log entries, I cannot find where I can increase the limit on the number of allowed sessions.  I have increased the RPC limits but this is HTTP so I don't see a setting.  Any help would be greatly appreciated.

    Tuesday, September 20, 2016 3:13 PM

All replies

  • Hi,

    What's the full message information in the MAPI Client Access Log? Are there any error events in application log?

    To increase the MAX MAPI session limit, we can use Exchange Information Store registry key with the following steps. Take a try to see if it will work.

    1. Open regedit.

    2. Navigate to \\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

    3. Right click ParametersSystem, select New, then select Key. Name the key MaxObjsPerMapiSession.

    4. Right-click MaxObjsPerMapiSession, point to New, and then click DWORD (32-bit) Value.

    Value Name: objtFolder

    Value data: 600 (You can set this value to what you want)

    5. Right-click MaxObjsPerMapiSession again, point to New, and then click DWORD (32-bit) Value.

    Value Name: objtFolderView

    Value data: 600 (You can set this value to what you want)

    6. Then Restart the Microsoft Exchange Information Store Service.


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Lynn-LiModerator Wednesday, September 21, 2016 8:01 AM Typo
    • Marked as answer by manielsen2002 Wednesday, September 21, 2016 7:39 PM
    • Unmarked as answer by manielsen2002 Friday, September 23, 2016 4:42 PM
    Wednesday, September 21, 2016 8:00 AM
    Moderator
  • Ok, so I thought this was resolved but apparently not.  

    I have restarted the information store and increased the values in the registry to 1000 each, perhaps the log entry below will point to another value that I need to change.  

    2016-09-23T16:35:38.143Z,16278,1,/o=First Organization/ou=First Administrative Group/cn=Recipients/cn=cellis,,OUTLOOK.EXE,15.0.4859.1000,Cached,10.0.0.114,,,MapiHttp,Client=MSExchangeRPC,R:{F088729D-4E11-4D5D-A6D3-6D9065CA2C84}:2|A:d3a5853a-058e-4fc4-8650-e70b9637d709|FE:SRV008.PLUMBING.LOCAL,C:MAPIAAAAAPak8sLyyunb69rswfHI5dfnx/bC+Mn7wfLDmbqJsYm6g7CCs4GVPwAAAAAAAA==|S:0-h/YpFg==,DelegateLogon,1246 (rop::1246),00:00:00,"Logon: Delegate, /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Jose Rangelec1 in database 60111891-07b8-424d-97e5-da94a73dd425 last mounted on SRV008.plumbing.local","RopHandler: Logon: [TooManyObjectsOpenedException] Cannot open mailbox /o=First Organization/ou=First Administrative Group/cn=Recipients/cn=cellis. -> [MapiExceptionSessionLimit] Unable to open message store. (hr=0x80040112, ec=1246)  [diag::AAB+AQAA/wAAAAAAAAAAAnABAAAn2gAR5wEAACeqEDEAAAAAOAEAAAAAAAAAAAAAAAAAANDLQCEBD9KBIQDwHzAAAABww0AhAQ/SgZEXABABD9KBbIkAEAAAAAC6WvAfnAAAADpt8B/+AAAAukLwH94EAAA5aQAQgAMEAKFVQBDeBAAAOm3wH/oAAADWBfAfgAMEALC5ABAKAAAAEKEAEAAAAAAw6wAQBQAHgBCRABBjdGl2MOcAEAAAAAAQ1wAQMS4wNBCnABAzMzpT/9sAEDgAAAAPugAQAAAAAFDiUCAgAAAATW9NVAByY2hQghAQIQAAACjgQBDeBAAAKN4QEP4AAADYpkAQ3gQAACIqUEAAAAAAMTUuMDEuMDQ2Ni4wMzM6U1JWMDA4AAAA1gbwHw8BBIDhaAAQuQQAADlV8B/eBAAAuWYAELkEAADJQEAQ3gQAALl+ABCcAAAAqgZAEN4EAAC5YAAQLAAAALlQQBDeBAAAuWQAEH8AAAC5dEAQ3gQAAA==]   at M.E.D.S.MailboxSession.CreateMapiStore(ClientIdentityInfo clientIdentity, Byte[] partitionHint, Boolean unifiedSession, MapiStore linkedStore)     at M.E.D.S.MailboxSession.ForceOpen(MapiStore linkedStore, Boolean unifiedSession)     at M.E.D.S.MailboxSession.Initialize(MapiStore linkedStore, LogonType logonType, IExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, Boolean disposeIdentity, OpenMailboxSessionFlags flags, GenericIdentity auxiliaryIdentity, Boolean unifiedSession)     at M.E.D.S.MailboxSession.<>c__DisplayClass30.<CreateMailboxSession>b__2e(MailboxSession mailboxSession)     at M.E.D.S.MailboxSession.InternalCreateMailboxSession(LogonType logonType, IExchangePrincipal owner, DelegateLo",,,cellis@XXXXXX.COM,,



    Matt Nielsen


    • Edited by manielsen2002 Friday, September 23, 2016 4:47 PM Attached Image
    Friday, September 23, 2016 4:46 PM
  • Did you ever find a resolution to this issue with Exchange 2016?
    Saturday, January 14, 2017 6:23 PM
  • Nope, the only partial work around was to change the way the clients connected from Outlook.  This was only happening on secondary mailboxes, not the users primary account so I changed outlook to not use cached mode for the additional mailboxes.  https://support.microsoft.com/en-us/kb/982697 

    This didn't solve the problem directly, but they symptoms seemed to go away when I did this. In the end it was only a small number of users that had excessive number of additional mailboxes that act as schedulers for a department, it was very frustrating not to be able to just increment a upper limit.


    Matt Nielsen

    Monday, January 16, 2017 4:09 PM
  • Hi Everyone

     i have the same issue in Exchange 2016 CU3 

    Below is my case:

    Some users use a shared mailbox  together to receive  customer queries and respond to them . 
    They login only from OWA  from different locations.
    This works fine for 10 users.
    When more than 10 users login they get the below error 
    x-owa-error:microsoftexchangedatastoragetoomanyobjectsopenedexception

    Below are the troubleshooting steps performed:

    1) Increased the values in the registry to 100 each for the below parameters in this location on all mailbox servers 


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    Maximum Allowed Sessions Per User
    Maximum Allowed Service Sessions Per User
    2) Also tried with a  new throttling policy  of values owamaxconcurrency ,rcamaxconcurrency  to 100 for this mailbox alone.


    Have restarted the servers as well but still no go 

    Still getting this message in the IIS logs 

    microsoftexchangedatastoragetoomanyobjectsopenedexception

    I'm  continuously getting the event ID 9646 in the registry with the message exceeded the maximum of 16 objects of type "session" .

    Not sure from where its picking this 16 objects  though the limit is increased.


    The version of Exchange is Exchange 2016 CU3 


    i am out of ideas with this Problem. Would be nice to get help.

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com Thanks Sathish (MVP)


    Wednesday, January 25, 2017 10:08 AM
  • Nope, the only partial work around was to change the way the clients connected from Outlook.  This was only happening on secondary mailboxes, not the users primary account so I changed outlook to not use cached mode for the additional mailboxes.  https://support.microsoft.com/en-us/kb/982697 

    This didn't solve the problem directly, but they symptoms seemed to go away when I did this. In the end it was only a small number of users that had excessive number of additional mailboxes that act as schedulers for a department, it was very frustrating not to be able to just increment a upper limit.


    Matt Nielsen

    Hi Matt!

    Did you ever found a permanent solution to the problem?

    Best regards...

    Thursday, December 21, 2017 1:02 PM
  • Hi Everyone

    *text*


    Hi Sathish.

    Any luck regarding the problem?

    Best Regards...



    • Edited by monsta99 Thursday, December 21, 2017 2:46 PM
    Thursday, December 21, 2017 1:05 PM
  • An update after trying the above...

    Exchange 2016 CU7 and Outlook 2016

    Had problems with two large mailboxes that many clients connects to and suddenly got error when opening Outlook like "could not open bla bla bla" and if you got in and had the troublesome mailbox as secondary it was not connected.

    Owa worked fine by the way.

    Got this jibberish in C:\Program Files\Microsoft\Exchange Server\V15\Logging\MapiHttp\Mailbox\Mapi_Http_xx_x.log

    TooManyObjectsOpenedException] Cannot open mailbox /o=/ou=Exchange Administrative Group/cn=Recipients/cn=-> [MapiExceptionSessionLimit] Unable to open message store.
    (hr=0x80040112  ec=1246), mumbo-jumbo MoMTException:0x6BA (rpc Exception) -> [ServerUnavailableException]
    Connection must be re-established -> [SessionDeadException] The primary owner logon has failed. Dropping a connection. -> [TooManyObjectsOpenedException] Cannot open mailbox 
    /o=/ou=Exchange Administrative Group/cn=Recipients/cn=-> [MapiExceptionSessionLimit] Unable to open message store. (hr=0x80040112  ec=1246)

    MoMTException:0x6BA caught my eye and led me to this one: 

    http://www.webcommand.net/index.php/2017/10/13/exchange-2016-event-id-9646-momt-exceeded-maximum-32-objects-type-session/

    Had a lot of 9646 in application log.

    Executed the registry hack, restarted information store and now it's working again.

    Good luck everyone...

    //Monsta99



    • Edited by monsta99 Thursday, December 21, 2017 2:41 PM
    Thursday, December 21, 2017 2:37 PM