Windows could not finish configuring the system


  • After sysprep'ing (OOBE, Generalize, Shutdown) an image, pulling it to my WDS server and then pushing the new image I get the following error:

    "Windows could not finish configuring the system. To attempt to resume configuration, restart the computer."

    I have formatted the drives and tried over and over again. I have even tried this on multiple machines and even different WDS servers. 


    I am using windows 7 x64 Enterprise on an HP z200 as well as an HP 2740P Elitebook.


    I have seen a lot of posts for this but no real answers. PLEASE HELP!

    Tuesday, February 08, 2011 10:33 PM


All replies

  • When setup fails, can you check the log files in C:\Windows\Panther\UnattendGC? There are two files Setupact.log and setuperr.log that contain more detailed information about the error condition and in what phase the installation failed.

    You can open the command prompt using Shift-F10 when the error message shows.

    Ray - Author of Windows 7 for XP Professionals
    Wednesday, February 09, 2011 6:16 AM
  • Hi,
    If you created the 100mb hidden partition, there may be the sysprep issue when you have any additional partitions on the drive. You can refer to the following post to create it.
    In addition, please also check if the following KB is helpful.
    Best Regards,

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 10, 2011 12:45 PM
  • I'm now getting the same "Windows could not finish configuring the system. To attempt to resume configuration, restart the computer." message with the images that I'm trying to create, I'm using Ghost to create the image instead of ImageX.  The thread I created was the one named: Imaging Windows 7 and getting Windows Boot Manager 0xc000000e error

    Are you saying that the hidden partition is causing it?

    Thursday, February 10, 2011 3:21 PM
  • Hello Gentry,

    This is what I'm going to try to see if it corrects the issue I'm having with that error message.  I havent done it yet but when I do and if it works for my issue I will post back.  If you look at the setupact.log (or setuperr.log) file in C:\Windows\Panther\UattendGC folder are you getting the same 0x8007139f error?

    • Proposed as answer by Niki HanModerator Wednesday, February 16, 2011 3:30 AM
    • Marked as answer by Vivian Xing Wednesday, February 16, 2011 6:11 AM
    Thursday, February 10, 2011 4:40 PM
  • So far, I had success with using the Hotfix on the first test I did.  Now to add two programs I left off of the first image I created and redo that image and test it for a second time.  Then hopefully I will be able to get the other two images I need to create completed also.  Will post an update tomorrow.
    Thursday, February 10, 2011 10:01 PM
  • Update: I have been able to create two different images that I was having the "Windows could not finish configuring the system. To attempt to resume configuration, restart the computer." issue using the hotfix I mentioned above.  So I can say that the hotfix fixed the issue for me.
    Wednesday, February 16, 2011 4:50 AM