none
MTP USB Device failed and WPD File System Volume Driver

    Question

  • Hello

    I have just installed a new i7 system built around an Asus P8P67 pro mobo. The system is running well and on a clean install of Win7 Pro X64.

    There are two issues that I believe are related.

    1) Firstly, when I plug in my Nikon D700, which does not need a driver in Win7, as it is an MTP device, it gives me 'device driver not installed' message and says 'MTP USB Device failed' and wont see the camera. Ive tried with a Creative Zen media player, also an MTP device, and an apple iPhone 4, I get the same error.

    2) Second, I have 1-3 'Uknown devices' in my device manager. When I try to search for an update on the internet, it identifies them as WPD FileSystem Volume Driver, but tells me that the driver cannot be installed because 'this action requires an interactive window station'. What does this error mean?

    Doing some research it seems that these problems are related, as both are related to mounting external memory devices as drives in Windows.

    I've tried the fix for this problem suggested in another post in the vista forums that involved uninstalling and reinstalling the USB root Hub. It didnt work.

    Is there any other ideas how to correct this problem?

    Sunday, February 06, 2011 4:10 AM

Answers