none
I have a PC that will not wake from standby since Build 1709 (Fall creators update). RRS feed

  • Question

  • I am trying to troubleshoot an older computer that I just updated from build 1703 to 1709.  Windows itself appears to be functioning, however a very key feature, sleep mode no longer works properly.  The system will go to sleep if told, or left idle for 30 minutes, however it will not fully wake up.  I can hit the spacebar, power button or click a mouse button, or even send a WOL (Wake On LAN) signal, and the PC's fans will fire right up and the power LED will illuminate... however there is no video.  There's no response to a PING, and the machine is just a big box of whirring fans at that moment.

    If I go into the BIOS and change the sleep mode from S3 to S1, I can put the system to sleep AND wake it up... however when the system is supposedly asleep, the fans are still on (though much slower than normal).  I'd rather have S3 sleep enabled, as it was working fine in Windows 10 Anniversary update and Creators Update.  It saves much more energy and the feature of sending WOL packets to wake it up remotely is required.

    Now I could go and undo the Fall Creators update, however that is just a bandaid, and at some point I'll just get it again.  Plus I'd rather try to continue and move forward.  Is there anything I can check on the system that is different in Windows 10 Pro build 1709 vs 1703 that would eliminate the ability to wake on lan?

    The computer is an Intel Core i7 920 2.66 GHz from a few years ago, 12GB RAM, 128GB Samsung SSD Boot drive, and two 500GB drives in Raid0 for a downloads drive.

    All other functions of the PC seem to be working.  I did right click on the video driver and choose update.  The system did search the internet and supposedly install an updated video driver, however this did not fix the problem.  There was one RAID controller driver that was unknown, I believe a Marvell SAS raid controller that I do not use (I'm using the Intel SATA one).  So I disabled this device.  There was never a driver for this since Windows 10.

    Friday, October 27, 2017 3:13 PM

Answers

  • going into the BIOS, Advanced -> Intel Vt-d Configuration -> Intel Vt-d and setting this option to "Disabled"

    • Proposed as answer by DerJanc Monday, February 26, 2018 12:30 PM
    • Marked as answer by KJSTech1 Thursday, May 31, 2018 1:18 AM
    Monday, February 19, 2018 5:04 AM

All replies

  • Hi,

    Your issue  seems to be reported in many articles and forums. 
    I have found an article (in Japanese). It says (translate into English):
    https://freesoft.tvbok.com/win10/sleep_disorders_problems.html

    1. doubt USB devices and Wi-Fi devices. Disconnect all external devices except mouse and keyboard, and check if it occurs.

    2. uninstall old QuickTime (installed in Windows 7 era).

    3. install the latest drivers.

    4. uninstall old C++ redistributable (installed in Windows 7 era).

    5. disable OneDrive

    Please try and check. And if you discover something, please share it.
    There must be many people in need behind you.

    Regards,

    Ashidacchi

    Saturday, October 28, 2017 7:24 AM
  • I can't figure it out for the life of me.

    So what I did basically in Power Options I hid all options for sleep.  I changed sleep to never but in advanced power options I changed Hibernate to 60 minutes.  I added Hibernate to the start menu and removed sleep.

    The system has no problems doing hibernation mode, then I can send a WOL (Wake On Lan) signal and it wakes up properly (or hit keyboard or mouse if local).

    The time it takes to awake from hibernation is only a few seconds longer than traditional sleep mode.

    I can live with this workaround for now.


    Tuesday, October 31, 2017 6:40 PM
  • Hi,

    Windows 10 has various power states. Please refer to the following article: System Power States
    https://msdn.microsoft.com/en-us/library/windows/desktop/aa373229%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396
    I can't figure out more than this, if you can't figure out more. 

    Regards,


    Ashidacchi

    Tuesday, October 31, 2017 11:02 PM
  • I have also encountered this problem. I'm running an X5650 on an Asus Rampage III Gene, so it's probably something to do with the Nehalem platform. It was waking from sleep without problems before the Fall Creator's Update, now when waking from sleep the power LED comes on and the fans spin up but there is no display and nothing happens. Pressing the power button immediately powers off the PC.

    If I wait a while before turning the PC off I can see the following error in Windows Event Viewer after I boot up again:

    The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000005c (0x0000000000000500, 0x0000000004000000, 0x00000000fbffffff, 0x00000000ffffffff).

    For now I am using hibernate instead of sleep mode as a work around. It takes longer to boot up but with an SSD it's not too bad.

    Thursday, November 2, 2017 2:25 AM
  • Im also having the exact same problem on a Rampage II Extreme and a 975. I've reinstalled twice to no avail. Would be nice for Microsoft and their infinite wisdom to not force people to download an update that removes functionality from their PC. Thanks for wasting 2 days of my weekend trying to troubleshoot a problem that would not have existed otherwise, I appreciate it guys, really good work.
    Friday, November 3, 2017 4:35 AM
  • Maybe you are onto something. I have Asus Rampage III Formula and since upgrade to 1709 I have BSOD every single time when resuming from S3 standby. S1 works as expected.
    Tuesday, November 7, 2017 2:09 PM
  • I'm also having the same problem when waking from sleep on the latest stable build of Windows 10.

    I have all the drivers updated and didn't have this problem before. I'm also running on Nehalem platform with an i7 920. I'm hibernating for now until this gets fixed or a solution is found.

    Monday, November 13, 2017 8:45 PM
  • Hi,

    Same problem with a Dell M4700.

    Prior to Windows totally ignoring GPO and putting the Creators Edition on my PC it would suspend and resume fine (I don't use hibernate). Best I can tell is it's the Dell credential providers and drivers that hang because I can get to the screen before unlocking and keyboard/mouse are fine, but then  you go to the screen to put your password in or swipe the fingerprint reader and THAT is when the keyboard and mouse die.

    I've followed every guide I can find, disabled the Intel management driver as suggested in some places, and so on.

    Microsoft, or someone else, badly needs to come up with a tool that

    (1) provides you a UI for managing all the credential providers

    (2) gives you the option to remove all credential providers, filters, drivers etc that are not Win10 "out of the box", i.e. reset the entire thing to how a clean Win10 install would look.

    (3) deals properly with situations like OEM vendor customized power schemes tied to the hardware config not migrating to Win10 - I've now got three schemes inherited from Win7 Pro which I can't manage or modify, and they are specific to the hardware configuration so you cannot recreate them manually (for example, I have one that disables the nvidia graphics for maximum battery life, and another that puts the GPU and CPU at full speed with fans on full for performance work).


    Tim Staddon

    Monday, November 13, 2017 9:03 PM
  • Same problem here with a Dell XPS 9550. When the computer resume from sleep I get a blue screen that says Windows didn't load correctly... My only option is to restart. I confirm resuming from hibernation works fine.

    I've updated to the latest drivers, but to no avail :-(

    After reading this thread I come to the conclusion it' not a Dell-only problem... I hope Microsoft can fix the issue ASAP.

    Tuesday, November 14, 2017 1:18 AM
  • Likewise, S1 works, however who wants their pc fans still running? With and without advanced ACPI enabled it still wont work, even on a completely out of the box install. It would be nice for Microsoft to at least acknowledge that we are up shits creek without a paddle on future updates, rather than stringing us along. Its a shame we are at the mercy of Microsoft to support our older PC's as they wish.... It's so despicable that they are the determining factors of whether or not I get to use my reliable old hardware.

    Tuesday, November 14, 2017 10:30 PM
  • I also have that problem with sleep mode. Using the old Nehalem Xeon X5550 with Asus P6T motherboard. Today just got november update, was hoping it would fix the problem, but no changes here :( .

    I also had an issue with double authorization, when pc fully restarts (after booting from hibernate there was no problem), but after this update the problem dissappeared, whether sleep mode problem stays here. I have all newest drivers for my hardware (checking them each month with Snappy Driver Installer).
    Microsoft, please, look at this problem and do something with it, on previous Windows 10 builds everything was just great! That problem only appeared after Fall Creators Update, so the problem is 100% in your software. I really hope they will fix it as soon as possible.

    Wednesday, November 15, 2017 8:18 PM
  • Hi,

    I expect your issue has been resolved after Patch Tuesday/Windows Update (Nov. 14/15, 2017).
    How it is?

    Regards,

    Ashidacchi

    Thursday, November 16, 2017 12:19 AM
  • Hi,

    I expect your issue has been resolved after Patch Tuesday/Windows Update (Nov. 14/15, 2017).
    How it is?

    Regards,

    Ashidacchi

    Thursday, November 16, 2017 12:19 AM
  • No.  I checked for updates.  Installed the latest updates and rebooted.  I'm now at Version 1709 OS Build 16299.64.  I checked for updates a few more times and it claims the system is fully up to date.

    I went into the power options and added sleep back to the start menu.  I tried it.  System went to sleep ok.  I waited a minute and then clicked the mouse button.  Fans came back on, HD light lit up solid for 30 seconds or so, but I never got any video on either monitor.  I waited a few minutes but I had no input and no responds to ping from another machine - despite the fans running and the lights on the tower.

    I had to hit the reset button.  System booted up fine, and I went to remove sleep from the start menu again since its useless, but it never saved the fact that I added it back in anyway.

    I will just rely on Hibernate for now.  Wake on LAN works fine, as does touching a mouse button or hitting a keyboard key.  It comes back on fairly quickly, not much more time than sleep actually.  I'll just have to stick with what works I guess.

    Thursday, November 16, 2017 2:59 AM
  • I went into the power options and added sleep back to the start menu.  I tried it.  System went to sleep ok.  I waited a minute and then clicked the mouse button.  Fans came back on, HD light lit up solid for 30 seconds or so, but I never got any video on either monitor.  I waited a few minutes but I had no input and no responds to ping from another machine - despite the f

    Please check:
    Turn monitors OFF and ON, after fans come back , HD LED lights up.

    And provide an interface connecting between PC/Grahpic board and monitor(s). Display Port, HDMI, DVI, or VGA?

    Regards,

    Ashidacchi

    Thursday, November 16, 2017 3:13 AM
  • Hi,

    I expect your issue has been resolved after Patch Tuesday/Windows Update (Nov. 14/15, 2017).
    How it is?

    Regards,

    Ashidacchi

    As I said a bit earlier - no, unfortunately, November patch didn't solve this issue. PC still doesn't boot properly from sleep mode.
    Thursday, November 16, 2017 7:14 PM
  • Please update BIOS to to the latest version and install the latest graphics driver. Don't use Hybernate mode, if it is ON.

    Ashidacchi

    Thursday, November 16, 2017 10:23 PM
  • Strangely, I've started having the problem since an update happened on Tuesday. Sleep on Wednesday eve and won't wake on Thursday - hard reset. Sleep on Thursday eve and won't wake on Friday. I was already running 1709 for a few weeks before this week.
    Friday, November 17, 2017 6:32 PM
  • I have the latest bios and graphics driver. No difference.

    Been using DVI for many years.

    No issues waking up from sleep in build 1703, 1607, 1511, or Windows 7.

    Friday, November 17, 2017 6:35 PM
  • This is absolutely, positively a problem with the Fall Creator's Update. Don't listen to anyone telling you to check your power settings, drivers, etc.

    My system had zero problems. I installed the Fall update. Immediately, my display would not ever come back on once it has been turned off by any means (DisplayPort connection on Nvidia 1080ti). Not just sleep mode, or hibernate... even just powering the monitor off and back on, the display does not come back on. For me, only a hard reset would bring it back. 

    Just now, I uninstalled the Fall update (Settings>Recovery>Return to previous Windows version) and now the problem is gone.

    Instead of continuing to dole out scripted level one support responses, MS needs to admit this is their problem and figure it out.


    Saturday, November 18, 2017 4:03 AM
  • I seems like the issue is with whatever wake signal that goes through the display, the computer wakes up but the monitor does not seem to get the wake command.

    They probably forgot to put it back after they revamped the display metrics in the task manager

    The GPU monitor is great, you can actually see the amount of processing the GPU is doing now.

    Monday, November 20, 2017 1:18 AM
  • I don't think the system is waking up fully. It wakes, then crashes. If I leave the machine on for a minute after waking and before resetting, I can see a bugcheck crash in the event viewer. If it was just the display you would be able to ping the machine or set up a vnc server and connect in after waking.
    Monday, November 20, 2017 3:51 AM
  • It would help if everyone who has this issue describes what platform they are on. There seems to be a distinct issue with at least some Nehalem motherboards
    Monday, November 20, 2017 3:58 AM
  • What method did you use to enable Hibernate rather than Sleep?

    Monday, November 20, 2017 10:08 AM
  • How exactly did you enable Hibernate?  I have done that using PowerCfg and then editing the Power Plan, but it fails to resume the same way Sleep fails - Bugcheck 05.
    Monday, November 20, 2017 10:18 AM
  • This is a widespread problem ( PC going to sleep after a few hours even if told not to sleep) and not switching back on when a key is pressed. I have seen it on Intel and AMD chipsets and graphic cards. 

    Big problem. Fix it MS. 

    Monday, November 20, 2017 3:45 PM
  • Hi, I have the same problem after version 1709 update. Display doesn’t wake up after sleep. I press space bar or click mice, only see windows 10 background picture flashes then black off. Display win’t Wake up after only display sleeps (while cpu still on) or both display and cpu sleep. However after long hours sleep (more than 4 hours), display will be able to wake up by pressing space bar or click. I am sure it is caused by version 1709 update as my dell desktop works perfectly prior to version 1709 update. It is surprised that MS seems no urgent feeling to resolve its customers pain. Come on MS, we are all your royal customers.
    Wednesday, November 22, 2017 11:00 AM
  • Is Microsoft working on this bug?  There are enough people reporting the issue to see there is some sort of common problem here.
    Saturday, November 25, 2017 11:15 PM
  • Display doesn’t wake up after sleep.

    Others, especially ones who are using attached monitors, are using other keyboard workarounds to get the display back after Sleep.  Win+Ctrl+Shift+B (more than once seems necessary).  Win+P (etc.) to change the display configuration.  Note that a change might be as simple as Win+P, CursorUp, Enter but it is helpful to have Narrator running to monitor what you are starting from and what you get (especially if you are going to transition to Second Screen Only which has a ridiculously brief Keep this...? prompt that needs to be responded to (e.g. with a Tab, Enter of its own)).  Narrator is Win+Ctrl+Enter.  In fact, sometimes just starting Narrator is enough to bring the display back.  Coincidentally this morning the only thing that finally helped me (Resume from overnight Hibernation) was Ctrl+Alt+Delete.  Apparently getting out of the Lock Screen and into the Login screen is a viable workaround for this scenario too.  So, lots of possibilities but it helps to have Narrator running to let you know what you are getting but not seeing.

    Windows 10.  Still an Adventure ("Twisty passages, all different.")



    Robert Aldwinckle
    ---

    Sunday, November 26, 2017 3:38 AM
  • I have the same problem too, I have two computers, one has been fixed after updating Realtek ethernet driver, but the older computer is still having the problem after updated...@@
    Monday, November 27, 2017 9:54 AM
  • So since update my Multimonitor Setup is gone weird. I got 3 Monitors 2 of them connected through VGA and DVI via the onbord Intel HD. And my Main Monitor 4k connected via Displayport Radeon R290.

    Everything was fine if i left my PC the Monitors went to suspend, if i Moved my Mouse all of them awake.

    Since the Update, only my Side Monitors awake, i reinstalled the latest Radeon Drivers, nothing only solution is to let them on.

    I have to pull the Monitor Cable and reinsert it from my main Monitor to wake the GPU.

    When i try to reactivate the Monitor trough settings there is no posibillity like there is no monitor connected so i guess my Radeon will not awake from sleep trough Windows. (Multi GPU Setup, Intel awake, external Radeon doesn't. In BIOS the intel ist first GPU external Radeon second)

    Also if i Connect via RDP and want to Login again physically the Login screen is on my left Monitor cause its like Windows doesn't know there is something connected on the Radeon (radeon sleeping)

    I hope this informations will lead to an Patch which will fix the Problem i dont like to let the Monitors always on.

    Andreas Voigt

    Very well Microsoft, worlds finest "Verschlimmbesserer"



    • Edited by Phil2Sat Monday, November 27, 2017 5:18 PM Verschlimmbessern
    Monday, November 27, 2017 12:31 PM
  • Things tried so far:

    What about keyboard workarounds?  Doing those would save wear on your connectors in case you are resorting to the hardware workarounds that others are mentioning.



    Robert Aldwinckle
    ---

    Monday, November 27, 2017 7:00 PM
  • I am having a similar issue since updating to 1709 on a laptop.    It can take 5 minutes or longer to wake from sleep.    Drive (ssd) light is on the entire time.     It typically progresses this way.

    - several minutes of  solid purple screen  with mouse unresponsive

    - mouse pointer becomes responsive

    - windows screen saver image appears.  Mouse movement is jerky and sometimes unresponsive

    - eventually, if I wait long enough I get to enter my password and I'm back in business.

    This is many, many times longer than it takes to cold boot.   I've become so frustrated by it that I'm resorting to shutting down frequently so that my machine will not suspend. 


    • Edited by LowcarbNY Monday, November 27, 2017 8:23 PM
    Monday, November 27, 2017 8:22 PM
  • Things tried so far:

    What about keyboard workarounds?  Doing those would save wear on your connectors in case you are resorting to the hardware workarounds that others are mentioning.



    Robert Aldwinckle
    ---


    I was excited by all the key combo you provided, and 5 min ago my computer failed to wake up again (it happens intermittently) so I had a chance to try them all out. Unfortunately they do not work. This seems to be a different problem than a mere display/driver issue. The computer is not responsive to any keyboard input. The only way is to hard reset.
    Tuesday, November 28, 2017 7:37 AM
  • I am getting the same, have to restart machine if it goes it to sleep.

    Microsoft fixing this? Every update something is broken it seems...

    Tuesday, November 28, 2017 10:57 AM
  • I am getting the same, have to restart machine if it goes it to sleep. 

    If you can't use your keyboard it's not a case of just your screen sleeping.  E.g. you may be hibernating and in that case you would need to use the power button to restart.  However, if you are only configured for fast restart you would not have a full size hiberfil.sys to do a full resume with and then that could explain your symptom.  Use powercfg and the Control Panel Power Options to make sure that you are using Hibernate fully.


    Robert Aldwinckle
    ---

    Tuesday, November 28, 2017 11:52 AM
  • Have a similar problem with Acer with i5-4210U. Albeit not so severe.
    After the 1709 update my laptop sometimes (but no 100%) just won't wake up from sleep. It'll just be a black screen with a backlight. Sometimes it'll "wake up" but instead of a black screen it'd be a log-in background picture and it'd stay like that for very long.
    Friday, December 1, 2017 5:12 AM
  • I am getting the same, have to restart machine if it goes it to sleep. 

    If you can't use your keyboard it's not a case of just your screen sleeping.  E.g. you may be hibernating and in that case you would need to use the power button to restart.  However, if you are only configured for fast restart you would not have a full size hiberfil.sys to do a full resume with and then that could explain your symptom.  Use powercfg and the Control Panel Power Options to make sure that you are using Hibernate fully.


    Robert Aldwinckle
    ---

    For desktops, sleep/hibernate should either be able to be waken by keyboard or not, at the same time. If I enable keyboard wake under devmgmt, keyboard wakes the computer from both sleep and hibernation.

    For now I disabled the sleep function and use hibernate only, looks like hibernation is still working alright, too bad it adds to the wear of my SSD I guess.

    Friday, December 1, 2017 10:25 AM
  • In a matter of days since my Windows 10 Pro laptop upgraded to 1709, not only have I experienced Hyper-V NAT & DHCP related issues, SMB/CIFs issues, I now also have a powerful Dell XPS 15 32 Gig 7th gen i7 machine which, when at a client's, and on battery power, cannot resume out of sleep without it appearing like it's rebooted.

    Microsoft - please sort this sleep issue out as soon as possible. It is embarrassing.

    Also, please research this and note that Dell and HP users are affected by the same problem. I'm sure it isn't just confined to consumers of these brands.

    One of the advantages of a laptop is that you can resume work at a later date. Now, it just loses everything, as if you never put it to sleep.

    Problems so far:

    1) An unexpected spanner went into the works with Hyper-V - embarrassing because internal networking fails just before you're about to demo software. Sometimes you have to reboot guest machines over and over to latch onto the internal virtual network.

    2) SMB broke - guest machines could not access host shares without bizarrely having to enable/disable file and printer support on the virtual NIC.

    3) And now Sleep broke - with no means to resume where you suspended.

    Since resuming from sleep isn't working, it's a pain if Hyper-V guests don't get an IP straight away. Hyper-V guests need several reboots before the new 'Default Switch' will correctly allocate an IP. It is rubbish. Please fix all these issues as it is embarrassing when trying to work with clients.

    Edit - just to be clear - sleep only breaks when on battery power. When back on power at my desk sleep works fine. It's obviously something to do with power management but please fix this asap!

    Saturday, December 2, 2017 1:00 PM
  • One of the advantages of a laptop is that you can resume work at a later date. Now, it just loses everything, as if you never put it to sleep.

    So, use Hibernate with a full Hiberfil.sys.  Evidently you are only getting "fast restart" and need something more.


    Robert Aldwinckle
    ---

    Saturday, December 2, 2017 1:29 PM
  • Hibernate (Full) isn't working on my PC either.  It gives the same symptoms.  The monitors don't activate after waking up the PC.  I also noticed when I tried it just now (after updating to 16299.98) that the keyboard isn't active either - there are no Caps Lock or Num Lock lights.  This is with a USB connected keyboard.
    Sunday, December 3, 2017 12:09 AM
  • the keyboard isn't active either - there are no Caps Lock or Num Lock lights. 

    So it hibernated?  Then you need to use the power switch to start a Resume.  Is that what you meant by "waking up the PC"?

    FWIW I had an example today that was related (e.g., I had to use Power on for a Resume, since the Sleep had timed out).  I think my keyboard (wireless) was working but none of my keystrokes showed any sign of doing anything; e.g. no beep from Win+Ctrl+Shift+B, no "Starting Narrator" from Win+Ctrl+Enter, and nothing on my tablet screen no matter what I did with Win+P, etc.  Meanwhile my monitor showed swirling grey with static noise.  I finally relented and powered the monitor off and on...and then finally saw my Login screen looking as if it had been a bit abused.  One thing I noticed when I finally got it going again is that somehow the keyboard layout had been switched to DSK.  That could account for why my workaround keystrokes were not working (except for the Narrator one).  The fact that the HDMI monitor's audio port would have been my default audio would have accounted for the static noise and not being able to hear anything intelligible from Narrator.  I suspect I may have accidentally hit Win+Spacebar when I was trying to do something else.  I will have to be on my guard in future to try to avoid doing that and to be aware of it as a possibility that needs to be considered in a software-only workaround.  I'm not sure what I could try using as a workaround for having audio on a non-functioning port.  Maybe I should try using a headset then as well.



    Robert Aldwinckle
    ---

    Sunday, December 3, 2017 4:22 AM
  • Looks like Razer consumers have outed the issue stating it’s only when on battery power which is precisely what I said above except I’m experiencing it on a fully loaded Dell XPS. Looking forward to a patch.
    Sunday, December 3, 2017 10:00 AM
  • So it hibernated?  Then you need to use the power switch to start a Resume.  Is that what you meant by "waking up the PC"?



    Robert Aldwinckle
    ---

    Well, I have disabled Sleep in the Power Plan, enabled Hibernate using 'PowerCfg /H ON' & 'PowerCfg /H /Type Full'.  But I was able to wake the PC by pressing a key on the keyboard.  This isn't right is it?  I think you are right - you should have to use the power button to bring the PC out of hibernate.

    If you have Hibernate activated correctly, does the power command in the Start Menu still say 'Sleep' - because mine does.

    Sunday, December 3, 2017 10:45 AM
  • If you have Hibernate activated correctly, does the power command in the Start Menu still say 'Sleep' - because mine does.

    Yes of course but once the Sleep times out it will either do a Hibernate (if available and if sufficient power remains) or Shut down (for a fast restart).  FWIW I found that some of the defaults for low battery are too low but that may only be for my (old) battery.



    Robert Aldwinckle
    ---

    Sunday, December 3, 2017 1:20 PM
  • Response from Dell fixed it for me:

    Device Manager -> Display Adapters -> Uninstall.

    Restart

    Sleep resumption now works on battery power.

    Before this they recommended updating the battery related drivers but they were up-to-date for me.

    Sunday, December 3, 2017 1:20 PM
  • So it hibernated?  Then you need to use the power switch to start a Resume.  Is that what you meant by "waking up the PC"?



    Robert Aldwinckle
    ---

    Well, I have disabled Sleep in the Power Plan, enabled Hibernate using 'PowerCfg /H ON' & 'PowerCfg /H /Type Full'.  But I was able to wake the PC by pressing a key on the keyboard.  This isn't right is it?  I think you are right - you should have to use the power button to bring the PC out of hibernate.

    If you have Hibernate activated correctly, does the power command in the Start Menu still say 'Sleep' - because mine does.

    I see no reason you can't wake from hibernation with a keyboard. That's always been my experience for the past decade, in XP(?), Vista, 8 and now 10. It all depends on your USB wake settings. Sleep and hibernate can both be interrupted by USB based hardware, or sometimes even LAN.
    Monday, December 4, 2017 4:36 AM
  • I see no reason you can't wake from hibernation with a keyboard.

    Well, one missing detail would be that there is no such thing as  "Wake_From_S4_Supported" in  powercfg /devicequery /?

    Here's a description of the scenario that I want to make sure (as much as possible) that I can avoid (bolded below)

    https://docs.microsoft.com/en-us/windows-hardware/drivers/kernel/system-sleeping-states

    <quote>
    If a computer in state S1, S2, or S3 loses all AC or battery power, it loses system hardware context and therefore must reboot to return to S0. A computer in state S4, however, can restart from its previous location even after it loses battery or AC power because operating system context is retained in the hibernate file. A computer in the hibernate state uses no power (with the possible exception of trickle current).
    </quote>



    Robert Aldwinckle
    ---

    Monday, December 4, 2017 5:52 AM
  • Windows 10, version 1709 - major update that took almost two hours yesterday

    HP ENVY TS 17 Notebook

    Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz 2.40GHz

    Won't wake up after put to sleep

    With lid open or close

    Power button light is ON

    I can hear fan and HD but screen is OFF

    Happens with or without external peripherals connected

    Please HELP! This is beyond annoying as I have to waste my precious time waiting for computer to boot and going back to where I was work wise. 

    -> I haven't done anything to solve this problem as I have no clue what to do.

    annoyed user



    • Edited by marilee48 Monday, December 4, 2017 7:08 AM
    Monday, December 4, 2017 7:05 AM
  • I can hear fan and HD but screen is OFF

    What does Narrator say?  Win+Ctrl+Enter.   Then try  Win+P, CursorUp, Enter   Then if you still can't see anything try  Win+Ctrl+Shift+B (at least twice and at least note if you hear anything) and Win+P, Home, Enter   Note: that is an example of just one potentially effective sequence; otherwise you can try turning the attached monitor off and on to try to get the video system to be refreshed that way.


    Robert Aldwinckle
    ---

    Monday, December 4, 2017 2:30 PM
  • Has anyone made progress on fixing this issue?
    Saturday, December 23, 2017 12:25 AM
  • Our IT department has been swamped with calls concerning this issue.

    We started out blaming drivers. Then the trend emerged -- 1709.

    Will the geniuses at Microsoft fix this showstopper bug or are we supposed to wait for next cycle. Bullshit SaaS is an albatross around our necks.

    Saturday, December 23, 2017 10:53 PM
  • I hope someone's taken the whole of MS support staff hostage, because that's really the only excuse for it being this long without a fix.
    Sunday, January 7, 2018 7:41 PM
  • I'm delighted to let you know that, after 4+ months, the problem still persists, and an official from Microsoft refuses to; at the very least acknowledge that the problem exists. Rampage III Extreme | i7-975 | Gtx 480 | Raid 0 (non boot) | All BIOS Settings relating to P-state/ACPI tested | Multiple fresh installs | 

    Other people have reported that it seems to affect Nehalem Processors, unsure whether it stops at Bloomfield. Microsoft doesn't care, Hibernation is the only option. Thank you 16gb Hiberfile.sys and massively longer resume times... Thank You Microsoft.
    Monday, January 8, 2018 8:52 AM
  • I had a hardware switch from an older Motherboard to a new Ryzen - and this problem crept up. I am guessing some setting in the Motherboard BIOS/PCIe/power config/Motherboard driver is the culprit. Since all I changed was motherboard, it's the best case for a driver issue.

    Microsoft has basically 2 support suggestions - system restore or re-install. A good class action when it's proven they knew - we have been telling them for so long - but didn't try to resolve the issue out of greed should sober them up. I'm calculating Millions of people X hundreds of hours lost , even at minimum wage, should easily reach $1B. Any attorney willing to take the case, I'm willing to be lead plaintiff. Ford is a very nice case study.

    Anyways, I've been experimenting with a lot of settings in the BIOS. Only workaround that only wastes 5 minutes every time is hibernation. Does anybody know if hibernation is helped by "Fast Boot" feature?

    Monday, January 8, 2018 6:43 PM
  • There are probably a few different independent issues here, one specifically affecting the X58 platform. I'm running a Xeon x5650 on an Asus Rampage III Gene and my PC is affected. Other people with more modern platforms are probably affected by a different issue that results in the same symptoms. It's unlikely that the same exact issue would affect such different platforms as the old Intel X58 and the newer Ryzen or Intel stuff.
    Monday, January 8, 2018 9:34 PM
  • I found a solution that works for me!! Not sure if it will work for others.

    It seems that Fall Creators reset "Windows 10 Fast start" (I had it disabled). Once I disabled Fast start, sleep mode seems to work perfectly now again!

    There was also a settings in my BIOS (ASUS) for "Deep Sleep" that seems to do the same thing that I enabled. Anyways, the combo works.

    Here's a site for an explanation and how-to

    https://www.windowscentral.com/how-disable-windows-10-fast-startup

    Let me know if this works for others. Also will see if the the fix holds up for more than one day :-)


    • Edited by laxamar Tuesday, January 9, 2018 11:15 PM More info
    Tuesday, January 9, 2018 11:02 PM
  • Trying the 'disable Fast start' trick now...
    Saturday, January 13, 2018 3:08 AM
  • That didn't work.  Still no display upon resume from sleep or hibernate.
    Sunday, January 14, 2018 7:22 PM
  • I found a solution that works for me!! Not sure if it will work for others.

    It seems that Fall Creators reset "Windows 10 Fast start" (I had it disabled). Once I disabled Fast start, sleep mode seems to work perfectly now again!

    There was also a settings in my BIOS (ASUS) for "Deep Sleep" that seems to do the same thing that I enabled. Anyways, the combo works.

    Here's a site for an explanation and how-to

    https://www.windowscentral.com/how-disable-windows-10-fast-startup

    Let me know if this works for others. Also will see if the the fix holds up for more than one day :-)


    The easiest solution to disabling fast boot is powercfg -h off in an elevated command prompt, no hibernation, no problem, however fastboot is NOT related to a majority of our problems.
    Monday, January 15, 2018 11:37 PM
  • I've also got a Cyberpower Core i7-920 on a Gigabyte EX58-UD4P update to the latest BIOS firmware. All drivers are up to date except for LAN, because it won't communicate with that driver. 

    I've upgraded it many times. Raid1 500GB, Raid1 1.5TB with 24GB RAM at 1600; can overclock but no need to. The huge RAM works as a huge cache, so I take a performance hit only when I load stuff the first time, after that it's fast still after all these years!

    I also cannot get out of sleep mode with the mouse or keyboard. BIOS checked. All wake up from sleep used work used to work before Windows 10 Pro Version 1709 OS Build 16299.192.

    If hibernate works, I can live with that. I'll try that next. Get with it MS. Started with Vista, then Win 7 Ultimate then Win 10 Pro.

    The keyboard is a Logitech Y-UT76 model = plain-vanilla model!

    I've tried to update the driver for the keyboard via Device Manager>Keyboards> HID Keyboard Device.>Driver>Update Driver, but it says I have the latest, Not surprised here.

    Device Manager>Keyboards> HID Keyboard Device>Power management tab has box checked to allow this device to wake the computer.

    I've looked into the event log uner the Device Manager>Keyboards> HID Keyboard Device>Events tab.

    Here I get a warning from Kernel-PnP Event ID 442m with 2 others fromation events id 410, 400 before the 442 warning (View all events...) push button. Under the information it says Device HID\VID_046D&PID_C312\6&326822db&0&0000 was not migrated due to partial or ambiguous match

    Last Device Instance Id: ACPI\PNP0303\4&e4bbdba&0
    Class Guid: {4D36E96B-E325-11CE-BFC1-08002BE10318}
    Location Path: 
    Migration Rank: 0xF000FFFFFFFFF100
    Present: false
    Status: 0xC0000719

    and under events:

    time stamp  device not migrated

    time stamp device configured (keyboard.inf)

    timm stamp Device started kbdhid

    time stamp is 2 nights ago 2/8/2018 11:37:33 PM.

    Sunday, February 11, 2018 1:55 AM
  • I've tried to update the driver for the keyboard via Device Manager>Keyboards> HID Keyboard Device.>Driver>Update Driver, but it says I have the latest, Not surprised here.

    How old is it?  I see the same kind of thing with my Intel HD Graphics driver.  Surface support just seems to have stopped testing Intel's new stuff and left me with what used to work.  So, I downloaded the Intel generic driver and am testing it.  That required a few hoops to be jumped over but nothing really hard to do.

    So, if this wasn't migrated "due to partial or ambiguous match" what do you have?  Did the same thing happen to your mouse?  Look for clues in SetupAPI.dev.log?



    Robert Aldwinckle
    ---

    Sunday, February 11, 2018 5:31 AM
  • going into the BIOS, Advanced -> Intel Vt-d Configuration -> Intel Vt-d and setting this option to "Disabled"

    • Proposed as answer by DerJanc Monday, February 26, 2018 12:30 PM
    • Marked as answer by KJSTech1 Thursday, May 31, 2018 1:18 AM
    Monday, February 19, 2018 5:04 AM
  • > going into the BIOS, Advanced -> Intel Vt-d Configuration -> Intel Vt-d and setting this option to "Disabled" by Alex.Kor

    Yes! This worked for me.

    Asus P6T with Intel i7 920 and x58 chipset. nVidia GeForce 210 graphics.

    No updated Intel drivers anymore for ages, nVidia drivers were up to date.

    Reading tons of complaints about no wake from sleep after Fall Creators update (1703 -> 1709). I assumed it could be a conflict between hardware drivers - between chipset (sleep) and video.

    VT-d seems to facilitate direct hardware video to virtual machines.

    Could it be (hybrid) sleep is using virtualization techniques? And MS changed something there in the FC update?

    Anyway my wake from sleep issue has gone!

    So this answer is worth trying since it is very simple AND does have effect instantly.

    • Edited by DerJanc Monday, February 26, 2018 4:16 PM
    Monday, February 26, 2018 12:42 PM
  • Disabling Intel VT-D in BIOS works, thanks a lot Alex. After several months of trying different solutions this one actually fixed the problem with S3 sleep mode. Tested on ASUS Rampage 3 Formula, X58, i7990x with EVGA 1080ti FTW3.


    Wednesday, February 28, 2018 8:33 AM
  • I can confirm that disabling Vt-d in my BIOS settings solved the problem for me. I'm on an Asus P6T SE with an Intel Core i7 920.
    Thursday, March 1, 2018 9:16 PM
  • Well I'll be damned!  Disabling Vt-d fixed my sleep issue too!!  Yay!!!!  Finally.

    Good thing I don't need to run VMs on this workstation. 

    I have the same MoBo as Daniel - Asus P6T with i7-920.

    Friday, March 2, 2018 11:53 PM
  • I can confirm Vt-d disabled does fix the problem. Virtualization for Directed I/O seems unnecessary for normal operation, and you wouldn't want suspend enabled with a virtualized server or workstation anyways. I guess all is well.

    Note: Vt-d IS NOT the same as CPU Configuration > Virtualization. 
    vt-d is a separate config under Chipset/Southbridge configuration.

    Sunday, March 4, 2018 5:15 AM
  • I had resume from sleep fail this morning :(  No display on both monitors, keyboard appeared to be hung (couldn't change Caps Lock indicator).  Had to cold boot.

    No idea as to what was different about the sleep last night, compared to the previous nights where it worked fine.

    Monday, March 5, 2018 8:36 PM
  • Many thanks. This also resolved the crash on wake from sleep issue for me too.

    System - Asus P6T Deluxe (v1) another x58 based mobo, intel i7 920 CPU and AMD HD7800 GPU.

    Saturday, March 10, 2018 7:53 PM
  • Note helped.  Thanks.
    Monday, April 9, 2018 8:41 PM
  • going into the BIOS, Advanced -> Intel Vt-d Configuration -> Intel Vt-d and setting this option to "Disabled"

    This worked!

    Dell T7500 X5650 Westmere, BIOS A16

    Tuesday, April 24, 2018 10:22 AM
  • Disabling Intel Vt-d did resolve my problem as well.  It also resolved my issue updating to Windows 10 1803.  This is REQUIRED on these older motherboards to get 1803 to boot properly.  The chipset may be a few years old, but it runs great with an SSD drive and a bunch of RAM.
    Thursday, May 31, 2018 1:20 AM
  • going into the BIOS, Advanced -> Intel Vt-d Configuration -> Intel Vt-d and setting this option to "Disabled"

    This indeed is the working solution for most of the boot & S1/S3 resume problems on Windows 10 machines with old BIOSs and VT-d enabled.

    Old VT-d incompatibility is the reason behind numerus boot problems, especially with 2018 and later Win10 x64 versions. This incompatibility is most probably related to OS implemented security patches against Spectre & Meltdown vulnerabilities.
    Monday, November 5, 2018 11:35 AM