none
Repair PowerShell ISE RRS feed

  • Question

  • When using Power ISE the intellisense no longer populates, it just shows a grey dot. The autocomplete still works, and pressing the down arrow key allows me to select options from intellisense, I just cannot see them. 

    I have tried the following but the issue still occurs in both 32bit and 64bit ISE:

    • Created a new windows profile
    • sfc /scannow
    • DISM.exe /Online /Cleanup-image /Restorehealth

    Build 17127.rs4_release.180318-0047

    I can't add a screenshot of the fault until my account is verified

    Any ideas how to repair ISE, or what might be the cause of this issue?

    Saturday, March 24, 2018 10:17 PM

Answers

  • For me Snippets have not worked in ISE for last few preview build also (Ctrl+J)

    The IntelliSense not working on variables have been logged in the Feedback Hub, if that is the same upvote that.

    https://aka.ms/Ortvxl

    (above link will open in Feedback Hub)

    • Marked as answer by -Jacob- Sunday, March 25, 2018 7:52 PM
    Sunday, March 25, 2018 12:24 PM

All replies

  • For me Snippets have not worked in ISE for last few preview build also (Ctrl+J)

    The IntelliSense not working on variables have been logged in the Feedback Hub, if that is the same upvote that.

    https://aka.ms/Ortvxl

    (above link will open in Feedback Hub)

    • Marked as answer by -Jacob- Sunday, March 25, 2018 7:52 PM
    Sunday, March 25, 2018 12:24 PM
  • Not fixed in 17128.1 :(
    Sunday, March 25, 2018 6:39 PM
  • I wasn't sure if it was a build issue or just something specific to my device, it too has occurred for the last few builds. 

    I've commented, up voted and submitted the screenshot on the feedback hub - Thank you for the link. 

    Sunday, March 25, 2018 7:52 PM
  • Were you able to fix this issue?  
    Tuesday, May 15, 2018 3:02 PM
  • Were you able to fix this issue?  

    It was an Insider Build issue, was solved in later build.
    Tuesday, May 15, 2018 5:31 PM
  • Could you tell me which build resolved this issue? I have experienced this for several months, currently running 17134.48 and the issue persists.

    Wednesday, June 6, 2018 3:09 PM
  • Could you tell me which build resolved this issue? I have experienced this for several months, currently running 17134.48 and the issue persists.

    Powershell ISE Intellisense in Windows 10 1803 does not work

    Related post, it does not work again in 1803 at present. There is a work-around in that thread involving installing the ISE preview.

    Wednesday, June 6, 2018 5:56 PM
  • PoSH ISE - 5.1.17134.48 in Preview 1803 - It's unclear to me why this thread was marked answered because I see no answer provided. I too have updated feedback hub but I did find mitigation (thank you @phatlinebeta /reddit). I found ISE Preview appears to have this functionality working. 

    Install-Module -Name PowerShellISE-preview
    Install-ISEPreviewShortcuts # To add startmenu shortcuts
    isep #To launch from pshell or regular ise

    Monday, June 11, 2018 8:12 PM