none
PPPoE connection issue, error 651

    Question

  •  I connect to internet through RASPPPOE. With XP i have to install drivers from -> (http://www.raspppoe.com/)

    For Vista there are no drivers available, as they are inbuilt.

    I had to do following in Vista - In "Network and Sharing Center", i used to click on "Set up aconnection or network" then Select  "Connect to the internet" then Click on "Broadband (PPPoE)" then I had to enter the User name and password, and it would get connected. Now in Windows 7, I do the exact same thing, and i get - Error 651: The Modem (or other connecting device) has reported an error.

    I have installed Windows 7 on 2 different machines, but getting the same error.  I strongly believe is a bug in Windows 7.

    Sunday, January 25, 2009 1:15 PM

Answers

  • http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/0a015ef7-f9c4-497c-b94b-f980f0595f06

    look on this page

    Tuesday, January 27, 2009 10:54 PM

All replies

  • wrong encoding of servive name,search in and find topic pppoe wrong encoding
    • Marked as answer by xabhijitx Monday, January 26, 2009 9:04 PM
    • Unmarked as answer by xabhijitx Monday, January 26, 2009 9:04 PM
    Monday, January 26, 2009 1:40 PM
  • I dont really understant what you are trying to say, I have posted it under ->

    Microsoft TechNet > Forums Home > Windows 7 Beta > Windows 7 Networking

    I think its very much correct, please explain in details what you are trying to say. 

    Monday, January 26, 2009 9:06 PM
  • http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/0a015ef7-f9c4-497c-b94b-f980f0595f06

    look on this page

    Tuesday, January 27, 2009 10:54 PM
  • So its a bug in windows 7, and people like us can not connect to internet with windows 7,  that makes feed back impossible! so what now ?
    Wednesday, January 28, 2009 6:21 PM
  • Wait for a beter beta version. You don't 'fix' a beta, you upgrade it.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, February 05, 2009 10:08 PM
    Moderator
  • Mark,

    it's still present in bld. 7000. I solved this problem by replacing the raspppoe.sys from Vista SP1, but I seriously doubt that it's a normal way :)

    PS: Hurrah! Finally it's fixed in the build 7127.

    WMBR, George Hazan
    • Proposed as answer by George Hazan Tuesday, June 02, 2009 7:21 PM
    Sunday, May 10, 2009 5:03 PM
  • Get rid of anti virus program. I had some problem when using Kaspersky anit virus 8 but resolved as soon as I removed it. I suspect virus software is still too far behind. I am using the RC for info.
    cj
    Saturday, May 30, 2009 7:11 AM
  • No, the antivirus program is not a problem in this case; I don't have any.
    Tuesday, June 02, 2009 7:22 PM
  • RTM 7600 still has thus bug. I find it outrageous.
    Wednesday, August 26, 2009 4:52 PM