Windows XP Service Pack 3 = Blue Screen of Death



    I have a DELL Dimension 5100.  I had my computer set to automatically update itself with updates from Microsoft and I have noticed that a LOT of people are having issues with SP3.  After my computer updated from Windows XP Service Pack 2 to 3; I got the Blue Screen and an error message.  Stop: C0000221 {Bad Image Checksum}  The image wldap32.dll is possibly corrupt.  The header checksum does not match the computed checksum.  That is far as I can go.  Safe mode will not work either.  I read some other website forums and I went into BIOS and set my computer to boot from a Windows XP Service Pack 1 CD Rom that I have.  That is the only XP Cd Rom I have.  That part worked and I got to the Recovery Console screen.

    Microsoft Windows XP(TM) Recovery Console.  The Recovery Console provides system repair and recovery functionality.  Type EXIT to quit the Recovery Console and restart the computer.

    1: C: \WINDOWS

    Which windows installation would you like to log onto

    <To cancel, press Enter>?

    This is where I am stuck.  I press Enter and it starts all over again and brings me to the same spot; I try to enter my password to windows which is like almost 12 characters long but it only lets me type one character.  What do I do now? Also am I on the right track?  I thought I was.

    Monday, September 22, 2008 5:16 AM

All replies

  • Evening Alderan

    1) By chance did you have any anti-vrus programs running?

    Norton is the worst offender. as mentioned here


    2) Has your user account been updated with the subinacl.exe and the reset command? Sp3 does not install properly from a adminstrator account it needs a computer adminstrator account.


    a)    Boot back into your recovery console and pull the information out of the svcpack.log file as mentioned in this kb.



    b) Or the error that appears in this



    If you do not find anything that matchs the above kb, please post back your results.


    3) There might be something simple as having a SATA driver diskette or usb key drive available.



    4) Post sp3 troubleshooting steps.


    5) there are some simple fixes listed here. And a list of things that might help your situation out


    Monday, September 22, 2008 5:43 AM
  • Thanks for responding so quickly. No, I did not have any antivirus software running at the time. Actually I just got past the point where I got stuck before then I got stuck again. I pressed 1 then Enter on the Recovery Console Screen; then I got prompted for a password. I tried my windows password which which did not work.  So I then started over and just pressed Enter.  This time and I got the c:\ windows prompt.  I then entered

    copy C:\windows\servicepackFiles\i386\wldap32.dllc:\windows\system32  

    It could not locate any file with that name so I then tried

    copy c:\I386\wldap32.dll c:\windows\system32          

    and it said access is denied.         I am really stuck now.  Most of those links you gave me have fixes if you can get windows to load up; my blue screen is far as I can go.  I guess I need step by step instructions. I wish I never updated to Service pack 3.  I have so much important info (research papers, essays that I have written, music, movies, etc.)  on my computer if I loose all of that info I will be literally sick.

    Monday, September 22, 2008 6:36 AM
  • Evening

     if you do not mind what is the error and the 0x number? Will give us a better direction. For the next attempt. Most problems can be solved one way or another.

    Where you able to boot into safe mode at all? Pressing the F8 key just before the splash/welcome screen.


    Set your motherboard bios to boot from the cd. Consult your manual for how to set this to boot. Each computer can be different

    Hp is F11. Some are Del key, and some are F1 key.


    Easily solve boot into your recovery console.

    Get to the point where you can choose recovery console.


    Once you have the >_

    enter this


    batch \%windir%\$NtServicePackUninstall$\spuninst\spuninstl.bat


    Let this run until completion. It may take awhile depending on the computer.




    Tuesday, September 30, 2008 9:32 AM
  • Ive had this same issue .. my pc is pretty dated now its a compaq somthing or other, a tower that is all ready to use, not one that you pick individual parts and they make it .. just one that was in the shop all ready.

    its got an amd  3500 i think cpu

    geforce 6200 gfx card .. ect ect ect getting old now not entirely sure of all the numbers and such that describes it all.

    but anyway. i dont actually have a window disk, when i loaded it up the first time i made recovery disks which i assume have windows on them.

    my pc also has a recovery drive .. now a few weeks ago i was looking for updates to my pc just trying to keep it in order. well any way i found sp3 .. and thought to myself 'ok now i know theres an sp 2 but 3 .. ok ill download it'

    spent a good 3 hours waiting for it to install. then restart the pc all fine and dandy.

    gets passed the usual first couple of screens the BOOM blue screen of death. i did'nt read it all, unfortunatly i quite frankly crapped myself. (but not litterally.. almost but not quite.)

    anyway now ive fixed the whole thing ran my recovery thing got my pc back to factory settings .. and im in the now. for the last week or 2 .. automatic updates has been asking me to install sp3 .. and to be honest i really dont think i will bother if its going to F*k up my pc again..

    it basically wasted a whole day because of an update... arnt things like this not supposed to happen?

    anyway i seem to be doing just fine without it.

    but i was maybe thinking that the problem maybe somthing to do with my pc bieng a pre-set tower with its own 'windows installing software' and maybe just maybe wasnt designed to survive untill sp3 (or you know, just not built to install/run/update to it.

    meh just a guess.
    Wednesday, October 01, 2008 7:40 AM
  • Keith


    Found I need to do a little more than the batch line provided and there was mispelling (sic) in the file to run.


    copy \%windir%\$NtServicePackUninstall$\spuninst\spuninst.txt \%windir%\$NtServicePackUninstall$\spuninst\spuninst.bat


    batch \%windir%\$NtServicePackUninstall$\spuninst\spuninstl.bat


    Other than that the instructions were fab!



    Wednesday, October 08, 2008 4:46 PM
  • Same problem on my Dimension 5150. Completely ruined it. MS support useless and have not acknowledged in writing that the problem exists with service pack 3.


    Totally cheesed of with MS and all my attempts to get it back to its original state have failed. I'm not an expert and don't see why I should waste my time having to investigate a fault caused by MS. They even sent me new disks but the installation wiped out all the drivers so I cant do anything with it.


    Their attitude is apalling, all they ever do is refer you to support sites and expect you to sort it yourself, not just for this problem but almost everything. If you had a car that brokedown would you expect the garage to point you to a bench and say here are some tools and a few books, perhaps you wish to sort it out yourself. It is EXACTLY what ms expect you to do and to many people swallow it. Well I haven't. I have written to Trading Standards asking them to investigate why Microsoft are issuing an update in the full knowledge that it potentially causes problems.


    Frankly it is symptomatic of MSs failure to test things probably before release. Take a look at the MS support site and see how many fixes, patches and updates there are for various problems. Ask your self why these are necessary.


    I have also asked them to pay for my PC and my wasted time trying to fix it and will take it to the small claims court if I have to.

    Friday, October 31, 2008 11:44 AM
  • Further to my post 31/10/2008 I issued proceedings in the UK small claims court against MS for the loss of my PC and the cost of my wasted time trying to fix it.

    Initially they indicated they would defend the claim but they did not follow up and judgement was granted in my favour on the 18th, December.

    I had to issue a warrant of execution on MS and the Bailiff has confirmed today thay they have now received full settlement.


    Monday, January 26, 2009 2:57 PM