none
slow file transfer on LAN, machines OS Win 7 Ultimate 32 bit, AVG Internet Security RRS feed

  • Question

  • loaded Win 7 on 2 machine over LAN , shared out folders transfer rate is about 5 bytes per second. Checked security protocols, no problem with internet traffic only transferring files between two Win 7 machines on LAN. No such problems with XP. I'm sure in this security wizard overkill stuff in 7 there is something I missed. 
    Wednesday, February 17, 2010 7:08 PM

Answers

  • Hi,

     

    Based on my research, I would like to suggest the following:

     

    1.    Update the NIC driver for the Windows 7 computers.

     

    2.    Update the router’s firmware.

     

    3.    Boot the computers to Safe Mode with networking and check how it works.

     

    4.    Please run the following commands in an elevated command prompt in Windows 7:

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, February 19, 2010 10:36 AM
    Moderator

All replies

  • Hi,

     

    Based on my research, I would like to suggest the following:

     

    1.    Update the NIC driver for the Windows 7 computers.

     

    2.    Update the router’s firmware.

     

    3.    Boot the computers to Safe Mode with networking and check how it works.

     

    4.    Please run the following commands in an elevated command prompt in Windows 7:

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, February 19, 2010 10:36 AM
    Moderator
  • This is the ONLY answer that FINALLY worked for me...

    I changed these 3 settings, restarted my pc and snail pace speeds are replaced with normal functionality..\Thank you

    I am amazed at how many forums and Microsoft Emgineer hacks havent been able to solve such a basic function of the win7 os. Hopefully everyone finds this answer before going elsewhere.

    Thursday, June 7, 2012 2:15 AM