none
Windows can't communicate with the device or resource (primary dns server)??? Are my routers conflicting with each other?

    Question

  • I have a network where I am trying to use my Linksys WRT54G wireless router as a switch. I have my modem hooked up with it and I have one PC hooked up to it with no problems connecting to the internet. Also connected to that router is one Netgear XAVB101 Powerline Ethernet adapter, with another plugged in downstairs connected to my laptop where it serves as a direct connection from the switch to my laptop which is across the house where I get no wireless signal. This all works fine until I try to use my Linksys WRT300N wireless router on the same network as a switch/wireless point in the room where my laptop is. It will work for 5 seconds until it gets an error that says "WINDOWS CAN'T COMMUNICATE WITH THE DEVICE OR RESOURCE (PRIMARY DNS SERVER)". I'm pretty positive it has nothing to do with my powerline adapters, but that the routers are conflicting with one another. Do I have to manually input different DNS servers on my WRT300N? And if so, where can I find those numbers to input? I feel like this may be a normal problem when connecting 2 routers on one network, but I can't find any help online anywhere. I appreciate any help anyone can give me.
    Sunday, July 11, 2010 7:03 PM

Answers

  • What do you have for a modem:  a simple modem, or a modem/router (AKA "internet gateway")?  If you're not sure, what's the make & model of it?

    Settings would need to be changed on the secondary router (the '300N), not the primary (assuming that the primary really is operating as a router, connected to a simple modem.)
    If there's no Operating Mode choice, I'd say that it's safe to disregard that one item, so long as all other settings are made as recommended.
    And, it doesn't connect to the internet - it connects to your LAN - any clients that are connected to the '300N (be it wired or wireless) connect to the internet via your primary router.  You're after disabling the routing, DNS, and DHCP functionality on the secondary router, allowing it to work as an extention of your existing network.  Functionally, you're literally reducing it to a simple switch (albeit one with a wireless AP built in.)

    Regards,
    Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by J-Cap Monday, July 12, 2010 12:29 AM
    Sunday, July 11, 2010 9:50 PM

All replies

  • Even money says that your '300N is still operating as a router (which you do not want), rather than a switch/AP (which you do want.)
    And, actually, you do not want to enter DNS info into it - that is handled by your primary router (or residential gateway device.)

    Here's a copy/paste of a writeup I've posted in the past, on how to properly configure a Linksys wireless router to be a switch/AP:

    Unfortunately, setting up a Linksys router to operate in AP-only mode isn't all that intuitive... 
    Note:  do this with the wireless router NOT connected to your LAN!!!!
    First, reset the wireless router (consult its manual.)
    Log in to the Linksys (natch.)
    Setup > basic setup.
    -internet connection type: Automatic configuration DHCP
    -network setup: local IP address to one on your subnet, but outside of your router's DHCP range (example: my DHCP range is 192.168.0.100~199, my WRT54G is set to 192.168.0.254); subnet mask same as your network (default is 255.255.255.0); ignore gateway and local DNS (leave them blank.)
    -DHCP settings:
    --DHCP type: DHCP server
    --DHCP server: disable
    Click Save Settings.
    Setup > advanced routing.
    -operating mode: router.
    -Dynamic routing: interface: disable.
    Save Settings.
    Congratulations! You've set up a Linksys wireless router to operate as an AP + switch only! 
    And, put a piece of tape over the Linksys' WAN port, so you're not tempted to use it.

    Power down your new AP, and reconnect it to your LAN.

    HTH,
    Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, July 11, 2010 8:15 PM
  • First off, am i supposed to change those settings on the router connected to my modem? because I tried changing them on my 300N, which is my one on a different floor than my modem but there is no Operating Mode choice under advanced routing.

     

    and secondly, whichever router i change those settings on to make them a AP/switch, how does It connect to the internet when I can't use the WAN port?

    Sunday, July 11, 2010 8:53 PM
  • What do you have for a modem:  a simple modem, or a modem/router (AKA "internet gateway")?  If you're not sure, what's the make & model of it?

    Settings would need to be changed on the secondary router (the '300N), not the primary (assuming that the primary really is operating as a router, connected to a simple modem.)
    If there's no Operating Mode choice, I'd say that it's safe to disregard that one item, so long as all other settings are made as recommended.
    And, it doesn't connect to the internet - it connects to your LAN - any clients that are connected to the '300N (be it wired or wireless) connect to the internet via your primary router.  You're after disabling the routing, DNS, and DHCP functionality on the secondary router, allowing it to work as an extention of your existing network.  Functionally, you're literally reducing it to a simple switch (albeit one with a wireless AP built in.)

    Regards,
    Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by J-Cap Monday, July 12, 2010 12:29 AM
    Sunday, July 11, 2010 9:50 PM
  • Alright thanks very much. I had a friend  come over and help and it was simple. I was just made it overcomplicated. Glad to finally know how to do this.
    Monday, July 12, 2010 12:29 AM
  • You're welcome.  Glad to help.  :)
    And, thanks for the feedback.

    -Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, July 12, 2010 1:51 AM