none
Acer Netbook Windows7 Starter Print problems

    Question

  • I have a home network connected via a Netgear WNR2000 Router.

    1 wired computer running XP Home

    1 Dell Latitude running XP pro

    1 Compaq laptop runnign XP Home

    1 HP LaserJet M2727nf USB connected to the Dell

    1 HP Deskjet 6988 wirelessly connected to the network

    I recently bought an Acer Aspire One netbook running Windows 7 Starter to replace the Compaq.  The intent is for it to use the HP Deskjet exclusively for printing.  I do not want it printing to the LaserJet.  I connected the Acer to the network and installed the printer with the driver supplied with windows.  Installed Microsoft Office 2007 Home and Student, and Microsoft Outlook.  Transferred all documents and outlook files from the Compaq to the Acer.  Internet access and email (except as detailed below) work fine.

    The problem is printing.  The print jobs seem to hang up in the print queue.  The printer will print a single line then stop with the "on" light blinking.  To clear, it takes manually cancelling all documents in the print queue, and powering off the printer.  At times, very small print jobs, like a small email will print ok.  Anything with any size, for example a PDF file, will never print.  When a print job is stuck, email will not work.

    Based on what I've read so far, I set the router to assign the printer to a static IP address.  That has not solved the problem.  I upgraded the router firmware to its most recent version, no change.  I experimented changing settings with the print spooler to delay until the last page was spooled, print directly to printer, etc to no avail.

    The XP computers always did, and continue, to print fine.  Obviously this is a problem with the Win 7 OS.

    There is no updated driver available for this printer.

    What do I do to get this thing to print?

    Sunday, April 25, 2010 2:04 AM

All replies

  • Windows 7 starter edition lack a few feature as compare to home and ultimate edition. Have you verify the printers drivers is working fine and no exclamation mark or whatever in device manager?
    Sunday, April 25, 2010 4:06 AM
    Answerer
  •  

    Hi,

     

    Here are some suggestions you can try:

     

    1. Clear Printer Spooler files and enable the spooler service on Windows 7

     

    a. Click Start, type "Services.msc" (without the quotation marks) in the open box and click OK.

    b. Double-click "Printer Spooler" in the Services list.

    c. Click Stop and click OK.

    d. Click Start, type "%WINDIR%\system32\spool\printers" in the open window, and delete all files in this folder.

    e. Click Start, type "Services.msc" (without the quotation marks) in the open box and click OK.

    f. Double-click "Printer Spooler" in the Services list.

    g. Click on Start. In the Startup Type list, make sure that "Automatic" is selected and click OK.

     

    2. Temporarily turn off firewall and antivirus program on the machine for a test.

     

    Thanks,

    Novak

     

    Thursday, April 29, 2010 6:04 AM
  • No help.  Any other ideas?  Would upgrading to a higher win7 level help? 
    Wednesday, May 5, 2010 2:35 AM
  • Anybody?

     

    Friday, May 7, 2010 2:23 AM
  • Playing around with it and it found that the router is continuously assigning it new IP addresses even while the computer remains on continuously.

    I have the Dell and the netbook both open at my desk and connected to the router wirelessly.  I am monitoring the "attached devices" screen on the router manager.

    The Dell has been continously at the same IP address: xxx.xxx.x.17.  In the past 1/2 hour, the netbook has gone from xxx.xxx.x.22 to xxx.xxx.x.33.

    I tried to reserve an address for the netbook, rebooted, and the netbook was still assigned a different address. Is this normal behavior?Could this explain my printing issues? 

    Friday, May 7, 2010 3:29 AM