none
Enable Edge Browser to render very large html files RRS feed

  • Question

  • Hello everybody,

    we have several documentation files in html format. Some of them are about 50 MB and larger, and reference lots of GIF files. Edge as well as Internet Explorer 11 do not render them fully. After a certain location in the file, both browsers only render white space down to the end of the files.

    Is this a hard-coded limit, or can we configure one of the browsers so that they will render larger html files?


    Best Regards, Stefan Falk

    Tuesday, March 14, 2017 10:30 AM

All replies

  • Hi Stefan Falk,

    This seems to be related to the "Enhanced Protected mode".
    Please open Internet Explorer 11 as administrator then input the path to the html file in the URL. Add the URL to the "Trusted Zone". Ensure the "Enhanced Protected mode" option is not enabled(Internet Options\Advanced\Security\Enhanced Protected mode).

    Enhanced Protected Mode and Local Files
    https://blogs.msdn.microsoft.com/ieinternals/2012/06/19/enhanced-protected-mode-and-local-files/

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 15, 2017 1:57 AM
    Moderator
  • Hello MeipoXu,

    Thank you very much for your prompt answer. I noticed that the file opens just fine if it is run from the local intranet zone or trusted sites zone, if the zone has proctected mode disabled. The file's location does not have to be in the trusted sites; intranet with protected mode disable works just fine.

    Can I enable this to a file in C:\users\Stefan\Documents\SomeFolder, and if so, how?


    Best Regards, Stefan Falk

    Wednesday, March 15, 2017 2:24 PM
  • Hi Stefan Falk,

    The key point is the permission. Have you tried to open Internet Explorer 11 as administrator then input the path to the html file in the URL(such as C:\users\Stefan\Documents\SomeFolder\test.html)?

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 16, 2017 1:51 AM
    Moderator
  • Hello MeipoXu,

    Thank you again. Running IE as admin did not help with the file from the C: drive. The file is seen as Internet Zone, and disabling protected mode for the Internet Zone did not help either.

    I guess I could solve my problem if I could add my C:\... folder to the trusted sites zone - do you know a way of doing so?


    Best Regards, Stefan Falk

    Thursday, March 16, 2017 10:00 AM
  • Hi Stefan Falk,

    "I guess I could solve my problem if I could add my C:\... folder to the trusted sites zone "
    The URL in Trusted sites zone should be "https:\\". So I didn`t think it is available to add C:\ to trusted site zone.

    Please try to tick the following option:
     Internet Options\Advanced\Security\Allow active content to run files on My Computer
    Restart the machine then check the symptom again.

    In addition, check those files` properties that couldn't be opened for the "unblock" option.

    Here is a link for reference:
    Understanding Local Machine Zone Lockdown
    https://blogs.msdn.microsoft.com/ieinternals/2011/03/23/understanding-local-machine-zone-lockdown/

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, March 17, 2017 6:43 AM
    Moderator
  • Hello MeipoXu again,

    Thanks for your tipp. I tried that already, and supplemented it with rebooting and running as admin. However, it didn't help.

    If we don't find a solution with reasonable efforts, I guess I will just put the documentation on a file server. That worked and would be sufficient for me.


    Best Regards, Stefan Falk

    Friday, March 17, 2017 10:47 AM