SP1 Failed Install - Error Code 0x800f0a12


  • Service Pack 1 won't install for me.  I've dug through a bunch of the other posts on here in regards to this issue.  I use this post as one of the more helpful sources for me.

    Now I have Ubuntu loaded on another partition and I use GRUB to load to it.  When I run BCDeditlog.txt I get this:

    The boot configuration data store could not be opened.
    The system cannot find the file specified.

    I did include a the zip file of the logs from CBS and a few of the other logs asked for

    <iframe title ="Preview" scrolling="no" marginheight="0" marginwidth="0" frameborder="0" style="width:98px;height:115px;padding:0;background-color:#fcfcfc;" src=""></iframe>

    In that other forum post there is a link to 'repair the BCD'.  I haven't proceeded with that part simply because I don't know if that is something that will screw up using grub and my ubuntu partition.


    I hope I have included everything to make this as smooth for those who can provide help.



    Wednesday, February 23, 2011 1:33 AM


  • I have a dual-boot system with 64-bit Win7 and Fedora FC 14 Linux and received the same 0x800f0a12 Win7 SP1 failure code.  diskmgmt.msc showed that the 100 MB partition already had a drive letter assigned (D:).  Selecting Repair after booting from my Win7 DVD allowed SP1 to complete successfully.  After successful upgrade to Win7.SP1, both Win7 and Fedora boot successfully.
    • Proposed as answer by Andre.Ziegler Wednesday, February 23, 2011 1:44 PM
    • Marked as answer by Pigmasta Wednesday, February 23, 2011 5:37 PM
    Wednesday, February 23, 2011 4:59 AM

All replies

  • Did you disable the automount policy as I stated in my blog?  If not, try giving the system reserved partition in Windows a drive letter and then reinstalling the service pack.
    --Joseph [MSFT]
    Wednesday, February 23, 2011 1:37 AM
  • I tried enabling automount and restarting aswell as giving the reserved partition a drive letter manually.  That's when I noticed something I thought was fishy.  I noticed that I didn't have a 200mb partition stored anywhere on my system.

    I have an unused 14.65 gb partition at the beginning which this whole time I assumed was the boot sector held by Windows.  I have my windows regular partition (C) and a Shared data drive for windows and linux (D) and my linux partition is 23.8gb and a manditory 1gb used for linux.

    I wonder if this is my issue?

    Wednesday, February 23, 2011 3:02 AM
  • I have a dual-boot system with 64-bit Win7 and Fedora FC 14 Linux and received the same 0x800f0a12 Win7 SP1 failure code.  diskmgmt.msc showed that the 100 MB partition already had a drive letter assigned (D:).  Selecting Repair after booting from my Win7 DVD allowed SP1 to complete successfully.  After successful upgrade to Win7.SP1, both Win7 and Fedora boot successfully.
    • Proposed as answer by Andre.Ziegler Wednesday, February 23, 2011 1:44 PM
    • Marked as answer by Pigmasta Wednesday, February 23, 2011 5:37 PM
    Wednesday, February 23, 2011 4:59 AM
  • Interesting, sounds like there might be something with the boot code thats being manipulated then.

    Pigmasta, can you try the same thing as Jesse_B (select repair from within WinRE) and let me know the results?  I'll look into this a little more internally and see what else I can find out.

    --Joseph [MSFT]
    Wednesday, February 23, 2011 12:01 PM
  • That was my biggest concern, if linux would still work for me.  Now one more road block question... my laptop didn't come with any Windows 7 CD or even a boot CD with it, is there a place I can download just the boot repair part of the CD or even the CD itself?
    Wednesday, February 23, 2011 2:38 PM
  • If you have an OEM installation, you should have a utility to create media somewhere in your Programs group.

    --Joseph [MSFT]
    Wednesday, February 23, 2011 2:43 PM
  • I have the same error too. My system doesn't have the 100Mb partition, since the boot is done by OSX Snow Leopard.

    Is there any way to solve this?



    Wednesday, February 23, 2011 4:56 PM
  • Can you use gparted to pipe out your drive layout for me?
    --Joseph [MSFT]
    Wednesday, February 23, 2011 5:10 PM
  • I create a CD I got from this 7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso .  I ran it on boot up and did a repair start up.  I booted to windows again and installed the service pack from the CD rather than the auto update (not sure if this was different).  It now worked.  I imagine the boot repair did it.  The 14gb Partition which was unallocated is now allocated as an F drive and has 14gb free space, which it wasn't being detected by windows earlier.  So all and all I think i'm a satisfied forum user!  Thanks for the help guys!




    Wednesday, February 23, 2011 5:41 PM
  • Can you use gparted to pipe out your drive layout for me?
    --Joseph [MSFT]


    Hi Joseph.

    Here -->


    Wednesday, February 23, 2011 6:17 PM
  • Windows 7 and Windows Server 2008 R2 Service Pack 1 (SP1) installation error: 0x800F0A12

    Also see:

    Fix: The Windows 7 partition must be the Active Partition.

    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft

    Wednesday, February 23, 2011 7:54 PM
  • On Wed, 23 Feb 2011 14:38:39 +0000, Pigmasta wrote:

    That was my biggest concern, if linux would still work for me.  Now one more road block question... my laptop didn't come with any Windows 7 CD or even a boot CD with it, is there a place I can download just the boot repair part of the CD or even the CD itself?

    Your laptop should have come with a recovery partition (usually D:)
    and with instructions on how to create a DVD from it. Contact its
    manufacturer if necessary.

    Ken Blake, Microsoft MVP
    Wednesday, February 23, 2011 8:19 PM
  • Can you use gparted to pipe out your drive layout for me?
    --Joseph [MSFT]


    Hi Joseph.

    Here -->


    I looked at your picture and noticed that your Windows partition is not marked as active. Assuming that you have these partitions on the same drive, the simplest approach (next to installing successfully in Safe Mode) is to use the same program you used to display the information to mark your Windows partition as active. As currently configured the Service Pack in Normal Mode looks to the active partition for the boot files that need to be updated. If your Windows partition is not active, this can generate the above error. Make sure that you are logged into Windows 7 using an administrative account for each of the changes.

    1. First, try installing SP1 in Safe Mode. Some users report that this worked for them. If this fails, go to step 2. If successful, skip to step 8.

    2. Write down which partition is marked as active. You will need this to change it back.

    3. Right-click on the partition containing Windows 7 and select the menu item to mark the partition as active. Save changes.

    4. Install Windows 7 SP1. Let the Service Pack restart your system. The update should be applied without problems as it brings you back to the logon screen.

    5. Log on to the administrative user again.

    6. Open a Command Prompt as an Administrative user or as Adminstrator.

    7. Run DISKPART and go through the steps to set your old active partition (the one you wrote down) as active again.

    8. Restart your system.

    You should then be able to boot using your boot manager as before and have SP1 installed.

    Thursday, February 24, 2011 2:22 AM
  • I have the same problem on installing SP1. I have opensuse linux installed in another partition. I tried the following

    • Downloading SP1 manually and installing it from safe mode
    • startup repair and installing SP1 after that 
    • mountvol /E
    • I tried to mount a 100MB drive but it doesn't exist, see here  

    Do you know what's going on?

    Wednesday, March 02, 2011 8:54 PM
  • --Safe mode wont install the Service Pack properly, so dont do that

    --Make sure that your C: drive is what is marked active if it isnt already

    --You dont need a 100MB partition for Windows to function, thats just part of the Bitlocker prep we do at install, has nothing to do with the issue

    --Make sure you dont have the automount policy disabled on your system (

    --Joseph [MSFT]
    Wednesday, March 02, 2011 10:19 PM
  • I have the same problem on installing SP1. I have opensuse linux installed in another partition. I tried the following

    • Downloading SP1 manually and installing it from safe mode
    • startup repair and installing SP1 after that 
    • mountvol /E
    • I tried to mount a 100MB drive but it doesn't exist, see here  

    Do you know what's going on?

    Your Windows system partition (C:) apparently is not marked as active. (If it were, the word 'Active' would show up in the list of attributes for the Windows partition).

    1. Write down which partition currently is marked active. You either will need to use DISKPART to remark it active when you are done or GRUB (or whatever boot manager you are using) will do it for you. Make sure you are logged on as an adminstrative user or the Administrator user.

    2. Right-click on the C: drive and select the Mark Partition as Active menu item.

    3. Do NOT restart your computer.

    4. Install Service Pack 1.

    5. Restart your computer when requested to do so by the service pack.

    6. Make sure that you boot into Windows and not any other OS. The configuration will finish on restart.

    7. Logon to Windows again.

    8. Restart again. If your Linux distro's boot manager does not boot the system you will need to mark the Linux Boot partition as active (or whatever partition was active before). If not, log onto Windows and run DISKPART from an administrative command prompt.

    If you need any other information, let us know.

    Friday, March 04, 2011 2:02 AM
  • my partition flag is pretty weird (maybe because of reformatting).
    on Disk Management (search and run), my D drive has 'system' flag instead of C drive (which has boot flag).
    after I mark D drive as active, then the installer ran with no problem.

    so find any partition which has 'system' flag, mark it as active. don't restart yet.
    remember to untick 'automatically restart' on the installer.
    before you restart, mark the previous partition as active (in this case C).


    Sunday, March 06, 2011 4:30 AM
  • Thank you for your answer! I used DISKPART and activated the windows partition. It is Partition 1.

    DISKPART> list partition

    Partition ### Type Size Offset
    ------------- ---------------- ------- -------
    Partition 0 Extended 35 GB 31 KB
    Partition 2 Logical 2055 MB 63 KB
    Partition 3 Logical 13 GB 2055 MB
    Partition 4 Logical 19 GB 15 GB
    Partition 1 Primary 197 GB 35 GB


    The installation of SP1 worked, however, I have no dual-boot now. I have GParted as a partition manager. Can I try to set the "boot" flag with GParted to try the other partitions and see if the dual boot works again without messing around too much? I imagine that "active" in DISKPART is the same as "boot" in GParted.


    Saturday, March 12, 2011 4:40 PM
  • The 'Boot' flag and 'Active' are the same. However, I would not suggest using GParted to make the change unless you have no choice because DISKPART won't work. Did you write down which partition was originally active before making the change? If not, you could experiment but your configuration is a rather 'funky' one.

    Lots of logical drives but only one Primary partition? Generally, booting operating systems requires the partition to be an active partition. The exception is if the boot manager is running in its own partition and/or is loaded from the MBR or resides in an Extended MBR in its own partition. It is odd that you are running GParted because your disk does not appear to be a GPT or GPT/MBR hybrid disk but rather MBR only with an extended partition at the beginning of the drive rather than at the end.

    Here is my configuration:

    DISKPART> list partition
     Partition ### Type    Size  Offset
     ------------- ---------------- ------- -------
     Partition 1 Primary   200 MB 512 B
     Partition 2 Primary    39 GB 200 MB
     Partition 3 Primary   425 GB 40 GB

    As you can see each partition is a primary partition, which makes them all bootable if they contain boot code from an operating system or from a boot manager. You may not in your case be able to set the correct partition active with DISKPART (I have never tried to run it in such a configuration as yours) but it is worth a try. In the case of failure, you could try GParted but you also could potentially mess things up. I have never run GParted in such a configuration as you have above, either.

    If GParted was not installed to the MBR you will need to activate the partition that actually holds it and runs it. That might be your SuSE Linux boot partition or one of the other SuSE partitions. If your boot manager did not run from another partition then you will need to reinstall it to the MBR and reactivate it where it is supposed to be and it should find your Windows partition and be able to chainload it thereafter. Generally, GRUB boot code is installed in the partition containing SuSE and can be loaded with GParted.

    Try DISKPART first and if that does not work (it likely won't, as you will see below) try GParted. You will only get one shot with DISKPART unless you have the original DVD and run the recovery tools and go to the Command Prompt in advanced options, in which case you can run it as many times as you want. Windows might not boot up if you activate the wrong partition but the boot code will remain in its system partition or C: drive, so it is an easy fix unless you accidentally erase your Windows partition with GParted.

    But, as I said, DISKPART might not work for activating logical drives in an extended partition. I get the following when I try to activate a logical drive:

    DISKPART> active
    Virtual Disk Service error:
    The specified partition type is not valid for this operation.

    I get this when I try to make an extended partition active:

    DISKPART> list partition
     Partition ### Type    Size  Offset
     ------------- ---------------- ------- -------
     Partition 0 Extended   279 GB 8032 KB
     Partition 1 Logical   250 GB 8064 KB
     Partition 2 Logical    29 GB 250 GB
    DISKPART> select partition 0
    Partition 0 is now the selected partition.
    DISKPART> active
    Virtual Disk Service error:
    The specified partition is a not a primary or logical volume.

    You may not have a choice but to run GParted to be able to set it up correctly since you were using it prior to the change. DISKPART might not work for your configuration to restore it to its previous boot state. Your operating systems and your files still are all there but the problem is that the boot code is not being loaded from the MBR or from the partition that originally had the boot flag set.

    But, I could be wrong. It is possible that the DISKPART option did not work for me because the disk I ran it on was not the primary disk in the computer like the previous one with all the primary partitions. You can try it and see. It might work for you with your configuration. Try it first and see.

    Let us know what happens. If it does not work after several tries of using DISKPART, I believe GParted actually comes on a bootable CD originally and can be used to set the boot flag to the proper partition.

    Saturday, March 12, 2011 10:52 PM
  • Thanks, Charles, for the advice. When I set up my system I installed Windows 7 first and then openSUSE linux. With the openSUSE came a dual-boot option with the name grub (this is what I found out now) which allowed me to select between Windows and linux to boot on start up and worked very good up to now. I think that grub it is in the extended partition.

    I now tried to set the "Extended" partition as "active" which was not possible with DISKPART. I used GParted (from live-CD)  to do that. After that, the dual-boot screen appears upon restart. I can select linux to boot, which works. I can select Windows to boot, but this does not seem to work with this setup now. To boot windows again I now have to use GParted (from live CD) and set the boot-flag to the windows partition (partition 1).

    I think I need to install grub again or change some settings there (I don't know how to do that but I hope I'll find out).

    I hope that in future Service Packs this will be more easy.

    Thanks for your help.

    Sunday, March 13, 2011 2:39 PM
  • As far as I know, you cannot boot an extended partition but I think you might be able to boot from a logical drive within the extended partition. From what it looks like, you may have installed GRuB boot code on your Windows partition, which, now may be overwritten by the Service Pack's installation, if that is the case.

    If GRuB was not installed on your Windows boot sector, it may still be sitting on one of the logical drives within the extended partition. It is one of the logical drives which you must mark as active, or set the boot flag on, if you can.

    If you cannot do that, it may well be necessary to reinstall GRuB. There is a fairly easy way to do that without reinstalling SuSE but it has been so long since I have used Linux that I do not recall the methodology at the moment.

    Generally, GRuB, if it is not installed in the MBR, will be sitting on your SuSE partition. I do not know whether you have a separate boot partition from the files partition for SuSE or your files in /Boot are located on the same partition as your / (root filesystem). It will depend upon your installation method you used at the time you set up SuSE on your system.

    The GRuB menu configuration files are generally located in the same place as your boot files (I have seen Linux installations that have the files in /boot and I have seen others with GRuB installed in its own directory on /). Wherever your files in /boot are stored is the logical drive you need to mark as active or on which you must set the boot flag.

    Given that you have an extended partition, which was setup for you when you configured SuSE for the first time, I would say that you need to see whether you can set one of the logical drives within the extended partition as active as I believe that you cannot boot an extended partition (if I recall corectly you only can boot either a primary partition or a logical drive in an extended partition). Otherwise, it is possible that you have overwritten GRuB on the Windows partition, if it originally was installed there.

    I agree that it should be easier to set up the service pack without the hoops but the engineers of the OS cannot account for every possible configuration on every system. Maybe they can hard code a portion of the installer to look instead for files in the \boot location of the Windows system partition or elsewhere instead of the active partition and perhaps this is something they can fix in Windows as well. At least you can boot your Linux installation so that is a good thing and an easier fix. You should be able to look for SuSE information on how to reinstall GRuB in a configuration such as yours.

    Another thing you can try is to use Windows 7's boot manager to boot up SuSE instead of reinstalling GRuB. I have not done that in a long time, either, but I used to do that in the past with some of my dual boot systems and Windows 2000 and Windows XP. I recall having to use the dd command to create a bootsect file containing the boot code of the first 512 bytes of the Linux distro's boot sector code (you can call it bootsect.lin or something like that to remember it and distinguish it from any other bootsect file that may be sitting in your Windows partition) and then call that with Windows 7's boot manager. Again, doing this will require you to know which logical drive contains that Linux boot code.

    In Windows 2000 - XP you would edit the boot.ini file to call the boot manager to use the selected bootsect file you created and copied onto the Windows system partition. In Windows Vista and Windows 7 you now edit the BCD, which requires you to have the partition where Windows is installed to be active in order to function properly, if I recall correctly. You can use a boot.ini file even in Windows 7 but I do not recommend it. I recently used a piece of Microsoft software to recover files from an old OneCare backup on an XP machine prior to installing Windows 7.

    When I finished the restoration, I found that I had the boot manager show up and offer me a choice between Windows XP Media Center Edition 2005 and the Command Console! I had to go in and delete both the console directory and the boot.ini file to restore my system to its proper configuration, so I know it probably would work that way using a boot.ini file. I do not know for sure, however, but, as I said, I recommend doing things the proper way in Windows 7 to prevent further headaches, and using the BCD if you want to go that route instead of using GRuB. If you use the BCD method, you likely won't have a service pack problem of this same nature again even if Microsoft software engineers they never modify the installation methodology of service packs for Windows 7.

    If you want to try that BCD route rather than reinstalling GRuB, let us know and someone among us should be able to walk you through the process to do that.

    • Proposed as answer by D4256 Saturday, March 26, 2011 2:03 PM
    Sunday, March 13, 2011 3:58 PM
  • For those who want to try and go the Windows 7 BCD route, here is a how-to guide. In order for this to work you must have installed GRUB to your boot partition or logical drive for your Linux distro and not to the MBR. If you wrote it to the MBR or used MBRFIX or the like then GRUB is gone and you will need either to reinstall it to the MBR or to the Linux boot partition or logical drive, depending upon whether or not you want to use the BCD method. Once again, the BCD method requires that GRUB boot code is installed to the boot partition or logical drive of your Linux distro.

    Here is the BCD method of multibooting. Make sure to print this guide up so you can follow it and go over it again if something goes wrong. For the record, I tried this just before I wrote this guide and posted it. Everything is working fine for me. Be careful! You can screw things up if you are not careful.

    1. Boot into your Linux-based or Unix-based OS using whatever means necessary.

    2. Create bootsect file (name it whatever 8.3 filename you wish and adjust 'if=' and 'of=' parameters as needed for your OS but 'if=' must point to the device representing your bootable partition containing your other OS and 'of=' must point to the location where you will be saving your bootsect file) by running the command (adjusted as necessary for your purposes) as user root:

    dd if=/dev/rdisk0s2 of=/mnt/share/bootsect.yos bs=512 count=1

    3. Copy the bootsect file to a floppy, shared partition, USB stick, or other device from which you can copy the file to the root directory/folder of your Windows C: drive.

    4. Reboot and log onto Windows 7 as an administrative user.

    5. Make sure Windows C: Drive is active. If it is not, set it to active using either diskmgmt.msc or DISKPART from an administrator user. This is important as BCDedit may malfunction if it does not know where to look for the BCD information store (the program looks to the active drive if there is no Windows System Reserved partition).

    6. Copy the new bootsect file you created to the root directory of said Windows C: drive.

    7. Right-click the icon for Command Prompt and select 'Run as administrator...' menu item.

    8. Run command as follows (this will help hide and protect this file from prying users and from yourself) replacing bootsect.yos with the same file name and extension you used for your bootsect file:

    attrib +s +h +r c:\bootsect.yos

    9. In the same command prompt windows type "bcdedit" without quotes. You should see the following (or something very much like it):


    Windows Boot Manager
    identifier              {bootmgr}
    device                  partition=C:
    description             Windows Boot Manager
    locale                  en-US
    inherit                 {globalsettings}
    default                 {current}
    resumeobject            {3f12c2e6-c437-11df-8660-b6c6e0009e55}
    displayorder            {current}
    toolsdisplayorder       {memdiag}
    timeout                 5

    Windows Boot Loader
    identifier              {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows 7
    locale                  en-US
    inherit                 {bootloadersettings}
    recoverysequence        {3f12c2e8-c437-11df-8660-b6c6e0009e55}
    recoveryenabled         Yes
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {3f12c2e6-c437-11df-8660-b6c6e0009e55}
    nx                      OptIn


    10. Run the command (substituting the name of your OS [with no spaces] for "OS". Examples: "SuSE" or "Linux" or "UNIX"):

    bcdedit /create /d “OS” /application BOOTSECTOR

    BCDEdit will return an alphanumeric identifier for this entry that you will for purposes of this how-to refer to as {device-ID} in the remaining steps in this guide. You will need to replace "{device-ID}" by the actual returned identifier. This number (including the curly braces) is very important! Write it down so you can reference it each time you will need it for the following instructions.

    11. Specify which partition hosts the copy of the bootsect.yos (or, whatever else you named it) file you created:

    bcdedit /set {device-ID} device partition=c:

    12. Now, you need to set the path to your bootsect.yos file:

    bcdedit /set {device-ID} path c:\bootsect.yos

    You will now need to add an entry to the menu that will be displayed at boot time:

    bcdedit /displayorder {device-ID} /addlast

    13. Then, specify how long the menu choices will be displayed:

    bcdedit /timeout 10

    You can decide on pretty much any number you want for timeout but somewhere between 5 and 10 seconds is alright for most people doing this.

    14. Finally, check to see that you will actually see a list of choices of OSes by going to Advanced system settings in the System Control Panel and clicking on the Startup and Recovery Settings button. There should be a dropdown list with the entries Windows 7 and the other entry you created. You can change the two options presented to you as desired but make sure that the default OS is Windows 7 if that is your preference.

    Close out everything and reboot your system. If you did everything right, you will be given at boot time the option of choosing your OS to boot. Keep the device-ID you wrote down! (If you forgot to keep it or lose it later, you can always run BCDEDIT to get the device-ID and list of menu items, so no worries). If you decide later to go with another boot loader and don't want to use the Windows 7 BCD, you can get rid of the new item you created in the BCD menu by typing in an Administrator Command Prompt:

    bcdedit /delete {device-ID}

    That's it! Happy dual-booting....

    Sunday, March 13, 2011 9:57 PM
  • Thank you all, for your helpful tips, hints and solutions. This helped me resolve the Error Code 0x800f0a12.

    System OS: Win7 Ult 32bit.

    NB: a non-dual boot scenario. But several virtaul machines installed on vBox and VMWare.

    HDD 0 = 100mb "system reserved" partition with no driver letter marked as primary system and active;  372GB partition marked as C: primary, Windows, boot, page file, crash dump

    Solved by:

    1. download stand-alone SP1 pack.
    2. uninstall all language packs except default.
    3. disable AV pemanently, instead of the option of re-enable at boot up.
    4. use msconfig to disable bloatware to only allow windows to boot to normal mode.
    5. Run chkdsk.exe  /f  & scf.exe / scannow - no problems on this occassion.
    6. install & run checksur.exe ( KB947821 )
    7. Used disk managment (or diskpart) to assign drive letter to assign drive letter D to 100mb "system reserved" partition with no driver letter.
    8. Mark 372GB partition as active.
    9. run Windows6.1-kb976932-x86.exe with no auto-restart
    10. At completition, use disk managment (or diskpart) to mark D drive 100mb "system reserved" partition , as active. Before 1st re-start.
    11. Reboot and allow multiple reboots as the SP1 confgures itself.
    12. enable bloatware and AV.
    13. Run window update again to install new language packs.

    Hope this helps. As all your hard work above, certainly help me.

    Thanks :-)

    Saturday, March 26, 2011 2:27 PM
  • Hi,

    Sorry to revive such an old thread but I've been looking for a fix for this issue for some time now and I finally got it!

    For me, several things were going on and have all been fixed. I couldn't install a couple of KB updates, windown 7 x86 SP1 and I got a blank screen when trying to add windows featurues in the controll panel with "Turn windows features on or off".

    My set-up: Scientiffic Linux 6.0 dual boot with windows 7, both are x86/x32.

    As per this link: i were able to find and remove previously failed updates (yes i've tried all the MS recommended options like the update readyness tool and the windows troubleshoot option but none of em did the trick).

    At that point I were able to install all updates except for SP1.. But then i found this article! I couldnt run bcdedit because it gave me the error that the file could not be found. I've read all the comments in this thread and saw that someone said that you should activate your C: drive. That didnt do the trick for me, I had to activate the 100 MB ntfs partition that windows made. after that i could run bcdedit without any problem and SP1 installed fine!

    Thanks and good luck!

    Friday, February 24, 2012 8:17 AM
  • Let me fix this for you. Just go into the BIOS and set the physical drive you have windows on to the first hard drive in your boot sequence.

    The fact that you have to do this and that it takes a linux user to solve it show the quality of the Microsoft community and OS. Its kind of silly that the OS has to be on the first boot sequence drive. If this was a linux issue it would have been solved much sooner.

    Saturday, July 14, 2012 5:46 PM
  • ahronzombi,

    Your "fix" would not have worked for me. My Windows drive is the first drive in both BIOS and physically. I am sure that this is the case for many others.

    As to Linux, I happen to experience on a nearly daily basis problems with Linux components that still, to this day, remain unfixed that are fixed fairly quickly in the Windows Community.

    For instance, I have the latest and greatest "everything" in Linux and update frequently enough to ensure it stays that way (updating nearly everyday, and is your kernel at 3.4.4 as of the date of this posting?). I still suffer from an issue that plagues USB on every system I have owned (and a lot of other systems others own) with Linux installed. This has not been fixed since 2004. I don't have these problems in Windows or even on a BSD-based derivation I run--just Linux, no matter the distro.

    I still have several pieces of software that don't do all that is claimed for them. I still have to run Windows programs on Linux to do what I need and even these do not work right unless I run them in a virtual machine.

    One other thing: Last year I installed a version of Fedora (16) on my system and it did not recognize the correct BIOS order of my hard disks. I had to set this manually to keep Anaconda from crashing repeatedly on install!

    Worse, just this year I installed Fedora 17 cleanly (preupgrade failed and corrupted my system beyond simple repair) and it took a "Beefy Miracle" just to get it to boot correctly, if at all! I still am unable to scan using my network scanner that SANE fully supports. I have done everything I have read all over the internet and multiple clean installs, and I still have a non-functional scanner. I can print and fax but the scanner is no joy. It just works on every OS I use except Linux.

    I (and many others far more expert at it than I) can't even get Wine to do a truly decent job at bidi support for fonts and languages without hacks and multiple re-compilations of multiple components.

    I still cannot run Cheese except once on a failed upgrade of Fedora 16. After the failed upgrade Cheese started working for the first time since Fedora 14. After the clean install I finally ended up having to do, Cheese is once again broken and non-functional. Luckily there was other software that could somewhat take its place. The worst thing about this is that I wanted to simply remove Cheese since I am not using it anymore, anyway, but that was not entirely possible. Removing Cheese went OK but removing the Cheese-libs wiped out Gnome and several other applications due to complex dependencies! That initiated another complete reinstall because even the new reinstallations of just Gnome and the applications broken left dependency errors all over the place that took literally days to fix and even then the installations programs would say that software was installed that I visually confirmed wasn't! It was that bad.

    Contrast that with every version of Windows I have ever installed. Every version I have ever installed just installs. And, if there is a problem, which happened to me once because of a new piece of hardware, just add a switch to the install and it was up and running in minutes. Scanning in windows just works and there are multiple ways of doing it even if you don't install the software that comes with the scanner. Bidi just works out of the box or needs complex scripting support installed for the most complex scenarios. Just a tick in a checkbox and a click to an Apply button and I am good to go.

    Don't get me wrong, I love Linux and use it daily but it is not as free from and easy with problems as people make it out to be. Until some of the most basic functions are fixed and not hacked, Linux will never make it to the mainstream. Fact is, each OS has its share of kudos and epic fails. And don't get me started on Gnome 3.x.x and KDE 4.x.x...! :-)

    Saturday, July 14, 2012 9:15 PM