Can not turn on media streaming


  • I am trying to stream content to my Xbox 360 and for some reason I can not enable media streaming.  When I click on "Turn on media streaming" the button will go grey for a few seconds, but then nothing changes.  When I attempt to manually enable Windows Media Player Network Sharing Service, I receive the message "The Windows Media Player network Sharing service on Local Computer started and then stopped.  Some services stop automatically if they are not in use by other services or programs."  I have tried using WMC and setting up the Xbox 360 as an extender but it says it is unable to find the Xbox.  Despite all of this I am able to use Tversity and stream to my Xbox 360 with no issues at all.  I am currently using Avira as my firewall and I have tried setting this up with it disabled with no luck.
    Friday, July 17, 2009 8:11 AM

All replies

  • Hello,

    It's known that streaming to the 360 is kinda buggy for the moment, but if you follow the instructinos in of the links below, you should be able to get where you want! :)

    Good Luck!

    Filip Wilms

    Friday, July 17, 2009 9:17 AM
  • I looked through those links but I couldn't find anything dealing with the issue of being unable to turn on media streaming.  The menu that shows the various devices never actually comes up.
    Saturday, July 18, 2009 8:09 AM
  • I have the same issue, cannot figure out what is causing this....
    Sunday, November 08, 2009 6:55 AM
  • me too having the same problem.
    does anybody have the answer to this issue already?

    The anable mediatreaming button keeps going greyed out and never gets to enabled.
    Sunday, January 10, 2010 10:44 PM
  • Same problem here
    Sunday, December 19, 2010 12:28 AM
  • The first post in this thread described an issue and included Avira Anti virus
    and also stated that TVersity worked. If you have the same issue, try
    uninstalling Avira. If you really don't have the "same" problem, then please
    start a new thread and provide some details.
    On Sun, 19 Dec 2010 00:28:10 +0000, Andialeigh wrote:
    >Same problem here

    Barb Bowman

    Sunday, December 19, 2010 10:23 AM
  •      The way I got  "Turn on media sharing" button to work was to enable "SSDP Discovery" and "UPnP Device Host" services using "Control Panel/Computer Management/Services". I then gave access to my home WiFi/Wired network in "PC Tools Firewall Plus". I did not have to change any settings in my "DLink DIR-625" router. I now have access to all the media on my PC from my PS3 via WiFi.
         I think the issue is that UPnP, which I heard in not very secure, gets turned off in some way and SSDP Discovery needs it to run.


    Here is a link to the ports that have to be enabled threw a firewall...





    Saturday, February 05, 2011 3:37 AM
  • HI all, i got the same issue...but i got a work around...but is temporary... unistalling media features reboot and install media features of windows has been working for me...

    Also i have notice that the service "windows media player network sharing service" fails to start when this issue happens.... once it fails ...there is no way to make it start again...(that i know) unless you remove the media features and reboot then reinstall the media features and reactivate media streaming.... i really like to fix this once and for all... i got to 3 computers with W7. One is W7 Ult X64 and the other W7 Pro X64 they have the same issue but the "fun" laptop has W& Ult X32 has NO PROBLEMS AT ALL with that one ...

    Sunday, February 13, 2011 3:37 PM
  • works like charm...thank you very much. :-)




    Saturday, September 10, 2011 6:27 PM