none
Windows 10 VPN Connections no longer work, can't start remote access connection manager, error 2 RRS feed

  • Question

  • My VPN connections (windows built-in VPN L2TP) stopped working recently. They would hang on connect attempts. Opening the VPN page in settings had a significant delay. Creating a connection just hung and I had to cancel or go back. The connection was partially created, but the old network adapters page showed it wasn't created and missing drivers.

    Tried two different VPN connections, both of which work fine from other devices, and both fail similarly on this machine, so I assume it is not the server that's at fault.

    Seems like the remote access connection manager may be required, but it fails to start. When starting it manually it gives this error:

    Windows could not start the remote access connection manager service on Local Computer. Error 2: The system could not find the file specified.

    No further info on what the missing file is from there or from event viewer.

    - Lenovo ThinkPad P50, Windows 10 Pro, Domain Joined

    - No other VPN clients installed

    - Do have virtualbox installed (found an old reference to this) but uninstalling it didn't help, nor did reinstalling it

    - All other networking functionality seems fine

    - Tried sfc /scannow, nothing detected

    - Rebooting doesn't help

    - Nothing evidently wrong in device manager. Tried uninstalling all WAN Miniport drivers and they reappeared fine on reboot/rescan.

    - All latest windows updates installed, and all Lenovo drivers up to date

    - Can do system restore as I'm not sure exactly when this happened and may have done lots of work since that I don't want wiped.

    - Nothing of consequence in tracing folder logs after running 'netsh ras set tracing * enabled' and trying to start the service.

    - Tried running process monitor while trying to start the service and the only thing that seemed to be file-not-found related was for windows/system32/driverstore/en-us/oem86.inf_loc

    - running 'netsh int ip reset' and rebooting didn't help

    Thanks in advance!

    Clancy

    Wednesday, May 9, 2018 3:32 AM

All replies

  • Also tried:

    Dism /Online /Cleanup-image /Restorehealth

    and:

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.Ins
    tallLocation)\AppXManifest.xml"}

    both with no improvement.

    Wednesday, May 9, 2018 3:50 AM
  • You're a lifesaver, momominta!

    Indeed those two reg keys were not present and adding them fixed everything up. No clue how they disappeared, though... Thanks for the link. My searching clearly wasn't that good.

    For the benefit of those having the same issue, this fixed it for me.

    Open regedit, navigate to:
        [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RasMan\Parameters]

    And add these two keys if they don't exist:

        "AllowL2TPWeakCrypto"=dword:00000000
        "AllowPPTPWeakCrypto"=dword:00000000

    Wednesday, May 9, 2018 4:35 AM