none
Windows 10 Indexing Issues For Domain Users RRS feed

  • Question

  • Hi,

    I’m just wondering if you can help me, because no amount of head scratching is going fix this one!! ;)

      I'm trying to roll out Win 10 pro across 4 schools. I'm running in a 2012r2 domain Environment.  My Issue is that Windows 10 seems to have a massive problem with the Indexing. Basically it works fine in  the first instance, for example the admin user you create when installing Windows.. However, once you've added to a domain and restarted & logged on as a domain user the indexing has broken. All you see is indexing incomplete with the little spinning search arrows. I've tried all the usual stuff like rebuilding the index file and running sfc /scannow but this doesn’t do anything.

    Our Academy is a member of the Volume purchase program for MS software licensing.  So all the ISO images I am using are legitimate and include most updates. I am also running Windows updates manually to force any patches etc.…

    After reading many forums I found a chap that has been able to offer a work around. But this is time consuming when having to do it for every single user on every single Windows 10 machine across 4 sites.

    Basically it’s all down to this…

    C:\Users\admin\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings\en-US

    When Widows 10 creates a new profile it doesn’t include the Indexed folder which contains the settings for all the Language packs.. Thus breaks the indexing function for that profile.

    You have to copy the entire folder from admin (or whatever user you created when setting up Windows) and paste it into the same location of your domain profile with the broken indexing.

    You then have to right click on the indexed folder go properties – general – Advanced – and untick “All files in this folder to have indexed”… Apply to all files and sub folders. Then repeat the process but turn back on. Give the PC 10 mins and BOOM! Indexing is fixed.  This has worked on many machines so far…

    As you can imagine I’m pulling my hair out with this… and have been unable to find anything about applying a permeant fix. Is there not an update I can roll out via WSUS or something? Or am I talking horse dump and doing something completely wrong?

    Any help or advice would be really appreciated.

    Cheers

    Mick






    • Edited by Mikehawo Tuesday, July 12, 2016 11:19 AM
    Tuesday, July 12, 2016 10:43 AM

Answers

All replies

  • Hi ,

    Good to hear that you have found a workaround. We could create a GPP to automatically copy the entire folder from admin(Source file) to domain profile(Destination file ) to workaround it.

    Please check this link about setup a GPP to implement it.
    https://technet.microsoft.com/en-us/library/cc772536(v=ws.11).aspx

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, July 15, 2016 1:58 AM
    Moderator
  • Hello,

    I have the same issue related to indexing issue and missing language pack in windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings\ after joining computers to domain. This problem occur almost on every workstation with Windows 10 in my environment. I think that it's serious bug in Win10 and Microsoft must immediately publish appropriate update to fix this. Advice to resolve this bug using GPO is in my opinion ridiculous!! That may be temporary solution in case of waiting for update. Can anyone help Win10 admins escalate this problem??

    Sunday, October 16, 2016 5:49 PM
  • Count me in as well. It's paralyzing much more use cases than people seem to assume and it needs a quick fix in the upcoming bulk of updates. Not in 3 years, right now.
    Tuesday, October 25, 2016 6:39 PM
  • Hi,

    i can confirm this problem with 1607 and all the latest updates installed as of today.

    It has nothing to do with language packs, that is just a symptom but not the cause, because it happens for me on installations with no language pack at all.

    It looks to me as if it has something to do with the GPO's applied, because the only workaround i found is when create an OU that blocks all GPO's and move the pc, that has no GPOs applied yet!, into this OU, this bug does not happen.

    If a move a pc already joined to the domain in said OU afterwards, it does not solve the bug, so something must have been applied to the pc already.

    I can reproduce this issue 100% with a clean 1607 install.

    This needs to be fixed asap because right now, Windows 10 can't be used in an active directory if you want your users to be able to use the search function?

     


    • Edited by D00fD1ll4 Thursday, November 3, 2016 12:49 PM
    Thursday, November 3, 2016 12:49 PM
  • Thank you so much for providing a workaround for this issue! This problem has been eating away at me for months, but copying the "Indexed" directory from a local admin user to the location where it should be for a domain user, and then re-ticking the "Allow files in this folder to have contents indexed..." setting worked like a charm and allowed Indexing to finally complete successfully.

    I can also confirm this issue occurs with Version 1607, with domain GPO's applied to the client, and the very latest Cumulative Update installed.

    As D00fD1ll4 stated above in their post, this has got to be a GPO issue of some kind, as the issue only occurs after a client has been joined to the domain, with a domain user logged in. The only problem now is isolating which GPO is causing the problem...

    Does anyone have any further insight or clues?


    C Vallejo


    • Edited by C Vallejo Thursday, December 15, 2016 6:30 PM
    Thursday, December 15, 2016 6:20 PM
  • Some interesting Info here. It’s clear it’s a bigger issue than i imagined.<o:p></o:p>

    I'm just not in a position at the moment to build a test environment and then try to replicate the Issues.  I'm wondering now if maybe something would get picked up in the event logs. For now ive just disabled Cortana via registry and started to install the trusted Classic Shell. God bless the person who wrote that!! ;)<o:p></o:p>

    <o:p> </o:p>

    Thanks for everyone's comments and support btw...<o:p></o:p>

    Mick<o:p></o:p>



    Mikehawo

    Wednesday, January 18, 2017 12:39 PM
  • Hello everyone,

    Just FYI, it appears this issue is resolved in the Creators Update. I recently created new corporate images for Version 1703, and the problem with indexing the Control Panel does not exist.

    Can someone else confirm?


    C Vallejo

    Tuesday, May 16, 2017 7:05 PM
  • hmm maybe :) I don't have time for testing 1703 yet, but I think that problem still persist. Many features from Control Panel was migrated to Settings and this can be illusory conviction that issue was addressed. I suggest install latest CU, create new user account and check whether language directory was created under below path:

    %localappdata%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings



    • Edited by nynor Tuesday, May 16, 2017 7:22 PM
    Tuesday, May 16, 2017 7:21 PM
  • Funny thing is, that directory is not present under the user's profile directory, however the user is still able to search for items in the Control Panel without a problem. This was not possible in versions earlier than 1703 without manually copying the directory from another user's profile, as explained in the above workaround.

    Very interesting...


    C Vallejo

    Thursday, May 18, 2017 9:19 PM