Can't connect to corporate SMTP server with one application (others OK)


  • Hi all,

    I’m testing an application called ProcessMaker on my desktop computer at work. This program has an e-mail notification feature with a typical, simple mail setup dialog. I’ve set it to send mail through our corporate SMTP server, but it can’t successfully connect to the server. It resolves the host and port, but just sits and spins when it tries to establish a connection.

    I've worked with our mail admins and established that the SMTP server is working fine. I'm using the right settings. I can telnet to it from my computer. I set up both Outlook and an additional mail app to send mail through the SMTP server and both of them were able to send mail successfully.

    Now it gets weirder: I installed ProcessMaker on my coworker's computer and the e-mail function worked fine.

    So, there's some problem with the setup on my workstation that's interfering with this one application.

    Here's what I've tried:

    • It's a webapp (I have it running at localhost:8080), so I tried it using both IE and Firefox.
    • I disabled SEP to see if the firewall or other protection scheme was interfering.
    • I reset my TCPIP settings using netsh int ip reset.
    • I disabled TCPIP autotuning to see if that was interfering.

    None of these has made a difference. Any ideas from the field?

    Our SMTP server doesn't require authentication or encryption. Oh, and I can't test ProcessMaker using an external SMTP server such as Gmail; we can't use those from inside our corporate network.

    Thanks much!

    Alex Harris

    • Edited by jah1138 Friday, February 15, 2013 9:44 PM
    Friday, February 15, 2013 9:39 PM


  • Hi Alex,

    I suggest you try the following:

    1. Turn off the anti-virus and firewall, run the program using the administrator.

    2. Test this program in Clean Boot mode.

    If the issue persists, you need to contact the application provider for more help.

    Hope this helps.

    Vincent Wang
    TechNet Community Support

    Tuesday, February 19, 2013 5:36 AM