none
StarCraft can not run in Windows 7 RC

    Question

  • The application compatibillty assist doesn't work to install StarCraft using recommended setting after installing the game for the first time.  I have tried run installer as administator/properties install in compatibillity mode for XP SP3/then run the game as adminisator.  I have downloaded the current patch and it took several times trying the install features.  Then it installed appeartly successful.  When you try to play the game it will crash some times at start of running the application.  I have noticed that this game makes the OS unstable ie: other applications like explorer seem to stop working until you refresh screen and caused the mouse pointer to change to a thin dotted line.  I was able to get it back by selectting a different pointer and then reselectting the normal pointer.  I have uninstalled the game and the OS is stable agian.
    Friday, May 22, 2009 1:18 AM

Answers

  • @ solousa2000 I am running Windows 7 RC 64-bit version.
    @ axfelix Alex, yes I was running it in Windows XP SP2 compatibility mode with 256 colors at 640x480 resolution and running as Administrator.

    @ HensonWin7 Some people have said have a Windows Explorer window open and NOT minimized fixes the problem with the turquoise colors showing up.

    @ ScottRB82 Hi Scott, thanks your suggestion worked.

    However, I had to do some additional steps to get it installed on my Windows 7 machine.
    Because after I set the Compatibility Settings and launch StarCraft successfully, it can't upgrade to the latest patch when logging into Battle.net.

    It seems like Blizzard screwed up with their StarCraft Installer.
    The CHECKSUM of the installed files from the downloaded client do not match what the StarCraft Patch Installer is expecting.
    So it says some kinda of checksum error for the StarEdit.exe file.


    After looking for a solution, this is what I did since I have the original CDs.

    1. Install StarCraft from the original CD.
    2. Make a copy of BrooDat.mpq (careful with file name. There is BroodWar.mpq or something like that) file (it's better if you make a complete copy of the entire installation folder...just in case)
    3. Uninstall StarCraft
    4. Re-install from the downloaded installation client from Battle.net.
    5. Replace the BrooDat.mpq file in your StarCraft folder with the backup version from step #2
    6. Set compatibility settings (Windows XP SP2, 256 colors, 640x480 resolution, Run as Administrator).
    7. Start the StarCraft and log into Battle.net and it will successfully update to the latest version.




    So the summary is this.
    1. StarCraft original install CDs have a weird problem with Windows 7.
    2. Downloaded StarCraft Installation file is screwed up by Blizzard.
    3. The Patch file is screwed up because it says the file CHECKSUM for StarEdit.exe does not match.
    4. That's why a workaround file to replace the BrooDat.mpq is needed.

    Hope it helps for other people having the same problem as me.


    ~ Soe
    • Edited by Soe Tun Wednesday, June 17, 2009 3:39 PM
    • Proposed as answer by Soe Tun Wednesday, June 17, 2009 3:40 PM
    • Marked as answer by axfelix Wednesday, June 17, 2009 10:08 PM
    • Unmarked as answer by sprogis Monday, July 06, 2009 2:09 AM
    • Marked as answer by sprogis Monday, July 06, 2009 2:09 AM
    Wednesday, June 17, 2009 3:24 PM

All replies

  • I can confirm this as well. I have tried setting the Compatibility Mode to XP SP3 as well.
    As soon as I click on the "Starcraft" icon (or) Run as administrator, error dialog window shows up with "Starcraft has stopped working".

    I truely hope this issue is fixed somehow because out of all old games, StarCraft is still very popular and widely played everywhere.
    Sunday, June 14, 2009 3:26 PM
  • sprogis  ... it sounds like you have a virus or corrupt installer...

    Soe Tun  ... it sounds like you're trying to install from the disc you bought many many years ago.

    @ Both of you:  Try going to Battle.net, creating an account, adding StarCraft game to the account (it'll require your VALID product key/id) then downloading the newer installer.

    there's also a patch you can get from: http://us.blizzard.com/support/article.xml?locale=en_US&articleId=21149&rhtml=true%3Frhtml%3Dy       i know, it's kinda silly to have to download about 1.25 GB then having to d/l a patch because the version on the official website isn't the final version.... but then again, it's Blizzard so it's really not surprising. however, if you just install then run the game, then go to multiplayer and try to connect to Battle.Net, it'll download the patch and install it automatically (for me, this method worked far better and downloaded much faster.)

    The compatability settings i used (had no problems at all using these):

    for the installer: NONE

    for the game:
    Windows Vista SP2
    256 colors
    disable Desktop Composition
    disable Visual Themes
    Run as Admin
    ~Scott.
    Sunday, June 14, 2009 7:22 PM
  • Hi Scott,

    thank you so much for your help. I did download the 1.25GB from the Battle.net website and installed it.
    After installation, the StarCraft client did start without any problem.

    However, I am having this error now.
    [Battle.net was unable to properly identify your application version.] 


    But this is not Windows 7 problem anymore because I have the same problem on my Vista SP2 as well.
    This looks like something is wrong with the Blizzard's Battle.net authentication (or) CD-key verification.


    Thanks,
    Soe
    Tuesday, June 16, 2009 7:11 PM
  • Setting the _original_ and _unpatched_ StarCraft to run in "XP comportability" will result in nothing, as the StarCraft was made for Win98 (remember this one? :) ), and didn't worked under Win XP, even BroodWar add-on.

    In the XP environment, the problem could be solved, by manually replacing some of CD-ROM driver libraries from 98 to XP.

    Downloading newer installer might be the only solution for Vista and 7.
    Tuesday, June 16, 2009 9:29 PM
  • Which version of windows 7 are you guys using it works fine with my 32bit version of windows 7 on my laptop
    Tuesday, June 16, 2009 10:59 PM
  • Soe,

    Have you tried running Starcraft in compatibility mode for Windows XP now that you're using the new installer? To do this, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    Wednesday, June 17, 2009 3:54 AM
  • Strange that you guys should be mentioning this!

    I installed StarCraft (original, not Brood Wars) at a LAN party a few days ago on Windows 7.  The install seemed to go OK, but the graphics were severely distorted--no matter what compatability options I tried.

    - Henson
    Wednesday, June 17, 2009 5:24 AM
  • @ solousa2000 I am running Windows 7 RC 64-bit version.
    @ axfelix Alex, yes I was running it in Windows XP SP2 compatibility mode with 256 colors at 640x480 resolution and running as Administrator.

    @ HensonWin7 Some people have said have a Windows Explorer window open and NOT minimized fixes the problem with the turquoise colors showing up.

    @ ScottRB82 Hi Scott, thanks your suggestion worked.

    However, I had to do some additional steps to get it installed on my Windows 7 machine.
    Because after I set the Compatibility Settings and launch StarCraft successfully, it can't upgrade to the latest patch when logging into Battle.net.

    It seems like Blizzard screwed up with their StarCraft Installer.
    The CHECKSUM of the installed files from the downloaded client do not match what the StarCraft Patch Installer is expecting.
    So it says some kinda of checksum error for the StarEdit.exe file.


    After looking for a solution, this is what I did since I have the original CDs.

    1. Install StarCraft from the original CD.
    2. Make a copy of BrooDat.mpq (careful with file name. There is BroodWar.mpq or something like that) file (it's better if you make a complete copy of the entire installation folder...just in case)
    3. Uninstall StarCraft
    4. Re-install from the downloaded installation client from Battle.net.
    5. Replace the BrooDat.mpq file in your StarCraft folder with the backup version from step #2
    6. Set compatibility settings (Windows XP SP2, 256 colors, 640x480 resolution, Run as Administrator).
    7. Start the StarCraft and log into Battle.net and it will successfully update to the latest version.




    So the summary is this.
    1. StarCraft original install CDs have a weird problem with Windows 7.
    2. Downloaded StarCraft Installation file is screwed up by Blizzard.
    3. The Patch file is screwed up because it says the file CHECKSUM for StarEdit.exe does not match.
    4. That's why a workaround file to replace the BrooDat.mpq is needed.

    Hope it helps for other people having the same problem as me.


    ~ Soe
    • Edited by Soe Tun Wednesday, June 17, 2009 3:39 PM
    • Proposed as answer by Soe Tun Wednesday, June 17, 2009 3:40 PM
    • Marked as answer by axfelix Wednesday, June 17, 2009 10:08 PM
    • Unmarked as answer by sprogis Monday, July 06, 2009 2:09 AM
    • Marked as answer by sprogis Monday, July 06, 2009 2:09 AM
    Wednesday, June 17, 2009 3:24 PM
  • Hi Heson, I encountered just the same problem you mentioned, yet I have resovled it.

    It has nothing to do with Win 7's compatibility assist. To deal with it, follow the steps below:

    1.run your starcraft programme.
    2.swith to desktop, start task manager, and end the process named "explore.exe".
    3.swith to starcraft using ALT+TAB.

    Then all the graphic errors are fixed.

    This method also applied to Age Of Empire 2 where textures of maps always don't display correctly on Win 7.

    It seems as if desktop stuff that is displayed on top of some old games (though we can't see it), causes all these anoying issues. Hope Microsoft will handle it to further improve Win 7 's compatibility.


    Friday, June 26, 2009 5:49 AM
  • I just want to say thank you to all who have replied to my thread.  I now know that before you start any starcraft installer or patch upgrade you must first left click on the icon and select run as administator it has the little sheild on the left.  the OS will then ask you to allow this option or not so allow it.   Then run in compatibility mode for xp sp2.  I don't think you need to change the resolution.  It works just fine by appiclation settings.  Windows Vista sp2 64-bit
    • Marked as answer by sprogis Tuesday, June 30, 2009 3:31 AM
    • Unmarked as answer by sprogis Tuesday, June 30, 2009 3:31 AM
    • Edited by sprogis Monday, July 06, 2009 2:08 AM os name change
    Tuesday, June 30, 2009 3:06 AM

  • @Soe Tun

    You are right. it does work.  however there is still colour distrotion issue when running the program with Windows 7 RC 64 bit. Any thoughts about how to correct it?  I have tried severll different compitilblity modes nothing worked.   Vista sp2 64 bit loads prefectly when you set run as administrator. 
    Monday, July 06, 2009 2:07 AM
  • Hello

    Have you tried hooking your CD-Key to Blizzards https://us.battle.net? once you do that you get an installer that is much newer then the original one,and does both starcraft and broodwars.The version installed is also a no CD version

    I used this myself for Windows 7 and it had no issues installing...however the game will continue to have the graphic distortions,compatibility mode hasn't figured that out yet
    • Edited by Anon2057 Monday, July 06, 2009 7:52 PM To add that it's a no CD version
    Monday, July 06, 2009 7:51 PM
  • woah!!!... works... guess you are right...

    i did as you said, and it fixed my colors, (note i have ben trying all other stuff)
    and when i ran explorer again (with my game open) the colors turned bad again...
    Thursday, July 30, 2009 2:35 PM
  • to me, the problem was solved when i killed the explorer.exe in the task manager. hope this issue will be fixed until the real w7 will be in sales.
    Monday, August 24, 2009 1:26 PM