none
Win 10 Hyper-V Guest, Gen2, won't install OS from .iso: Using Virtual Hard Disk RRS feed

  • Question

  •  I have a Win 10 Pro Hyper-V Host that works fine. I created a Hyper-V "Gen 1" Guest on this machine and it works fine but when I created a  "Gen 2" Guest (with Win 10 Home) on the same Host I ran into trouble.

    Starting the Gen2 Guest led to this black screen displaying:

    "

    PXE Network Boot using IPv4 ( ESC to cancel )

    Performing DHCP Negotiation

    .. which lead to another screen

    Hyper-V

    _________________________

    Virtual Machine Boot Summary:

    1. SCSI DVD  (0,1)                     The boot loader failed - Time out

    2. Network Adapter (001..)       DHCP failed

    3. SCSI Disk  (0,0)                      No UEFI-compatible file systems was found

    "

    What am I doing wrong?  Does my Win 10 ISO image not contain a UEFU compatible file system?

    Saturday, February 6, 2016 7:12 PM

Answers

All replies

  • Is the Home ISO 32bit? That as far as I understand since Windows 7 32bit has not supported UEFI.

    https://www.microsoft.com/en-us/software-download/windows10

    https://www.microsoft.com/en-us/software-download/techbench

    Both links offer Windows 10 media to download it you need Windows 10 and TechNet Evaluation Center has Windows 10 Enterprise for evaluation.


    • Edited by -Mr Happy- Saturday, February 6, 2016 7:33 PM
    • Proposed as answer by Madmaxs Saturday, April 14, 2018 12:34 PM
    Saturday, February 6, 2016 7:32 PM
  • I found the issue had to do with file protection on the .iso. I had to move it to a new location, more info here: https://social.technet.microsoft.com/Forums/en-US/bcd32697-6091-454d-8828-75dbe1879a03/hyperv-cannot-boot-gen2-guest-from-windows-2012-r2-or-windows-81-x64-iso-file-format-not?forum=w8itprovirt 

    • Edited by Jecj Saturday, February 6, 2016 8:12 PM
    • Proposed as answer by -Mr Happy- Saturday, February 6, 2016 8:14 PM
    Saturday, February 6, 2016 8:11 PM
  • It is 64 bit
    Saturday, February 6, 2016 8:13 PM
  • Turn off Secure Boot on the Generation 2 VM.

    It needs to be off to install an OS.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Monday, February 8, 2016 3:19 PM
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 16, 2016 7:44 AM
    Moderator
  • I've just found my own answer to this through trial and error and had spent a good hour trawling the Internet to find an answer only to deduce it myself, so I will just share here in case it is of help. I had the exact same message above, and am very familiar with Windows in general but a bit of a noob with Hyper-V specifically.

    When I saw the message "Press any key to install from DVD..." (or whatever the exact wording is) I pressed the Enter button as quickly as I could but I still kept getting the above error message. Only finally did it occur to me that the VM didn't seem to be receiving my keyboard input. If you close the entire VM and go back to the VM Manager and look in the Actions column you should see "Hyper-V Settings..." (4th item in the list on my computer). On the page that pops up there is a "User" column, and within is a "Keyboard" item. The default was to use the keyboard from the virtual machine. When I changed this to "Use on the physical computer", and then went back into the VM and repeated the steps above it went immediately into the Windows install once I pressed the Enter key.

    Hope this helps somebody, somewhere :-)


    Jon

    Tuesday, August 8, 2017 6:39 PM
  •   That is odd.  I have never had to do that, and I have installed an OS in more vms than I care to remember.


    Bill

    Tuesday, August 8, 2017 11:20 PM
  • I've seen it if I wasn't quick enough and it was a VM I had created
    previously.  (even though installing the OS again)
     
    I just had to left mouse click inside the VMConnect window before the press
    any key message went away, then I just hit enter and all was fine.
     
     
    Wednesday, August 9, 2017 2:28 PM
  • selecting 'Microsoft UEFI Certificate Authority' would also work.

    Saturday, October 14, 2017 8:06 AM
  • It helped me Jon, thank you.
    Thursday, May 10, 2018 1:42 AM
  • Yay! Jon's keyboard solution worked for me. Reduced frustration, much thanks!
    Tuesday, July 31, 2018 6:10 PM
  • This is not the solution to the problem described and is an inaccurate statement.

    Installing Windows with Secureboot turned on is absolutely supported.  I've done this several times over.  Additionally, in order to get the little sticker OEMs put on their computers indicating they're Windows 8 ready, they must ship with Secure Boot on.  Secure Boot requires UEFI mode for your firmware as well.  

    I've been building Gen2 VMs for more than a year now.  It's only recently been an issue after upgrading to Win10 1803.

    In my case, I remote into the Hyper-V host via RDP and I believe that the RDP session is just not presenting the display fast enough.  There's no way I can tell to have the system post last a little longer.  What helped me was the keyboard input method in the Hyper-V settings.  It still doesn't solve my problem, but allowed my keyboard inputs to register while the VM was turning on so that I could press any key before it timed out.  I still never see the message but if I click and press any key, ultimately it will boot.  It may take a few times.

    But to reiterate - you do NOT need to turn off Secure boot.  In fact, you're reducing your security footprint and following bad practice by recommending people turn off security settings.  

    Don't answer questions like this as you could likely cause someone further issues with what they're trying to do.  People need to be able to develop their images with all the functionality and security they plan on implementing in their production environment.  

    Can someone remove the answer on this?  As far as I'm concerned, this is still an issue that many people face and turning off secure boot is not the answer.  


    nick

    Thursday, August 9, 2018 1:44 PM
  • Hey. Tried this many times with 1 virtual CPU on the WDS VM and it works fine. Adding one more virtual CPU on the WDS VM don’t work anymore. 1 virtual CPU = OK 2 virtual CPUs = NOT OK Maybe an interaction with NUMA or so. Anyway. The main point ist that it works fine for us. Best regards Alex
    Tuesday, September 25, 2018 7:19 AM
  • Hi Alex,

    Try putting your boot order as network first, then CD_ROM.  What I found was that the VM screen isn't loading as fast as the VM is actually trying to boot.  So by the time your display pulls up, it's already past the point where it asks to press any key to boot from CD.

    Putting network first in the list allows it to try an broadcast for a PXE server and will buy you a little time for the console session to fully load.

    I've also resorted to clicking in the window and pressing enter repeatedly.  This works sometimes, too.


    nick

    Tuesday, September 25, 2018 2:09 PM
  • Hey The bootorder makes no difference. Cheers Alex
    Friday, September 28, 2018 11:12 AM
  • Hitting the ANY key worked for me too. 
    Sunday, June 2, 2019 7:08 PM
  • After going through all of these threads, and working on this issue for many hours last week the solution that we found was the naming of the .iso, we had renamed it prior to attempting to launch it, and that was causing it to fail. We copied the same .iso over without renaming it from the original download, and it installed without any issues. Hopefully this will help someone as I had not seen this answer anywhere that I searched.
    Monday, October 21, 2019 2:12 PM