none
Edge crashes on launch on fresh installation on Windows 10 1809 RRS feed

  • Question

  • Edge crashes on launch on fresh installation on Windows 10 1809

    Other machince I have let windows update run and no issues. Fresh installation however and Edge crashes after entry of first two letters in url bar.

    Anyone got a solution?

    Thursday, October 4, 2018 8:02 AM

All replies

  • Hello,

    Try to re-register/reset Microsoft Edge, see if that helps:

    https://www.kapilarya.com/how-to-re-register-reset-microsoft-edge-in-windows-10

    Let us know if this helps!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Thursday, October 4, 2018 9:50 AM
  • Hi,

    Please run these commands as Admin to fix the issue:

    sfc /scannow
    Dism /Online /Cleanup-Image /RestoreHealth

    Afterwards, run the following PowerShell command as Admin:

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

    If the issue persists, do an In-Place upgrade to repair using official ISO file.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, October 5, 2018 7:47 AM
    Moderator
  • I also am having this issue. On Windows 10 x64 1809 Build 17763.168 (December CU) and opening Edge after about 10 seconds causes it to crash.  

    Here is what shows in event viewer:

    Faulting application name: MicrosoftEdge.exe, version: 11.0.17763.168, time stamp: 0x5c009850

    Faulting module name: edgeIso.dll, version: 11.0.17763.168, time stamp: 0xfdebd820

    Exception code: 0xc0000409

    Fault offset: 0x0000000000031c4a

    Faulting process id: 0x34f4

    Faulting application start time: 0x01d491a4d40c79a2

    Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe

    Faulting module path: C:\WINDOWS\SYSTEM32\edgeIso.dll

    Report Id: dfd50f50-2993-420b-8300-c8e63c6797d5

    Faulting package full name: Microsoft.MicrosoftEdge_44.17763.1.0_neutral__8wekyb3d8bbwe

    Faulting package-relative application ID: MicrosoftEdge

    Tuesday, December 11, 2018 10:59 PM
  • I had the same issue, Edge crashed on launch. This was in Event Viewer:

    Faulting application name: MicrosoftEdgeCP.exe, version: 11.0.17763.1, time stamp: 0x90f701bc
    Faulting module name: edgehtml.dll, version: 11.0.17763.168, time stamp: 0x8b650ac9
    Exception code: 0x80070005
    Fault offset: 0x00000000005677c0
    Faulting process id: 0x2750
    Faulting application start time: 0x01d49d61e7b6ee34
    Faulting application path: C:\Windows\System32\MicrosoftEdgeCP.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\edgehtml.dll
    Report Id: 605cdc1a-384e-4992-85b3-c3488e69f810
    Faulting package full name: Microsoft.MicrosoftEdge_44.17763.1.0_neutral__8wekyb3d8bbwe
    Faulting package-relative application ID: MicrosoftEdge

    ---------------------------------------------------------------------------------------

    The following trick did it for me. When adding this registry entry, Edge worked immediately after adding it. Run this command in CMD:


    reg add "HKLM\Software\Microsoft\Internet Explorer\Spartan" /v RAC_LaunchFlags /t REG_DWORD /d 1 /f



    • Edited by starbuff Wednesday, December 26, 2018 10:41 PM
    • Proposed as answer by FUSINON CHA0S Friday, November 22, 2019 8:29 PM
    Wednesday, December 26, 2018 10:30 PM
  • Thanks starbuff for this... registry key fixed this issue for me!
    • Edited by rwilkins1 Wednesday, March 6, 2019 3:29 AM
    Wednesday, March 6, 2019 3:28 AM
  • This solution worked perfectly for me. I had to run CMD as administrator.
    Sunday, March 17, 2019 3:58 PM
  • THANK YOU STARBUFF!!!

    This has been driving me nuts and after 100 different failed fixes, yours was the first that worked!  Thank you.

    Monday, August 12, 2019 2:05 PM
  • Fixed it for me too after none of the other reinstall / reregister / dism / sfc suggestions out there made any difference.

    kempshott

    Saturday, August 17, 2019 10:41 AM
  • The registry change using Starbuffs key fixed my issue as well.  Been working on this for over a week using powershell scripts to reinstall edge and such.  I upgraded to 1909 and shortly after it seemed to break all of our edge browsers in the office.

    reg add "HKLM\Software\Microsoft\Internet Explorer\Spartan" /v RAC_LaunchFlags /t REG_DWORD /d 1 /f

    Friday, November 22, 2019 8:39 PM