none
Problem with WMP 12 and Lyrics Plugin

    Question

  • Hi!

    I am using WMP 12 in Windows 7 and I have a problem with this plugin: http://www.lyricsplugin.com/

    It works, but everytime I restart WMP, it gets disabled and I have to re-enable it.

    As you can see, the plugin seems to be no longer updated and I couldn't find any alternative (it's very simple, but it does what I need).

    I had this problem both in the beta and in the RC and a friend of mine has the same problem too.

    Could you please try it and tell me if you have the same problem?

    If it's so, maybe someone more expert than me could find a workaround or perhaps understand why it happens...

    Or, if you know an alternative, please tell me.

    Thank you very much!
    Sunday, October 18, 2009 9:39 AM

Answers

All replies

  • I'm using it by myself and it doesn't get deactivated upon each start.

    How do you start WMP?
    Sunday, October 18, 2009 12:09 PM
  • I usually start it by opening a song, but now I tried to simply open it and I noticed that the plugin was still active (I looked in the Tools/Plug-ins menu). Then, when I played a song from the library, it deactivated.

    By the way, I have installed only another plugin, the one which is included in Messenger.

    Thank you for the reply!
    Sunday, October 18, 2009 12:22 PM
  • Hi Luca1ST, I have also tested this plugin on my computer and it does not get deactivated. I have checked this by restarting WMP and restarting the computer.
    Sean Zhu - MSFT
    Monday, October 19, 2009 9:03 AM
    Moderator
  • Hi!

    Given your feedback, I think there must be something conflicting with it in my computer. Unfortunately, I have no idea about what could be...

    Anyway, since I plan to install the RTM soon, I will perform a clean install and I'll try to understand what is the problem!

    I'll let you know if I find out something!

    Thank you!

    Monday, October 19, 2009 10:19 AM
  • I actually can't even get it to install.  I used this all the time when I was running XP and using Winamp.  Now I run the install and it just hangs and doesn't do anything.  Anyone else have this trouble?
    Sunday, October 25, 2009 6:39 AM
  • Did you notice a UAC prompt appearing? It often appears minimized.
    Sunday, October 25, 2009 9:49 AM
  • Did you notice a UAC prompt appearing? It often appears minimized.

    Yes, and I click on Yes to let it run.  However once the install window opens up it doesn't do anything.  I have let it run for up to 30 minutes just to see if it was really slow.  However it doesn't respond to anything and I actually have to open the Task Manager and force close it.
    Monday, October 26, 2009 4:46 PM
  • I have the same problem with my WMP and Lyrics Plugin.
    I am using Windows 7 Ultimate Pack, and The Latest Lyrics Plugin.
    Once I restarted my windows, the plugin doesn't show up anymore in my windows media player, but when I tried to configure it from WMP-Options-Plugins, the lyrics plugin was still there...
    Yeah.. I don't know how to enable the lyric plugin which has ben disabled from my WMP...
    Saturday, October 31, 2009 12:04 AM
  • I have the same problem with my WMP and Lyrics Plugin.
    I am using Windows 7 Ultimate Pack, and The Latest Lyrics Plugin.
    Once I restarted my windows, the plugin doesn't show up anymore in my windows media player, but when I tried to configure it from WMP-Options-Plugins, the lyrics plugin was still there...
    Yeah.. I don't know how to enable the lyric plugin which has ben disabled from my WMP...

    To re-enable it, you have to right-click on the to top bar in WMP (that with backward and forward arrows and the Play, Burn and Sync buttons) than Tools-Plug-ins and here you are.

    When you installed it, did it work correctly for some time before starting to auto-disable? Because, if it was so, you could try to remember what you installed when it stopped working.

    By the way, I have post-poned my upgrade to the RTM because I'm going to change my computer soon. I'll let you know if I find out something.
    Sunday, November 1, 2009 8:02 AM
  • Hello,

    Same problem here. Lyrics plugin doesnt work anymore under WMP 12, Windows 7, Home Premium. But is used to work fine first. I am now running it logged in as a standard windows user. Before I was administrative use. Let s try if that makes a difference. ... tataaaa. Switched to administrator. No problem there.

    Goodluck.

    Wednesday, November 18, 2009 9:45 PM
  • Update: Changing account type to administrative user did not solve the problem. None of the other users (standard nor administrative) have any problems with the lyrics pluging.
    Then deleted the installed pluging (c:\program files\media player\plug ins\lyricsplugin.dll) and reinstalled. This solved the problem for me. Bye
    Wednesday, November 18, 2009 10:10 PM
  • i had this lyricsplugin problem too with Windows Media Player 12 (Windows 7 Ultimate x86)

    the plugin can be enabled without any problem.
    i can also close or restart my pc without it being disabled.

    however, everytime i play video file and close the player, it will disable the lyricsplugin.
    (Note: must close the player after watch video to reproduce this problem.)

    i tried several case and this is the result.


    Case 1:
    open wmp12, play an audio, close wmp12. (no problem)

    Case 2:
    open wmp12, play an video, close wmp12. (lyricsplugin will be DISABLED)

    Case 3:
    open wmp12, play an audio, play a video, close wmp12. (lyricsplugin will be DISABLED)

    Case 4:
    open wmp12, play an audio, play a video, play an audio again, close wmp12. (no problem)

    ** all cases is tested with lyricsplugin enabled at the beginning. **


    hopefully some experts can help verify the problem..

    Monday, November 30, 2009 5:04 PM
  • Hi LucaST1,

    I had the same error. To solve the problem, go into the c:\program files\windows media player\plugins folder and delete the lyricsplugin.dll. Then download the lyricsplugin.exe file from the http://www.lyricsplugin.com/ site. Rightclick on the lyricsplugin.exe and choose run as administrator, and deploy the program. After then it will work...
     

    -Balazs Seprenyi (MCSE...)
    Friday, January 15, 2010 11:49 PM
  • Thank you for your suggestion,, but unfortunately it didn't solve the problem. I also tried to modify the security permissions of lyricsplugin.dll giving full control to all users, but it didn't change anything too.

    Anyway, in the next two weeks I should build my new computer (I'm waiting for some parts): maybe I won't have this problem on it.


    Saturday, January 16, 2010 10:23 AM
  • Make sure windows media player can connect to the internet.
    Wednesday, January 27, 2010 3:23 AM
  • Hi!

    I have a problem with this plug-in as weel using WMP 12 on Windows 7.
    The plug-in is installed, unfortunately no lyrics are appearing. Do you have any idea why?

    Thanks.
    Sunday, February 21, 2010 6:29 PM
  • Make sure it's activated. To do so, rightclick the top bar in the library view and navitage to "Plugins". Make sure the Lyrics plugin is checked.
    • Proposed as answer by WolfangAurus Saturday, August 7, 2010 4:39 AM
    Sunday, February 21, 2010 6:36 PM
  • Well it is there in the plug ins, but the thing is there's nothing to check it, not like the Msn plug-in. Weird.
    Sunday, February 21, 2010 6:38 PM
  • What do you mean by "Nothing to check"? You just click the menu item in the menu you invoke with the right mouse button, after clicking it once, it gets checked.
    Sunday, February 21, 2010 6:41 PM
  • Ok so I guess I wasn't in the right WMP view, but now I figured it out. Thanks for your help ZamKirill.
    Sunday, February 21, 2010 6:57 PM
  • i have same problem please help me!

    sorry bad english

    Thursday, July 15, 2010 2:33 AM
  • Just a little update: yesterday I tried to reinstall the plugin and now it works like a charm! There is hope! ;)

     

    Unfortunately, I've no idea about what was the problem because in these months I've installed many programs and made many changes to the system.

    Friday, July 16, 2010 9:59 AM
  • Hi,everyone

    You can try to hold down CTRL + M,then you will see the menubar on the top.

    Select the Tools /Plugins and check the 'Lyrics Plugin'.

    This will solve your problem.

     

    • Proposed as answer by corker888 Friday, August 6, 2010 2:06 PM
    Friday, August 6, 2010 1:46 PM
  • When you enter your wmp, specially win 7 (there is no options), in the program bar that are the left/right arrows and burn, etc..., in the middle of this bar do right click. When you see it, pass to the 4th option (tools i think) and if you see Lyrics Plugin without a check, give a click. Problem resolved.
    Saturday, August 7, 2010 4:37 AM
  • Hi,everyone

    You can try to hold down CTRL + M,then you will see the menubar on the top.

    Select the Tools /Plugins and check the 'Lyrics Plugin'.

    This will solve your problem.

     


    When you enter your wmp, specially win 7 (there is no options), in the program bar that are the left/right arrows and burn, etc..., in the middle of this bar do right click. When you see it, pass to the 4th option (tools i think) and if you see Lyrics Plugin without a check, give a click. Problem resolved.

     

    Any expert please answer to the problem instead of teaching how to enable the "Lyrics Plugin".

    The actual problem was unable to permenantly enable it in WMP.

     

    #scenarios as below:


    i had this lyricsplugin problem too with Windows Media Player 12 (Windows 7 Ultimate x86)

    the plugin can be enabled WITHOUT ANY PROBLEM.
    i can also close or restart my pc without it being disabled.

    HOWEVER, everytime i play video file and close the player, it will disable the lyricsplugin.
    (Note: must close the player after watch video to reproduce this problem.)

    i tried several case and this is the result.


    Case 1:
    open wmp12, play an audio, close wmp12. (no problem)

    Case 2:
    open wmp12, play an video, close wmp12. (lyricsplugin will be DISABLED)

    Case 3:
    open wmp12, play an audio, play a video, close wmp12. (lyricsplugin will be DISABLED)

    Case 4:
    open wmp12, play an audio, play a video, play an audio again, close wmp12. (no problem)

    ** all cases is tested with lyricsplugin enabled at the beginning. **


    hopefully some experts can help verify the problem.. 

     

    Sunday, August 8, 2010 4:39 AM
  • I too am a big fan of lyrics plug-in and Windows 7 disables it often. 

    (x) Deleting .dll file and, re-installing and running as admin does not fix.

    (x) Tools > Options... > Plug-ins > Now Playing > Lyrics Plugin is grayed out

     Only solution that works for me is to manually re-enable each time: 

     "To re-enable it, you have to right-click on the top top bar in WMP Library View, then Tools-Plug-ins and enable"

    That is:  Tools > Plug-ins  > Lyrics Plugin

    -------------------------

    Sorry to ____ but this OS is really a step backward from XP which came out in 2001.   I have had problems with other Windows 7 bugs: programs pinned to task bar open two copies of application, applications locking up.  I also miss the old photo previewer and the ability to create a second, customized, taskbar.  Thanks Microsoft!

     

    Saturday, August 21, 2010 8:15 PM
  • hey!1dude!! i have enable it and its work like fine ____...!!! do it permanently enable and then resatrt the computer and then it works okay!!!!!
    Thursday, January 6, 2011 2:36 AM
  • I had exactly the same problem but I realized (since I work on 64 bit windows 7) the windows itself comes with two versions of windows media player 12 (32 & 64 bit versions), so I everytime I tried to reopen WMP the plugin was gone and had to re-instal but I realized that the plugin does not work on 64 bit version of WMP so I went in the 84x program files folder and started the WMP from there and plugin was already installed when it started, so the problem is with 64 bit versions you can check it uncheck it all that you want on every restart the plugin will not be there simply make a shortcut on your desktop from the 32 bit WMP and you are good...
    • Proposed as answer by Zoki Dame Thursday, January 20, 2011 9:33 AM
    Thursday, January 20, 2011 9:33 AM
  • Thanks its works
    Wednesday, February 16, 2011 7:05 AM
  • your advice is very useful.thanks a lot

     

    Monday, February 28, 2011 3:52 AM
  • I have the same problem exactly....Windows 7 Ultimate 32 bit + WMP 12 and I installed the latest pluging 0.4 and I activated it from the menu and it is checked . but when I play any song I can see the song name and artist, etc on the now playing page and blank white page ...no lyrics...I have tried everything in the replies here with no success...I had it working before on previous versions (0.2 and 0.3) ...not sure what is the problem

     

    I hope someone can help me 

    Thursday, June 30, 2011 7:00 PM
  • Foesh: I think that the plug-in uses http://www.lyricsvip.com for retrieving lyrics and it looks like that website isn't working correctly anymore (clicking on any link on the homepage gives me a blank page). That's probably the reason why the plug-in isn't working anymore either - hopefully this will get fixed soon.
    Tim De Baets
    http://www.bm-productions.tk
    Sunday, July 3, 2011 10:40 AM
  • ya that works
    Sunday, January 29, 2012 1:24 AM
  • thanks buddy it works for me now...

    Monday, August 12, 2013 9:18 PM
  • thank you ...it worked for me

    You can try to hold down CTRL + M,then you will see the menubar on the top.

    Select the Tools /Plugins and check the 'Lyrics Plugin'.

    Sunday, October 27, 2013 8:44 PM
  • G'day chaps

    I found if I did the stuff indicated hereunder Lyrics Plugin still didn't work.  However, I discovered another <Lyrics Plugin> checkbox under the <Play> tag on the Menu bar.  It seems WMP12 has many <Lyrics Plugin> checkboxes that might need to be set.  Anyway, I'll see if this has completely fixed the issue over the next week or so;

    Regards

    Jimbo

    Tuesday, November 12, 2013 9:04 AM