none
Missing "Intel(R) Display Audio" device/controller in device manager

    Question

  • Hi

    My system specs are as follows:
    Intel i5-2500k Processor
    ASRock Z68 Extreme 4 motherboard
    8GB Ram (2x4gb)
    Creative Audigy 2 ZS
    PNY Geforce 460 GT (Has DVI+VGA+mini-HDMI out but only 2 can be used simultaneously)


    Monitors:
    1x Monitor - Philips 150B (Connected to the Geforce 460 - VGA)
    1x Monitor - Viewsonic 2268wm (Connected to the Geforce 460 - DVI-D)
    1x TV - Philips PFL6605 (Connected to the integrated graphics on the motherboard- HDMI)

     

    Problem is, my "Intel(R) Display Audio" controller is _not_ listed in Device Manager. And as such, I am unable to install the Intel(R) Display Audio Driver, which allows me to send audio as well as video over HDMI to my TV.

    I have installed the latest drivers for the chipset as well as integrated graphics(which come with the display audio drivers,  _but_ the audio drivers do not install as the controller is not detected)

    Please advise.

    Sunday, May 29, 2011 1:45 PM

Answers

  • Hi ugene1980,

    Restart the computer and enter into BIOS (normally press F10), go to Advanced - PCI Devices, make sure the audio device is enabled.

    Manually download the driver from the official website: http://www.asrock.com/mb/download.asp?Model=Z68 Extreme4, choose the Windows 7 or Windows 7 64-bit based on your version. Install the audio driver as listed: Realtek high definition audio driver ver:R2.55 

    Also update the BIOS to the latest one.

    Reboot to check if it works.

    Regards,

    Miya

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 31, 2011 5:34 AM
    Moderator

All replies

  •  Device Manager -> System Devices or Sound Controllers -> High Definition Audio Controller.

    See if you have any halt icon on it, and if so right click and enable the device. This worked for me.


    ganeshv
    Monday, May 30, 2011 3:44 AM
  •  Device Manager -> System Devices or Sound Controllers -> High Definition Audio Controller.

    See if you have any halt icon on it, and if so right click and enable the device. This worked for me.


    ganeshv

     

    The device is missing, there is no "High Definition Audio Controller" present in "Device Manager -> System Devices or Sound Controllers

    So I cannot enable it as it does not appear

    Monday, May 30, 2011 8:12 AM
  • Hi ugene1980,

    Restart the computer and enter into BIOS (normally press F10), go to Advanced - PCI Devices, make sure the audio device is enabled.

    Manually download the driver from the official website: http://www.asrock.com/mb/download.asp?Model=Z68 Extreme4, choose the Windows 7 or Windows 7 64-bit based on your version. Install the audio driver as listed: Realtek high definition audio driver ver:R2.55 

    Also update the BIOS to the latest one.

    Reboot to check if it works.

    Regards,

    Miya

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 31, 2011 5:34 AM
    Moderator
  • Re-Instal latest Video Driver. Its a Video driver issue; even though it comes up in Device Manager as Audio( Intel Display Audio is the clue)

    • Proposed as answer by PaulOrendorff Friday, July 05, 2013 5:56 PM
    Friday, November 30, 2012 5:46 PM