none
NTFS Permissions RRS feed

  • Question

  • Hi Experts,

    Can we set NTFS permissions for shared folder (win server 2016) in this way that user can write, edit, create and read all files and folders  but not able to delete any file or folder even he is creator of that file or folder.


    Mian Bilal

    Monday, October 21, 2019 11:01 PM

All replies

  • Hi Mian Bilal,

    NTFS shared folders on Windows server 2016 is more related with Windows Server. I'll help move this thread to Windows server General forum for further research.

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.

    Thank you for your understanding.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, October 22, 2019 1:54 AM
  • Hi,

    If we log on with Admin account, we cannot achieve it.

    If we log on with common users, we just need give a deny delete permission to this user account, so that when we delete this foloder, we need input our admin account and password.



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 22, 2019 6:18 AM
  • Hi,

    Simply add a "Deny" permission for the users and only select the "Delete" & "Delete subfolders and files" as Daniel showed above.

    Deny permission is stronger than Allow permission, which means that it takes over any allow permissions if you have configured both.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, October 22, 2019 6:29 AM
  • Danie1zhouLeon Laud

    When i set your said permissions as above, user can't delete any file r folder but it applies some more security like user can make file or folder but not able to rename and edit any new or existing file and folder. 


    Mian Bilal




    • Edited by Mian Sahib Tuesday, October 22, 2019 4:21 PM
    Tuesday, October 22, 2019 4:16 PM
  • If the user need to be able to create or modify files you will need the give at least the following permissions:

    • Allow Create files / write data
    • Allow Create folders / append data
    • Allow Write attributes
    • Allow Write extended attributes
    • Deny Delete and Delete subfolders and files

    Example:

    You can also simply give your users "Allow Modify", and then add a "Deny Delete Delete subfolders and files", with this users can create or modify files.

    If you want to apply these changes to existing files, check the following check box:



    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, October 22, 2019 5:21 PM
  • Leon Laude,

    First of all thanks for your prompt reply but my problem still persist, i followed your provided steps and every thing is fine but user still is not able to rename and edit any new or existing file and folder. 


    Mian Bilal

    Tuesday, October 22, 2019 7:41 PM
  • They might need to logoff and log back on for the changes to become effective or then wait some time.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, October 22, 2019 7:58 PM
  • Beside give the user deny delete permission, we should aslo give them some allow permission as Leno's screenshot shows. And then, we should log out and log on again.

    Cheers,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, October 23, 2019 6:56 AM
  • Leon Laude and Danie1zhou 

    I found that this is not possible. if any one have write permission he will get auto deletion rights which can't be removed. Any how thanks for you both buddies. 


    Mian Bilal


    • Edited by Mian Sahib Wednesday, October 23, 2019 3:46 PM
    Wednesday, October 23, 2019 3:46 PM
  • It you have inheritance enabled, and you are trying to change permissions from an inheritable permission it will not work.

    You will need to disable inheritance to be able to modify the permissions.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 23, 2019 3:51 PM