dvd-rw not working!!!!


  • just installed build 5472, and come across a problem with my dvd-rw, it shows up in computer as a dvd-rw but when i open dvd maker it says i have no dvd recorder installed and the same thing appears in media player? ne ideas? im guessing its to do with drivers but would have thought that they were built in?
    Sunday, July 23, 2006 9:29 PM

All replies

  • I have one dvd usb and installed appears only cd driver(dvd-r)

    but this is a DVD-RW.what do I?

    Monday, August 21, 2006 2:29 PM
  • Same problem I have
    Tuesday, September 12, 2006 11:27 PM
  • What are the brands and moddel numbers of the drives?

    Wednesday, September 13, 2006 10:54 PM
  • NEC 2500
    Saturday, September 16, 2006 2:57 PM
  • NEC 2500
    Saturday, September 16, 2006 2:58 PM
  • My suggestion.....

    Had a similar problem, my drive came up as a DVD-R only. My solution:

    Install SwiftDisc, see if it will recognise and erase a DVD-RW, and btw, seems to be one of the few Burner progs that actually installs and works with Vista. Not like these all singing, all dancing, do everything else programs that won't install.

    It recognised and worked with my DVD-RW just fine (Sony).

    SwiftDisc can be found at
    Sunday, September 17, 2006 7:47 AM
  • To register your copy of SwiftDisc on Vista:
    Install the software, Vista may prompt you for elevated privledges to do so, let it.
    After installation but before key install, pick the executable and select "Run as asminstrator". This will allow your software to accept the license key you provide.
    Monday, September 25, 2006 11:35 PM
  • i installed SwiftDisc 1.96 but still not working... it says 'no cd-rom device found'


    Friday, September 29, 2006 3:36 PM
  • Open RegEdit

    FindKey: HKEY_LOCAL_MACHINE/System/Currentcontrolset/Control/Class/
    Right click on key: {4d36e965-e325-11ce-bfc1-08002be10318}

    Export it to a safe place

    Now go to the right pane, and delete the keys named: UpperFilters and LowerFilters

    Close RegEdit and restart computer, windows will now reinstall drive, maybe this will help. If not, you can import back your safety copy you made earlier.

    Saturday, September 30, 2006 5:33 AM
  • It works for me!! Thanks alot Gerrit

    but i stil hav problem wif my SigmaTel High Definition Audio...

    could someone pls help me?

    Saturday, September 30, 2006 5:50 AM
  • Update:
    Just tried to copy a regular cd to the HD. got half way and said "Cannot read from source."

    Tried with a couple different CDs. Same thing everytime.
    Saturday, February 10, 2007 11:29 PM
  • I tried this fix for my Samsung SH-S162L (TS-H652L) DVD Combo Drive and it worked. I have been trying for almost 2 weeks to get the drive to work including endless hours with Vista Support People and this did the trick. Thanks!

    I was wondering, why did this work? Why does erasing the Upper & Lower Filters suddenly make Vista recognize the DVD Drive?

    Monday, February 12, 2007 2:47 AM
  • I tried this fix for my Acer notebook. it worked once but thent the next boot up it the drive was gone again. I have tried the regedit fix again but there are no Upper & lowerfilters in there anymore. any suggestions?
    Friday, June 29, 2007 6:38 PM