none
How do I remove the "Do you trust this printer?" dialogue? RRS feed

  • Question

  • We are not admins on our computers. It seem to me that Win7 (Windows 7) do not let me add printers. It asks me for approving printer drivers. A dialogue comes up: Do you trust this printer?  Windows needs to download and install a software driver from \\server computer to print to <printer name>. ...

    I've disabled   User Configuration > Policies > Administrative Templates > Control Panel/Printers > Point and Print Restrictions     
    However it still asks me for confirmation.

    The exact same policy works fine on Windows Vista with UAC enabled.


    • Edited by HAL07 Wednesday, June 3, 2009 6:44 AM
    Monday, May 25, 2009 7:21 AM

Answers

  • The Userbased GPO did also not work on Win 7 but the GPO fixed the problem on Vista.
    (User Configuration > Policies > Administrative Templates > Control Panel/Printers > Point and Print Restrictions)

    This settings applies to: Windows Vista and later (or should apply)

    Now I found annother policy which is in computer-based:
    (Computer Configuration > Policies > Administrative Templates > Printers > Point and Print Restrictions)
    I made some test with the local (gpedit.msc) policy. And it worked!
    The strange thing was: I did not find this policy on Vista :-/
    But this policy also applies to Vista and later...

    I configured a GPO for our Forest:
    User can only P&P to these servers => Disabled
    User can only P&P to machines in ther forest => Enabled
    When installing drivers for a new connection => Do not show warning or elevation prompt
    When installing drivers for an existing connection => Do not show warning or elevation prompt


    I hope this will fix your problem.

    PS: The policy works fine with UAC enabled

    Also see the Solution from 'matambanadzo'
    • Proposed as answer by Alex Koller Tuesday, September 1, 2009 8:00 AM
    • Marked as answer by HAL07 Tuesday, September 1, 2009 8:15 AM
    • Edited by Alex Koller Wednesday, November 4, 2009 7:23 AM
    Tuesday, September 1, 2009 7:59 AM

All replies

  • I am experiencing the exact same issue. I have disabled the same policy and recieve the same message. I know it works in Vista also, I have a GPO applied to several OU's. I hope somebody reviews this thread quickly and has a response.
    Tuesday, May 26, 2009 12:13 PM
  • Hello Microsoft? Are you planning to work against us on this one? I see newer builds still have this message.
    Are you planning to enforce us to use the new GPO's?
    Tuesday, June 9, 2009 12:54 PM
  • Have you checked Local Security Policies -> Security Settings -> Local Policies -> Security Options "Devices: Prevent users from installing printer drivers"?
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Thursday, June 11, 2009 9:25 AM
  • Thanks for your input Sanmartin :)

    However I now tested this and it's still the same annoying "Do you trust this printer?" dialogue.
    Friday, June 12, 2009 8:22 AM
  • News! Found this: http://msdn.microsoft.com/en-us/library/dd162838(VS.85).aspx. Look under "dw flags":

    "Windows 7: In Windows 7 and later versions of Windows [o-ho!], if this flag is set and the user is running in elevated mode, the Do you trust this printer? dialog will not be shown."
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    • Edited by Sanmartin Friday, June 12, 2009 5:24 PM
    Friday, June 12, 2009 11:17 AM
  • Thanks for the info. Not sure if I understand, as the user is not elevated.  Anyways, I'm not sure how Microsoft expect us to map printers.
    Monday, June 15, 2009 7:06 AM
  • I'm no technician, but from what I understand from the quote, you must be in elevated mode or you will get the "Do you trust this printer?" dialogue.
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Monday, June 15, 2009 7:53 AM
  • yes that is true. however it does not solve my problem at all.
    Thursday, July 2, 2009 11:06 AM
  • Out of curiosity if you answer yes to this dialogue can you then install your printer?
    If you were to install the driver through the device manager it may not ask.

    Thursday, July 2, 2009 2:28 PM
  • Yes would install, however it will bother the user a LOT if you have like 10 printers which we mostly deploy to our users at different offices, depending on where he/she logs in to.
    Friday, July 3, 2009 5:58 AM
  • These settings have been moved to the Local_Machine hive for Windows 7.  You need to use a Windows 7 machine to manage the two sets of policies (Machine for Windows 7, User for Pre-Windows 7)

    If you do it this way, you won't have any issues. 
    • Proposed as answer by Alex Koller Tuesday, September 1, 2009 8:00 AM
    Friday, July 17, 2009 3:52 PM
  • For a corporate environment Re-package your printer drivers to deploy automatically from a single executable. 


    If it isn't Mr. Seven it's not.

    • Edited by ONE ZERO Saturday, July 18, 2009 4:56 AM
    Friday, July 17, 2009 4:17 PM
  • It has been brought to my attention that this problem is also present in the RTM release. So I wonder why this move Microsoft?
    Also, even when confirming each printer, each printer install takes a very long time.
    Tuesday, August 4, 2009 7:18 AM
  • The Userbased GPO did also not work on Win 7 but the GPO fixed the problem on Vista.
    (User Configuration > Policies > Administrative Templates > Control Panel/Printers > Point and Print Restrictions)

    This settings applies to: Windows Vista and later (or should apply)

    Now I found annother policy which is in computer-based:
    (Computer Configuration > Policies > Administrative Templates > Printers > Point and Print Restrictions)
    I made some test with the local (gpedit.msc) policy. And it worked!
    The strange thing was: I did not find this policy on Vista :-/
    But this policy also applies to Vista and later...

    I configured a GPO for our Forest:
    User can only P&P to these servers => Disabled
    User can only P&P to machines in ther forest => Enabled
    When installing drivers for a new connection => Do not show warning or elevation prompt
    When installing drivers for an existing connection => Do not show warning or elevation prompt


    I hope this will fix your problem.

    PS: The policy works fine with UAC enabled

    Also see the Solution from 'matambanadzo'
    • Proposed as answer by Alex Koller Tuesday, September 1, 2009 8:00 AM
    • Marked as answer by HAL07 Tuesday, September 1, 2009 8:15 AM
    • Edited by Alex Koller Wednesday, November 4, 2009 7:23 AM
    Tuesday, September 1, 2009 7:59 AM
  • I think you just made my day! :) Thank you very much.
    Tuesday, September 1, 2009 8:15 AM
  • The answer DOES work. Thank you!

    For everyone else who stumbles upon this page, I'm going to clarify because the answer is not very clear.

    If you want print drivers to add automatically when the user logs in without it prompting to "Install Driver" do this:

    In the computer's Group Policy Object:

    Find: Computer Configuration > Policies > Adminstrative Templates > Printers > Point and Print Restrictions

    > Change it to Enabled
    > Change the following settings:

    Users can only point and print to these servers > Unticked (Disabled)
    Users can only point and print to machines in their forest > Enabled
    When installing drivers for a new connection > Do not show warning or elevation prompt
    When updating drivers for an existing connection > Do not show warning or elevation prompt

    If the computer is on during this process, run "gpupdate /force /boot" in the command line. (without quotes)
    After the restart it should add the printers in the login script that apply to the user logging in without prompting to install any drivers.
    • Proposed as answer by Alex Koller Wednesday, November 4, 2009 7:21 AM
    Wednesday, November 4, 2009 6:33 AM
  • No Problem...

    Thank you for your "how to" ;-)
    Wednesday, November 4, 2009 7:21 AM
  • Hi. To comment on the resolution below. I am deploying scripts via Group Policy on Windows 2003 R2 domain to Windows 7 clients. As with others who have posted the scripts run OK for both XP and Vista clients. The options detailed below are not available on the server. Any answers as to how to manage printer deployment globally?
    w
    If you want print drivers to add automatically when the user logs in without it prompting to "Install Driver" do this:

    In the computer's Group Policy Object:

    Find: Computer Configuration > Policies > Adminstrative Templates > Printers > Point and Print Restrictions

    > Change it to Enabled
    > Change the following settings:

    Users can only point and print to these servers > Unticked (Disabled)
    Users can only point and print to machines in their forest > Enabled
    When installing drivers for a new connection > Do not show warning or elevation prompt
    When updating drivers for an existing connection > Do not show warning or elevation prompt

    Kind Regards,
    Phil.

    IT Manager
    Monday, November 30, 2009 8:04 PM
  • I just found out that Computer Configuration > Policies > Adminstrative Templates > Printers > Point and Print Restrictions
    is only editable trough windows 2008 r2 server.

    good to know...

    Friday, April 2, 2010 10:44 AM
  • I just found out that Computer Configuration > Policies > Adminstrative Templates > Printers > Point and Print Restrictions
    is only editable trough windows 2008 r2 server.

    good to know...

    Friday, April 2, 2010 10:44 AM
  • Thanks! Nice 2 know :)

     

    Best Regards

    Alex

    Friday, April 2, 2010 11:28 AM
  • “Do you trust this printer?” – a workaround

     

     

     

    Problem

    I was trying to print from a netbook running W7 Starter edition to a printer server running Vista. I continually got the message “Do you trust this printer”. Every time I said “Yes” and every time the netbook downloaded the printer driver from the Vista server, even though it had done this irritatingly time-consuming action many times before.

     

    Solution

    To cut a long story short, I stumbled upon the option on the Printer Shares page “Render print jobs on client computer”. I unchecked the box on the Vista printer server and the problem disappeared immediately.

     

    Command sequence To summarise: On the computer acting as printer server running Windows Vista, the command sequence is:

    Start/Settings/Control Panel/Printers/Right-click Default Printer/Sharing/Change sharing options/Agree to continue/uncheck “Render print jobs on client computers

     

    The client computer is a Samsung N140 Netbook running Windows 7 starter edition, the printer is a Samsung ML1640 attached to the server computer (HP Pavilion tx 2000 Notebook running Windows Vista Home Premium)

     

     

    I appreciate the home environment is a long way from the way this thread started, but I would like to thank the participants in the discussion for leading me to somewhat indirectly to this solution.

    Tuesday, May 25, 2010 10:08 PM
  • Hi Hoenderdos. Do you perhaps have the reg key for this setting as I do not have w2k8 R2, only W2k8 server.

    Many thanks in advance.

    Wednesday, June 16, 2010 12:43 PM
  • I am havinga a related issue that no one else seems to have... I do not have the Point and Print setting listed under Computer Configuration.  It is under User Configuration, however.  In order to get the Point and Print setting listed under Computer Configuration, what must I do?
    Thursday, June 17, 2010 9:09 PM
  • I found the Point and Print setting for the default local GPO (Windows 7 Pro), but cannot find the setting in the Server 2003 forest functional level domain GPO I am trying to configure.
    Thursday, June 17, 2010 9:15 PM
  • I have tested the Point and Print setting for the default local GPO and it works... :)

     

    Now I just need to find the setting within the domain based policy...

    Thursday, June 17, 2010 9:36 PM
  • I have found the source of my problem:

    The templates loaded in the central store were out of date.  Having updated them, I can now see the Point and Print settings for Windows 7.

    Case closed!

    Friday, June 18, 2010 4:07 PM
  • Can you tell me how to update the template :)

    I'm having the same issue

    Thursday, June 24, 2010 9:18 PM
  • Hi there, 

     

    This works great on Windows 7 clients.  Has anyone discovered a group policy edit that works in windows server 2003?  Trying to save myself from doing this 100 times.

     

    Thanks 

    Saturday, September 4, 2010 1:42 AM
  • Same problem here. I have a windows 2008 R2 Server, and there is NO "point and print restrictions" under Computer configuration, so how can i set this? I do not want to go to each win7 workstation to set this. Anyone found a solution?
    Friday, November 26, 2010 11:36 AM
  • Could you explain us in detail how to update "the tamplates" please?


    i have the same problem


    Monday, June 6, 2011 3:23 PM
  • Could you explain us in detail how to update "the tamplates" please?


    i have the same problem



    Type "gpedit.msc" in the "Run" box.

    The detail please refer : http://msdn.microsoft.com/en-us/windows/hardware/gg463359
    Wednesday, June 8, 2011 3:42 AM
  • thank you for this link that explains how this GPO works but I have been more specific in my request:

    how can we update on win 2003/2008 server the "Computer Configuration > Policies > Adminstrative Templates > Printers > Point and Print Restrictions" (from win7 ? other?)

     

    i have 200 PC with win7 to manage so i won't go on each one to configure it to resolve the problem when i can do it once on the server ^^!

     

     

    vendredi 18 juin 2010 16:07Techie_Jones Médailles de l'utilisateurMédailles de l'utilisateurMédailles de l'utilisateurMédailles de l'utilisateurMédailles de l'utilisateur

     

    I have found the source of my problem:

    The templates loaded in the central store were out of date.  Having updated them, I can now see the Point and Print settings for Windows 7.

    Case closed!



    Wednesday, June 8, 2011 8:42 AM
  • i have 200 PC with win7 to manage so i won't go on each one to configure it to resolve the problem when i can do it once on the server ^^!

    http://globalknowledgeblog.com/technology/microsoft/how-to-support-windows-7-group-policy-settings-using-only-windows-server-2003-domain-controllers/

     

    Wednesday, June 15, 2011 10:15 AM
  • thanks A LOT!

     

    it works and it's very easy to do actually

    Thursday, June 16, 2011 8:56 AM
  • I love it when a problem description is short and to the point. Especialy when it is followed by a solution that is short and to the point. Thank you so much for solving my problem!!!!
    tweaton
    Tuesday, December 20, 2011 6:22 PM
  • Alex's fix worked like a champ for me with this problem after 3 years of aggravation.

    John M. Keller MCP (XP & 2003) | Security + E-Mail : itbeast@msn.com

    Wednesday, May 14, 2014 3:33 AM
  • Didn't work. Still need to Right-click and update the drives and when I do I get prompted.
    Tuesday, August 2, 2016 6:18 PM
  • It worked for us for a long time. but today it stopt working. It is after installing windows updates. zo we have to find out with one couse this isue.  

    Wednesday, August 3, 2016 8:43 AM
  • I too am having the same issue. I've followed all the tips here with no avail. I am giving up and will install the drive before hand via a script.
    Thursday, August 4, 2016 1:45 AM
  • It appears KB3170455 from Security Bulletin MS16-087 has introduced issues with point-and-print drivers. KB3170005 has information on the issues.

    • Proposed as answer by Ken2Johnson Thursday, January 12, 2017 12:14 AM
    Thursday, August 4, 2016 11:43 PM
  • I'm running into this at work as well and we also have KB3170455 installed. From what I'm understanding it basically is a result of legacy print drivers not conforming to security standards in driver installations. 
    Tuesday, August 9, 2016 10:33 PM
  • Hi,

    Registerhack on the server worked for me:

    If you have trouble deploying printers after applying critical updates according to MS16-087 (KB3170455) try this tweak: Edit the register on your print server. If you change the value of the key PrinterDriverAttributes under HKLM\System\CurrentControlSet\Control\Print\Enviroments\Windowsx64\Drivers\...\Driver name\ and restart the print server, you are able to make Windows treat the driver as packaged, and it will install unattended with gpo. The hex number has to be odd, i.e. 41
    Restart server .

    According to MS the 1 flag for PrinterDriverAttributes stands for PRINTER_DRIVER_PACKAGE_AWARE. This will treat the driver as package aware, which means a CAB package will be created, including the inf and the catalog. The package will be installed through setupapi.dll when installing the driver, validating that the catalog is trusted, and that hashes for all files are included in the catalog.

    Source: https://community.usa.canon.com/t5/Office-Printers/Package-Aware-Print-Drivers/m-p/182579

    • Proposed as answer by jeromebt Monday, August 29, 2016 9:25 PM
    Sunday, August 28, 2016 2:26 PM
  • It works for me. Thank you
    Monday, August 29, 2016 9:25 PM
  • It works for me too.suggest raise to resolution.
    Friday, September 2, 2016 3:08 AM
  • Changing the PrinterDriverAttributes was the first step as a solution, but not the last.

    Afterwards I still had the annoying problem that one printer (seagull driver) was not being installed as expected by the GPP, even though the latest driver had the setting Package aware=true

    It didn't matter what settings I tried in the GPO: trying to connect to the printer location as FQDN ended with that nasty "Do you trust this printer?" message.

    So I had to deploy the certificate inside the .cat file of the drivers as a "Trusted Publisher". Voila.

    • Proposed as answer by reduakm Thursday, August 24, 2017 1:06 PM
    Friday, September 30, 2016 12:05 PM
  • Microsoft has released a patch KB3170455 in security Bulletin MS16-087. More details can be found here Https://technet.microsoft.com/library/security/Ms16-087" After uninstalling the patch from the Windows 7 machines, they are no more issue warning to users who install the printers. Not prompting for Admin password 
    Wednesday, October 12, 2016 10:46 PM
  • Man, after spending 12 hours on this I read your (MWCJ) post and realized I merely had to install my cert under trusted publishers.

    If this helps anyone else searching, I had to modify my Canon PCL 6 drivers with their utility in order to make the defaults black and white single sided. I purchased a code signing certificate and signed the cab and INF (added the package aware line to INF). Didn't realize i had to add the cert to trusted publishers as well.


    • Edited by reduakm Thursday, August 24, 2017 1:07 PM Wanted to put user's name.
    Thursday, August 24, 2017 1:06 PM
  • Works perfect the registry change to an odd hex number on a fargo printer drive i had this issue with moving to windows 10. Not sure why it was not a problem in win7 with the same exact driver version.

    'PrinterDriverAttributes' under

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3\[PRINTERNAME]

    Simply changing the registry value and rebooting the print server has switched their driver status to "packaged = true" which allows them to deploy fine automatically. test prints are successful.

    Tuesday, September 12, 2017 6:16 PM
  • Also confirm that this happened to us on Windows 10 this year and the above reg change on drivers that are flagged as 'Packaged=False' has fixed our issue and the printers are now installing.

    I changed the 'PrinterDriverAttributes' to 5 but any odd number should work.

    Wednesday, September 20, 2017 10:19 AM