none
Correcting Name Discovery By Interface Priority RRS feed

  • Question

  • I have a very strange connectivity issue affecting a Windows 10 computer on my home network. I have narrowed down the cause of the problem, but I don't know how to fix it.

    Basically, the two computers in my home are connected through two different interfaces.

    1) There is a wired (ethernet) 1Gbps connection between the computers. This is configured as private, and has Windows File Sharing and everything enabled. This has no Internet connectivity. It is purely private.

    2) There is a wireless connection to the Internet, which goes through an Access Point that is shared amongst all of the apartments in my building. I have configured this as a public network, and have disabled all file and print sharing through this interface.

    The problem is that Windows finds the other computer through both networks, but when I try to do net view \\computername or open in File Explorer, it tries to access the other computer through the WiFi network, but everything is disabled on that network. If I do net view \\ip address using either the ip4 or ip6 address of the computer on the wired network, then it works fine. Alternately, if I disable the WiFi network then it immediately finds the other network through the wired connection. However, when both interfaces are enabled, it will only try to connect via the WiFi network even though everything is disabled on that network.

    So, what I want to know is how I can make the names discovered via the wired interface have higher priority than names discovered via the WiFi network, or alternatively, how to completely turn off name discovery on the WiFi network. (I have completely disabled all name discovery options I can find for the wifi adapter, but Windows is still finding the ipv6 address of the other computer through the wifi network fe80:... address family, and giving it higher priority than both the ipv6 and ipv4 networks i have explicitly set up on the wired adapter.


    Monday, January 27, 2020 1:50 PM

All replies

  • OK, I think I found it. I disabled Proximity Sharing in the Win 10 firewall rules.
    Monday, January 27, 2020 4:07 PM
  • Hi ,

    It seems that your issue has been successfully resolved. 

    Thanks for your posting here and sharing the solution.

    If there is anything else we can do for you, please feel free to let me know.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, January 28, 2020 3:40 AM