Several drivers need reinstalling after every reboot (LAN driver)


  • Hello, I am having a problem with my Windows 7 installation. A couple of weeks ago, for what seems like no reason at all, a problem started whereby if I reboot my machine my LAN driver (Broadcom 440x 10/100 Integrated Controller) will be corrupted with the yellow exclamation mark next to it. To remedy I have to open Device Manager, right click, uninstall, then search for new hardware. Then windows will install it correctly and the internet connection will repair itself.

    Other drivers affected are:
    Standard enhanced PCI to USB Host Controller
    3 x VIA USB host controller drivers

    I have noticed others are having similar issues caused by Apple Bonjour service, I have disabled the bonjour service and there is no ##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" Bonjour DNS Responder Service to remove.

    I have tried to update the drivers but they are all up to date, I have tried uninstalling them and installing the manufacturers drivers which still doesn't help.

    If anyone can help me resolve my predicament I would appreciate it.

    Many thanks
    Wednesday, February 24, 2010 12:25 PM

All replies

  • You may need to access the website of the motherboard or the computer manufacturer to download the Windows 7 compatible driver for the network adapter. After downloading, I suggest you temporary disable the anti-virus, then right-click on the installation program and choose “Run as administrator” to launch it.  
    Arthur Xie - MSFT
    Thursday, February 25, 2010 9:39 AM
  • Thanks for the reply, my system is a Dell Dimension E521 and they do not have any Windows 7 compatible drivers for download. But the machine has been running perfectly on Windows 7 for months and this happened only 2-3 weeks ago.

    I have been on the LAN card manufacturers website and downloaded the latest driver (which is Vista 64bit but downloads as XP 64bit).

    It downloads as a .inf, .cat, and a .sys. I have no option to right click install as admin on any of them, on the .inf I can right click install but that says it does not support that method of installation. Installing via device manager doesn't remedy the issue.
    Thursday, February 25, 2010 11:25 AM
  • Hi,

    You may try the following method to install the driver with the *.inf file.

    First I suggest you disable the antivirus.

    Then follow the steps below.

    1. Launch Device Manager from Start Search box.
    2. Expand “Network Adapters”, right-click on the entry under it and click Update Driver Software.
    3. Click "Browse my computer for driver software"
    4. Choose "Let me pick from a list of device drivers on my computer".
    5. Please check the option Show compatible hardware. Then click Have Disk.
    6. Click Browse and locate to the downloaded *.inf file.

    The number after “usbstor.inf” indicates the version of the driver. On your computer the number may be different. Please select the latest folder “usbstor.inf_*”

    Click Open. Click OK.

    Arthur Xie - MSFT
    Monday, March 01, 2010 6:49 AM
  • there is off course the possibility this is a hardware failure!
    If possible, try in another windows installation (possibly PE) anc check whether the issue occurs.
    Monday, March 01, 2010 7:27 AM
  • I have booted into XP and the drivers are all present and correct. I have read it could be a problem with Office or Photoshop, I have removed both and still the issue persists. I think it must be something to do with Windows 7 updates. At this rate I am going to have to format but I would much rather avoid that.

    Driver installation still does not resolve, and there are several unrelated drivers affected. No matter which driver I update it does not help :(
    Monday, March 01, 2010 1:41 PM
  • Check, you might find something there if there is some issue related to installation/update.

    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Tuesday, March 27, 2012 7:49 AM