none
Remote Desktop Connection freezes Windows 7 64-bit

    Question

  • At home, I just upgraded from a Windows 7 Ultimate 32-bit desktop to a new Dell with Windows 7 Ultimate 64-bit OS.  Remote Desktop Connection from my old home PC to my work PC worked great for years even after upgrading both to Windows 7 Ultimate.  Now everytime I try to use Remote Desktop Connection (RDC) to connect into my work PC (with Windows Ultimate 7 32-bit) the RDC window will freeze after a new seconds of use.  If I wait approx 3 minutes the RDC window will unfreeze for a few seconds before freezing again.  If I minimize the RDC window on my home PC, I can continue to work because it's only the RDC window that is frozen.  Here is everything I've tried already that has not helped:

    1. Trying reducing the home PC screen resolution

    2. Downloaded the latest 64-bit driver from NVIDIA for the GTX 260 graphics card

    3. Taken my home PC to work to test behind the company's firewall--doesn't help

    4. Disabled Window Auto Tuning (suggestion from this website)

    5. Called Dell support--they tried for about an hour to help but couldn't; thier suggestion was to order Windows 7 32-bit version OS and install it

    6. Tried running the 32-bit version of mstsc.exe - no help

    7. Using MSCOMFIG, disabled all Startup items - no help

    I have another home PC running Windows XP, it works perfectly using RDC to connect to my work PC.  Also, I have no problem at all using RDC from my work PC back into my home PC (the other direction).

    Here may be a clue:  if I start up my new Dell Windows 64-bit OS in Safe Mode, the RDC session does not freeze.

    Any suggestions would be appreciated!

    Sunday, March 21, 2010 11:02 AM

Answers

All replies

  • Hi,

     

    Since it works in Safe Mode, I suspect this should be related to some conflicts, please try the methods in the following Knowledge Base article to have a check:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

    In addition, please also ensure the NIC drivers on all of the computers are up-to-date.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Wednesday, March 24, 2010 8:49 AM
    Moderator
  • fcarroll,

    I had a similar problem that started after installing a Matrox TripleHead2Go. I found the problem is caused by the PowerDesk software utility and uninstalling this application solved the problem. I am still able to use the TripleHead2Go but do not have advanced configuration options without PowerDesk installed.

     

    Another odd symptom I observed was beeping while the computer was frozen when pressing any of my mouse buttons.

     

    Cheers,

    Gizmoto

    Friday, March 26, 2010 3:47 AM
  • Just so you don't feel lonely, I have an XPS 8100 with Win7 x64 Home Premium and am getting the exact same effect.  I have tried both an Cisco IPSEC vpn client and an SSL VPN client to connect.  RDP acts the same way for both.  When in the frozen state you cannot even close the RDP window.  After some time you will see a brief attempting to reconnect windows before the session comes back to life.
    Tuesday, February 01, 2011 6:52 AM
  • Just disable audio and recording in a remote connection then everything will work fine.

    My Remote Desktop freezes when a dialog box or message pops up.

    To fix this delay or hang or freeze follow these steps

    1. Open Remote Desktop
    2. Click [Options]
    3. Click [Local Resources] tab
    4. Click [Settings] for 'Configure remote audio settings'
    5. Select [Do not play] for 'Remote audio playback'
    6. Select [Do not record] for 'Remote audio recording'
    7. Click [OK]
    8. Connect to your omputer

    Disable he audio and recording fixed my remote desktop freeze.

    Good Luck


    .DN.
    • Proposed as answer by Looneyman Wednesday, April 18, 2012 11:57 PM
    Friday, February 18, 2011 5:07 PM
  • The above resolved my issue.  While I always like to find the root cause, I will take fixes where I can find them!

    Just for anyone wanting to dig even further, I have the machine able to dual boot to WinXP as well.  I have none of these issues when I go with that config.  Or when I use Windows Virtual PC and run XP on the same hardware, no issues.

     

    Thanks!

    nd

    Wednesday, March 09, 2011 3:20 AM
  • That fixes it for me too.

    Many thanks!

    --Tony-11


    Tony-11
    Wednesday, March 09, 2011 6:35 AM
  • Thanks for your help.  I spent over 4 hours with a IT tech from company to no avail........Changed the sound settings and it works perfectly.

    Thank You very much!!!!!

     

    brian

    Saturday, March 26, 2011 5:12 PM
  • I reformatted my disk and reloaded all the Dell software from their Download site.  Between each download, I would test the RDP function to see if it would feeze.  Upon loading the THX sound software, it immediately frooze.  So I did what you and several others did...disabled sound in the RDP session.  So for the past year that has worked great...no sound, no big deal.

    Yesterday I tried using Cico's Webex to listen to a webinar and guess what...it freezes and I think it's the same sound issue.

    What a mess.

    ~FC

    Wednesday, May 18, 2011 12:57 PM
  • I have the same problem with remote desktop and webex webinars.  DN's recomendations worked for me on remote desktop, but I haven't tried Webex.

    Very frustrating.

    Thursday, July 14, 2011 8:34 AM
  • Configuing the audio settings as indicated fixed this for me on my Windows 7 PC - thanks.
    Wednesday, April 18, 2012 11:58 PM
  • You are a friggin' genius! I use a remote desktop all called visionapp RDP and it was doing the same thing as MS RDP client. I would enter my credentials and then hang...  

    Win7 Ultimate 64bit on corporate LAN. No issues for over 3 years until recently. I opened MS RDP client, disabled audio and BAM! Connection successful!! After I did it once, all other connections started working, including ones with audio enabled... 

    Thanks again for the fix!


    Tuesday, October 30, 2012 4:00 PM