locked
print spooler won't start

    Question

  • can anybody help me, i am trying to install a HP photosmart 2575 printer onto my pc which is running vista i get so far through the installation and then an error occurs saying print spooler error fix, i have tried to restart the spooler but i get an error 1068 saying it will not restart, i am now really stuck any ideas?
    Sunday, June 10, 2007 12:48 PM

Answers

  • Right click on My Computer

    Select Manage

    Double click on Services and Application

    Double click on Services

    Scroll down to Print Spooler and double click on it

    Click on Dependencies tab

    Check what dependencies the print spooler has, if any

       you may need to click on "+" on those dependencies to more dependencies

    Go back to the Services list

    On each of the spooler dependencies, double click on it

    Make sure it is set to Automatic in the Startup Type drop down menu

    Now click on Start to start the service

    Click OK

     

    Now try and print

    if you still get spooler error messages, try this

     

    Open a Command Prompt window, found in your Start (Orb) at bottom left, and it is in the list that pops up

     

    key the command;
           sc config spooler depend= RPCSS
        (note the space after the = but not before)

    restart the print spooler 

     

     

    Hope that works, re post after you have done the above and let me know if it worked!

    Wednesday, July 18, 2007 12:18 PM
  • Wednesday, September 15, 2010 4:53 AM

All replies

  • I am having the same problem.  Let me know if you find a solution.
    Wednesday, June 27, 2007 12:07 PM
  • You are not alone.  I've tried reinstalling Vista (I have Home Premium) and I still get the same error.  Let me know if you find a fix.
    Tuesday, July 03, 2007 3:31 PM
  • Right click on My Computer

    Select Manage

    Double click on Services and Application

    Double click on Services

    Scroll down to Print Spooler and double click on it

    Click on Dependencies tab

    Check what dependencies the print spooler has, if any

       you may need to click on "+" on those dependencies to more dependencies

    Go back to the Services list

    On each of the spooler dependencies, double click on it

    Make sure it is set to Automatic in the Startup Type drop down menu

    Now click on Start to start the service

    Click OK

     

    Now try and print

    if you still get spooler error messages, try this

     

    Open a Command Prompt window, found in your Start (Orb) at bottom left, and it is in the list that pops up

     

    key the command;
           sc config spooler depend= RPCSS
        (note the space after the = but not before)

    restart the print spooler 

     

     

    Hope that works, re post after you have done the above and let me know if it worked!

    Wednesday, July 18, 2007 12:18 PM
  • I think you maybe a genius the print spooler has restarted will now try to install the software will keep you posted thank you!!
    Friday, July 20, 2007 6:34 PM
  • It worked! Thank you, I had tried the first set of instructions before and they hadn't worked but tried the second one (the command prompt) and it did the trick> I have now successfully installed my software and the printer has just printed a test page so thank you once again you are a .

    Friday, July 20, 2007 7:18 PM
  • I am experiencing the same issues. The print Spooler service keeps stopping and I get the following error message:

     

    Problem signature:

    Problem Event Name: APPCRASH

    Application Name: spoolsv.exe

    Application Version: 6.0.6000.16386

    Application Timestamp: 4549b734

    Fault Module Name: ntdll.dll

    Fault Module Version: 6.0.6000.16386

    Fault Module Timestamp: 4549bdc9

    Exception Code: c0000005

    Exception Offset: 00061861

    OS Version: 6.0.6000.2.0.0.768.3

    Locale ID: 1033

    Additional Information 1: 8d13

    Additional Information 2: cdca9b1d21d12b77d84f02df48e34311

    Additional Information 3: 8d13

    Additional Information 4: cdca9b1d21d12b77d84f02df48e34311

     

     

    Let me of any solutions for this please!!!

    Thursday, July 26, 2007 12:51 AM
  • My Compaq Presario Notebook came with Vista Home Premium.  EVERY time the desk top opens and my wireless network is acquired, I get this message: Spooler SubSystem App has stopped working.  When I attempt to start it in Services, the Start window opens and the green bar begins to fill then the start aborts.  At you suggestion, I checked and found that the Dependencies were set at Automatic.  When I tried to access the Command Prompt, it did not appear in the Start inquiries box.  In this condition, the computer will not allow me to even begin the process of installing a printer.  Any ideas you might have to remedy this problem would be greatly appreciated.

    Of note: NO OTHER Services can be changed so I think there might be an access problem.

    Thursday, August 02, 2007 5:41 AM
  • Dear Charlc14,

    Thank you very much for posting the instructions on how to restart the print spooler.  I've googled the above and found how to start the spooler from the services file; however that did not work.  My attempt resulted in a second error message. 

    The key command you provided did the trick!  I then reinstalled my printer and viola...printer works. 

    THANK YOU!!!
    Joy
    Saturday, August 04, 2007 2:01 PM
  • I'm having the same problem.  Microsoft apparently came out with a couple of updates for Vista that may help you.  Follow this link to an article which has a link for a reliability fix and a performance fix on the Microsoft downloads page.  I hope this helps the both of us.

     

    http://blogs.zdnet.com/microsoft/?p=628&tag=nl.e550

    Thursday, August 09, 2007 11:53 AM
  • charlc14   you are a geniuos for sure. I was experiencing the same exact problem but on windows xp. I typed the command you posted in  Run and restarted perfectly.  thanks

    Wednesday, August 29, 2007 3:04 AM
  • thanks so much- you are a true guru

    Wednesday, September 05, 2007 1:41 AM
  • I tired the following command...but doesn't work/

    key the command;
           sc config spooler depend= RPCSS
        (note the space after the = but not before)

    restart the print spooler 

     

    Is there anything I should be awared of before I type the above command?

    Any help is highlg appreciated..Thanks

     

    Thursday, September 06, 2007 3:54 AM
  • The remedy works very well. Thanks a ton.

     

    Regards

    Himanshu

    Friday, October 19, 2007 12:11 PM
  • I am a bit more interested in why te spooler stops. I am using a dell latitude 620 laptop & the spooler sops atleast once every 2-3 months .twice before i reloaded the system but im loosing too much down time due to this ,not mentioning the loss of updates . Is the print spooler affected by a registery coruption or a program coflict? I now keep programs loaded to a minimum toavoid excessive loss & backup regularly just incase.

     

    Please advise on on your thorts

     

    Thanks

     

    Zaahied

     

    Monday, October 22, 2007 8:17 AM
  • the command window only pop up for a second and close. I did it again and it pop up again for a second. please help.

    Sunday, November 11, 2007 2:32 AM
  • ATTN CHARLC14:     You have bailed me out of a mess today..Thank you!  Could not turn on Print Spooler in XP Pro after many attempts.  Your Help has enlightend me to find the dependencies from an old printer service which had been previously removed.    We never know it all do we?

     

    GH

     

    Saturday, November 24, 2007 5:28 PM
  • I've all of the avove and error 1068. What shoud I do next?

    Sunday, December 09, 2007 1:13 PM

  • You my friend are a GOD. After 2 1/2 days and three different printers the second step finally worked. THANK YOU! 
    THANK YOU! THANK YOU!
    Saturday, December 15, 2007 8:51 PM
  • Thanks - for days I tried to find a workaround since spooler kept failing - this did the trick!

    Wednesday, December 26, 2007 11:21 PM
  •  

    YOU'RE A GENIUS!!!  After taking 2 printers back to the store and NO help from tech support for HP and LexMark, I finally came across this board. The Command Prompt definitely worked!!   THANK YOU !!!
    Saturday, January 05, 2008 1:57 AM
  •  

    ok well i tried that camand prompt and the my computer one and it still wont work there is no dependicies i am using windows vista home basic and i was wondering if there was something else i could do it worked when i had windows xp on the computer but i upgraded to windows vista and it would not work i have a lexmark x6170 and when i turn the computer on it detects it and it says print spooler not on or something like that. hope ypu can help me
    Wednesday, February 13, 2008 6:15 PM
  • Thank you very much!!! I was going crazy!!!! Your a winner, Thanks again!!!!!!!!!!!!!

    -koolkatttj-
    Saturday, February 23, 2008 12:26 AM
  • plz state how to key in those command in Command Prompt window, b'coz I've tried that you mentioned in your post, but it appealed that "Access Denied" .

     

    Sunday, February 24, 2008 12:59 PM
  •  charlc14 wrote:

    Right click on My Computer

    Select Manage

    Double click on Services and Application

    Double click on Services

    Scroll down to Print Spooler and double click on it

    Click on Dependencies tab

    Check what dependencies the print spooler has, if any

       you may need to click on "+" on those dependencies to more dependencies

    Go back to the Services list

    On each of the spooler dependencies, double click on it

    Make sure it is set to Automatic in the Startup Type drop down menu

    Now click on Start to start the service

    Click OK

     

    Now try and print

    if you still get spooler error messages, try this

     

    Open a Command Prompt window, found in your Start (Orb) at bottom left, and it is in the list that pops up

     

    key the command;
           sc config spooler depend= RPCSS
        (note the space after the = but not before)

    restart the print spooler 

     

     

    Hope that works, re post after you have done the above and let me know if it worked!

    Wednesday, March 05, 2008 3:18 AM
  • still get 1068 error

     

    Wednesday, March 05, 2008 3:21 AM
  • tried the above and still got 1068 error

    Wednesday, March 05, 2008 3:24 AM
  •  bmr6794 wrote:

     

    ok well i tried that camand prompt and the my computer one and it still wont work there is no dependicies i am using windows vista home basic and i was wondering if there was something else i could do it worked when i had windows xp on the computer but i upgraded to windows vista and it would not work i have a lexmark x6170 and when i turn the computer on it detects it and it says print spooler not on or something like that. hope ypu can help me

     

    FIRST>> Follow the other instructions from Charlic ...down to turn on print spooler  try turning on again..

    Should it fail to print once you know it is turned on, We would recommend checking for updated drivers from Lexmark

    as you have indicated it worked while using XP OS.  Sounds as though you may also be experiencing an older printer

    which may not have drivers compatiability with Vista.

     

    George @ Custom Computers & Technology

    http://techbuyer.spaces.live.com

     

     

    Wednesday, March 05, 2008 4:40 AM
  •  Dkneesyho wrote:
    My Compaq Presario Notebook came with Vista Home Premium.  EVERY time the desk top opens and my wireless network is acquired, I get this message: Spooler SubSystem App has stopped working.  When I attempt to start it in Services, the Start window opens and the green bar begins to fill then the start aborts.  At you suggestion, I checked and found that the Dependencies were set at Automatic.  When I tried to access the Command Prompt, it did not appear in the Start inquiries box.  In this condition, the computer will not allow me to even begin the process of installing a printer.  Any ideas you might have to remedy this problem would be greatly appreciated.

    Of note: NO OTHER Services can be changed so I think there might be an access problem.

     

    TO Change Services .....have you signed in as user or administrator???  HELP MENU should guide you to ADM sign on

    See Charlic14 post above for guidance relative to this issue....but also be aware some "older printers" had drivers that were not compatiable with Vista OS.  Not knowing what printer you have...I recommend checking manufacturers website for updated drivers as well.

     

    George @ Custom Computers & Technology

    http://techbuyer.spaces.live.com

     

     

    Wednesday, March 05, 2008 4:51 AM
  • interesting solutions, i will be testing after i went over to my customers office. The printer sub system won't start because when the users print to HP laserjet 1022n. The documents somehow causes the crush on the printer spooler. i have no idea why it happen but I am aware that possible it is badly build Vista drivers from HP and the only usb drivers for vista (no network drivers). i will tried this trick if it might help. Im going to check back on this thread.
    Thursday, March 06, 2008 3:00 AM
  • Have tried the dependencies without success and receive a OpenService Failed 5: Access is denied. on the command promp .   I've tried everything, is there a solution ??
    Thursday, March 06, 2008 7:38 PM
  • i would like to say a big thank you for solving the issue on print spool as i have been trying to get minre started for over a week but the comand worked ,very good  thank you,,,bob

    Friday, March 07, 2008 11:14 AM
  • TRY THIS:  to get your Command Prompt, try Click Start, Run, type in CMD, then OK.

    You will have to go in as Administrator. 

     

    Let me know if that helps

     

    Saturday, March 08, 2008 11:05 PM
  •  

    Thanks It worked great.  I have been working on this for 10 hours over two days.  I even took it to the geek squad with no help.  Thank you!!!!!

    B

    Sunday, March 23, 2008 3:33 AM
  •  

    If the previous resolutions don't work:

    Make sure you do not have any jobs in the print que folder in the system folder.

    C:\WINDOWS\system32\spool\PRINTERS  (this is for WinXP, substitute WINNT for WINDOWS for a WinNT system, Im not crazy about Vista, so your on your own if you have Vista, but it should be the same as WinXP.) 

     

    After deleting all the files in this folder try to restart the spooler service.

     

    Good Luck!!

    Thursday, April 03, 2008 3:20 PM
  • WHAT a blessing! THANK YOU! DAYS of searching finally led me to this site and THE solution!

    Sunday, April 20, 2008 12:43 AM
  • I tried all the above methods and I still get error 1068 when I try to restert the print spooler,when I double click on the dependencies nothing happens,what am I doing wrong?

     

    Wednesday, May 14, 2008 6:54 PM
  • Solved

     

    we had a lot of problem  with this   and spend days trying to solve it  Finally we came to the conclusion that  adope   Universall Postcript driver  and our  HP1022   had an issue with  window vista  and printing pdf files.

     

    we had to delete the outstanding  print job

    disconnect the printer  

    refresh all printer settings   and printer drivers

    restart the  printer spooler

    reconnect the printer

     

    this solved  our printing problems  with normal documents

    to enable  the  printing of pdf files   we had to uninstall  the Adope  program   and installed another 

    alternative  pdf reader.

     

    This solved our problem     There must be a  big bug in the adope program  or the HP driver. This error only occurs with Vista  not  with XP   and only with our hp printers

     

     

     

    Saturday, May 17, 2008 11:28 AM
  • I tried to do the command prompt by keep getting access is denied.  Suggestions?

     

    Thanks.

     

    NJ

     

    Sunday, June 22, 2008 6:15 PM
  • I still get the error message after restarting the print spooler. 

     

    I tried the command...and I get an access is denied message.  I am the administrator.

     

    What's next?  I can't print anything anymore. 

    Tuesday, July 08, 2008 12:31 AM
  • I had this same problem with an HP1022 and trying to print with an adobe pdf, but on a WinXP Prof (SP3) machine.  I thought it was my computer.  Reformatted and reloaded everything with new drivers.  Still got error.  Went and purchased a new computer from HP, a Pavillion Notebook. Loaded up everything including Adobe Acrobat 8.0 Pro., HP Laserjet 1022 and an HP Officejet Pro L7650.  Everything was fine for 1 month.  Two days ago, got the old "Spooler Subsystem App Error" and lost all printers.  Have been on phone with  HP for approximalety 7.5 hours last two days to fix problem.  Notebook tech support thinks its the printer, printer tech support thinks its OS software (MS Vista Home Premium).  I finally decided to see if I could get the 7650 to print the adobe pdf.  It printed.  Then I tried the HP1022 and it gave me the error again and knocked out the 7650 also.  Went and cleared the que, restarted the print spooler, stopped the print spooler then restarted it, then retried to print the pdf with the 7650 and it worked.   I have come to the conclusion that it is the HP 1022 software update, Windows XP SP3 and Windows Vista.  I have decided to not use the HP 1022 anymore, so I guess HP will get some more of my money and I will purchase a Vista certified laserjet printer.  This has been very frustrating and reading everything from tech notes to blogs, it looks like it may be happening to other printer manufacturers also.  I am a faithful HP printer user and have never come across so many problems with compatibility as i have since using Win XP SP3 and Vista.

    Thursday, July 10, 2008 3:36 AM
  •  Bwonder wrote:

    I still get the error message after restarting the print spooler. 

     

    I tried the command...and I get an access is denied message.  I am the administrator.

     

    What's next?  I can't print anything anymore. 

     

    OK guys and gals, if you are running Vista... You must run the command line mentioned previously as an administrator. This fix does work! Rightclick your command shortcut or the actual command file in your windows folder, and then click run as administrator. Now type the command. Good Luck with that, and I'll look back in on the forums later.

    Friday, August 08, 2008 2:43 AM
  • I have the same printer, but it is with XP. When I try to install my Lexmark printer, it says "PRINT SPOOLER HAS STOPPED"  and it can't find "LEXBCES.EXE. Once I find this item I will let you know if it works.

     

    Friday, August 15, 2008 9:40 PM
  • your suggestions were very helpful to others

    i was wondering if you could help my issue

     

    i bought a new computer with vista on it

    and tried to install a lexmark all in one printer model # x5450

    every time i try to in stall it say drivers need installed

    but on top of that im getting window could not start print spooler

    on local computer.  Error 1075 the dependancy servies don't exist or

    has been marked for deletion.

     

    Thanks, Charlie

     

    Friday, August 29, 2008 9:19 PM
  • I will attempt to assist you since you have not recieved a reply.

     

    First I would advise you to run your install disc for the Lexmark Printer.

    If not available, Go to Lexmark website and locate newest drivers file for your model and download / install.

     

    Once complete it will then be necessary to follow the instructions from above in this thread to solve your "print spooler issue"

    [Copied Here] 

     

     charlc14 wrote:

    Right click on My Computer

    Select Manage

    Double click on Services and Application

    Double click on Services

    Scroll down to Print Spooler and double click on it

    Click on Dependencies tab

    Check what dependencies the print spooler has, if any

       you may need to click on "+" on those dependencies to more dependencies

    Go back to the Services list

    On each of the spooler dependencies, double click on it

    Make sure it is set to Automatic in the Startup Type drop down menu

    Now click on Start to start the service

    Click OK

     

    Now try and print ... if you still get spooler error messages, try this

     

    Open a Command Prompt window, found in your Start (Orb) at bottom left, and it is in the list that pops up

     

    key the command;
           sc config spooler depend= RPCSS
        (note the space after the = but not before)

    restart the print spooler 

     

     

    Hope that works, re post after you have done the above and let me know if it worked!

     

     

     

    Saturday, August 30, 2008 11:12 PM
  • Thanks for the solution, it was promising but it isn't working for me.  I have Vista Enterprise and Print Spooler dies soon after login. 

     

    Spooler dependencies are HTTP Remote Procedure Call then DCOM Server Process Launcher.  These are set to Automatic and are grayed out, so I can't change them.  So I ran sc config spooler depend= RPCSS and restarted the Print Spooler.  No change in behavior.  I'll try it in Safe Mode and see what happens.

     

    Friday, November 14, 2008 10:23 PM
  • Charlc, worked like a charm. I can print now. Wonder why Vista ships with a manual start print spooler? Anyway it's working.

    Thank-you 
    Monday, April 13, 2009 1:32 PM
  • Tnx a lot malrc14... We love you... hehehe
    Saturday, April 18, 2009 2:03 AM
  • Thank you so much.  That was the trick!
    Wednesday, May 06, 2009 2:36 PM
  • I tried this but get and Access Denied message.  where do i go from here?
    Wednesday, November 04, 2009 8:56 PM
  • OMG Thanks Bunches!!! Worked like a charm!!!
    Thursday, November 05, 2009 5:44 PM
  • Thanks so much for your posting as it has solved my spooling problem after many hours of investigation and frustrations!
    • Proposed as answer by Andrea0859 Tuesday, July 06, 2010 1:28 AM
    Sunday, December 20, 2009 2:10 PM
  • It says i dont have rights to this. huh?
    Monday, January 25, 2010 12:32 AM
  • charlc14, your second method worked like a charm.

    Thanks so much! (:
    Wednesday, February 03, 2010 1:05 AM
  • I've tried both set of instructions. I have windows 7 and I still get the error msg saying I need to "find a printer" I click and it does not show any printer.

    Thanks!

    Tuesday, March 16, 2010 5:49 AM
  • still not working
    Saturday, May 29, 2010 9:31 AM
  • Hi slb875,

    HP Photosmart 2575 Driver All-in-One Printer Windows Vista Software

    Good luck

    Monday, May 31, 2010 8:10 PM
  • Should the result be instant after typing in the command at the command prompt.  How long should I wait?  My Administrator Command Prompt window says:

    • Microsoft Windows [Version 6.1.7600]
    • Copyright (c) 2009 Microsoft Corporation.  All rights reserved
    • C:\Windows\system32>cd\
    • C:>sc config spooler depend= RPCSS
    • (Blinking Cursor)

    Checked services for Print Spooler and it hasn't started.  I have chedked all the dependensies for the Print Spooler, and they are all running (Automatic Startup).

    I have a Dell Latitude E6400, Intel Core 2 Duo P8400 @ 2.26GHz, 3.00GB Ram, Windows 7 Professional 32bit.

    This computer came with Microsoft Vista Professional 32bit installed.  It developed the same Print Spooler issues.  I have since Reformatted the computer and installed Windows 7 Professional 32bit.  The Print Spooler issues are back. 

    I know I can't be crazy, but I'm starting to think how did the Print Spooler issue no go away when the new operating system was installed.

    Could it be some sort of hardware issue?  or Some sort of software or Office 2007 SP2 issue that is stoping the Print Spooler?

     

    Thursday, July 01, 2010 3:03 PM
  • charlc14.

    Got to hand it to you. Your directions were perfect.They worked like magic..Thank you.

    Wednesday, August 25, 2010 2:04 AM
  • Wednesday, September 15, 2010 4:53 AM
  • thank you for this!
    Tuesday, October 19, 2010 9:37 AM