none
Why doesn't Windows 7 Professional display asian characters?

    Question

  • In Windows 7 Professional, neither of the internet browsers (newest IE, Firefox, Opera) can correctly display asian characters (of course I tried changing the character encoding in the browsers's display menu but it is useless). While Korean characters are displayed correctly, instead of Chinese (and some Japanese) characters I got only squares (in Firefox there are also numbers in the squares).
    I don't want to change the system language, I'd just like to be able to view the characters correctly if I visit an East Asian site.
    What can be the solution? Please help me!
    Monday, January 25, 2010 8:43 PM

Answers

  • OK, thanks for your answers but:

    Magon_67: I can only repeat myself. I don't want to change the interface language of Windows 7 by installing a language pack, I don't want menus or anything to be in Chinese (I don't speak it anyway). I'd just like to be able to view those characters correctly if a web page or anything happens to have some.

    And as I've already written: I tried to change internet browsers' character encoding options, but believe me, neither set to auto, nor to anything else, neither of my browsers works correctly.

    Update: I've found the solution. For some reason there weren't any Chinese fonts in the Windows/Fonts folder. I downloaded and put one in, now my browsers display asian characters correctly.

    Thank you all for your helping efforts!
    • Marked as answer by jer85 Wednesday, January 27, 2010 8:52 PM
    Wednesday, January 27, 2010 8:51 PM

All replies

  • Hi,

    When does this issue happen? Did you upgrade windows xp\windows vista to windows 7?

    As Windows Vista and Windows 7 include support for East Asian characters in the standard installation, it should have worked. However, the procedure explained on Microsoft's support page does not work in 7 for the Japanese font set, as it did with Vista.

    You may need to install files for East Asian Languages through windows update.

    Go to Control Panel\Clock, Language, and Region\Region and Language\install or uninstall display launguages, windows will check for updates, it is recommended to install all those updates to obtain a stable performance.

    • Proposed as answer by U-KNOW Monday, January 23, 2012 7:47 AM
    • Unproposed as answer by U-KNOW Monday, January 23, 2012 7:47 AM
    Tuesday, January 26, 2010 8:36 AM
  • Sounds like the web pages are not correctly flagging the language ID. Could you please post some URLs so I can look to see what is the problem. I have seen problems with Russian as well as Japanese, Chinese and Thai pages that lacked meta tags.



    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site
    • Proposed as answer by Vegan FanaticMVP Tuesday, January 26, 2010 4:08 PM
    • Unproposed as answer by jer85 Tuesday, January 26, 2010 9:33 PM
    Tuesday, January 26, 2010 4:08 PM
  • For me any web pages containing Chinese characters are faulty: let's see for example China's name in its own language at
    http://en.wikipedia.org/wiki/People%27s_Republic_of_China
    I don't think it would be any helpul to try to find the mistake in web pages, as the problem is definitely with my computer.

    I used formerly Windows XP, I bought a new computer and Windows 7 is my first operating system on it (but it has been reinstalled several times).

    "When does this issue happen?" :) Always, it's not an occassional thing.

    In Windows 7 Professional there is no option under Region and Language to install display languages, just input languages. Anyway, as I said I don't want to change the system language to an East Asian language, I'd just like to be able to view properly those characters if a web page contains some.

    In Windows XP it worked pretty simply and well to install East Asian language support, it's a shame that it's so messed up In Windows 7, at least in my case.
    Tuesday, January 26, 2010 9:33 PM
  • The Language Packs are only supported in Windows 7 Ultimate and Windows 7 Enterprise.They will be listed in the Windows Update screen.  If you do not have Windows 7 Ultimate you can't use the Language packs.

    You may follow this procedure to download and install a Windows 7 language pack:

         1.    Start Microsoft Update. To do this, click Start, type Microsoft Update in the Start Search box, and then click Microsoft Update in the Programs list.Collapse this imageExpand th

          2.    Click the optional update links for the language packs.

          3.    Under the Windows 7 Language Packs category, select the desired language pack.

    Note If you install many additional language packs, the disk space and system performance are affected. In particular, disk space and system performance are affected during servicing operations, such as Service Pack installations. Therefore, we recommend that you only add a language pack to your computer if you will use the language pack.

          4.    Click OK, and then click Install updates to start the download and installation process.

           For more information on how to install language pack, please refer to the article below:
           http://support.microsoft.com/kb/972813

    Wednesday, January 27, 2010 10:09 AM
  • For me any web pages containing Chinese characters are faulty: let's see for example China's name in its own language at
    http://en.wikipedia.org/wiki/People%27s_Republic_of_China
    I don't think it would be any helpul to try to find the mistake in web pages, as the problem is definitely with my computer.

    I used formerly Windows XP, I bought a new computer and Windows 7 is my first operating system on it (but it has been reinstalled several times).

    "When does this issue happen?" :) Always, it's not an occassional thing.

    In Windows 7 Professional there is no option under Region and Language to install display languages, just input languages. Anyway, as I said I don't want to change the system language to an East Asian language, I'd just like to be able to view properly those characters if a web page contains some.

    In Windows XP it worked pretty simply and well to install East Asian language support, it's a shame that it's so messed up In Windows 7, at least in my case.

    OK looks like your brower is not accessing the UNICODE fonts. Haev you have changed any of the fonts in use? It should be set to auto.

    If that does not help, click on start, and in the search box type

    sfc /scannow

    Then reset IE to defaults.




    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site
    • Proposed as answer by Vegan FanaticMVP Wednesday, January 27, 2010 1:57 PM
    • Unproposed as answer by jer85 Wednesday, January 27, 2010 8:19 PM
    Wednesday, January 27, 2010 1:57 PM
  • Vegan is right. To "install display languages" is quite another thing than to enable your browser to display the right characters for language specific letters/symbols. The first refers to the ability to change your system appearance (menus, descriptions...) to your preferred language, the latter is simply a browser setting (see "Page" -> "Encoding" on IE menu bar) that should be set to "Unicode (UTF-8)" by default. I never changed those default settings and can see all Chinese (simplified, traditional) characters on your quoted page without problems. Thus, there is no need to "install East Asian language support" and nothing that could be messed up in Windows 7, compared with XP.

    Edit: As I see that you already followed most of the suggestions, the only remaining thing I can think of is that's something messy with your Windows\Fonts and/or Windows\IME folder. All needed characters and their usage instructions should be stored there, and you don't have to install anything supplementary like on XP where eastern fonts and IME settings were not implemented from start on.  
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (50G),D:WIN7 (30G),F:DATA (250G)
    Wednesday, January 27, 2010 2:44 PM
  • OK, thanks for your answers but:

    Magon_67: I can only repeat myself. I don't want to change the interface language of Windows 7 by installing a language pack, I don't want menus or anything to be in Chinese (I don't speak it anyway). I'd just like to be able to view those characters correctly if a web page or anything happens to have some.

    And as I've already written: I tried to change internet browsers' character encoding options, but believe me, neither set to auto, nor to anything else, neither of my browsers works correctly.

    Update: I've found the solution. For some reason there weren't any Chinese fonts in the Windows/Fonts folder. I downloaded and put one in, now my browsers display asian characters correctly.

    Thank you all for your helping efforts!
    • Marked as answer by jer85 Wednesday, January 27, 2010 8:52 PM
    Wednesday, January 27, 2010 8:51 PM
  • I didn't have that problem, but I've got a similar one.

    A good page to check if it's as it should be on the internet browser: http://en.wikipedia.org/wiki/Help:Multilingual_support_%28East_Asian%29

     

    I've having a problem just in displaying East Asian characters in Windows itself.

    I'm in the same situation as jer85 was/is, as I don't understand the characters, but I do like to see them instead of, for example, «É¢É±;», which I believe no Asian could read either. Would the East Asian pack help even if not selected as display language? Or is there any other solution? This problem used to be easily solved through Region and Language settings, as it always had the option to install East Asian characters in any Windows version.

    I can't understand why Microsoft took it off for Win7... How can't it be solved? Or is Microsoft going to fix this giant issue?

     

    Thanks in advance.

    Friday, March 18, 2011 10:33 AM
  • Control panal -> region & language -> tab "Administrative" -> "Change system locale" select "Japanese" and reboot.
    Thursday, July 12, 2012 9:54 AM
  • This is probably super extremely late, but i had this same exact issue. I deleted the font cache (windows\system32\Fntcache.dat) and restarted. The system recognized japanese again after that.
    Thursday, September 27, 2012 6:46 AM
  • In Windows XP to display Asian languages all we had to do was click the check box to add Asian Support and "Bam" all the fonts were installed. Simple.

    In Windows 7 this option has been removed and it seems nobody on their tech support seems to know or care about having the ability to display Asian languages. I did a lot of Googling, and all that kept coming up was that you needed to install the language packs which is only available in the Enterprise or Ultimate editions, but this also changes the windows UI, which is not what we want, we only want FONT SUPPORT! Plus it eats up a lot of disk space and possibly memory.

    Anyway after some trial and error I found an easy solution.

    To add fonts support for a particular language all you need to do is change your region settings system locale into that language and reboot.
    You should now be able to see the characters correctly. The nice consequence of this is that when you change your region settings back to English and reboot you can now still see the characters correctly. This process of changing the system locale probably installs or enables the fonts for that language.

    Its a bit tedious to have to do this for every language you want to display, if like me you work for a localisation company and you need to work with many different languages, but at least its a simple solution that works.

    I just wish this was documented somewhere or that Windows Dev didn't remove the XP option to add Asian language support, which was a much simpler process.

    Cheers,
    Anthony.

    Tuesday, February 19, 2013 3:02 PM